Bug 76605 - Patch to fix minor reporting bug in loader.c
Patch to fix minor reporting bug in loader.c
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-23 21:50 EDT by Damian Ivereigh
Modified: 2007-04-18 12:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-25 10:50:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix the above bug (570 bytes, patch)
2002-10-23 21:51 EDT, Damian Ivereigh
no flags Details | Diff

  None (edit)
Description Damian Ivereigh 2002-10-23 21:50:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020916

Description of problem:
in loader/loader.c line 467, the log_message prints an size_t type as an int and
thus messes up the parameter stack. This patch fixes it. I have also added the
reporting of whether the copy succeeded or not.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
It is not easy to see, since the error would only come up if the downloading of
netstg2.img failed half-way through. Which it was for me since my ramdisk was
too small. However if that error had been reported properly it would have saved
me a bunch of time!



Additional info:
Comment 1 Damian Ivereigh 2002-10-23 21:51:30 EDT
Created attachment 81846 [details]
Patch to fix the above bug
Comment 2 Michael Fulbright 2002-10-24 14:50:03 EDT
Thanks!
Comment 3 Jeremy Katz 2002-10-25 17:29:26 EDT
Committed slight variation
Comment 4 Michael Fulbright 2002-12-20 12:38:25 EST
Time tracking values updated
Comment 5 Brent Fox 2003-05-25 10:50:43 EDT
I'm going through Bugzilla closing some bugs that have been marked as Modified
for some period of time.  I believe that most of these issues have been fixed,
so I'm resolving these bugs as Rawhide.  If the bug you are seeing still exists,
please reopen this report and mark it as Reopened.

Note You need to log in before you can comment on or make changes to this bug.