Bug 766234 - [abrt] ibus-1.4.0-11.fc16: __GI_raise: Process /usr/bin/ibus-daemon was killed by signal 6 (SIGABRT)
[abrt] ibus-1.4.0-11.fc16: __GI_raise: Process /usr/bin/ibus-daemon was kille...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
abrt_hash:f0714f418604fec71f29b8a008a...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-10 23:30 EST by gcarter
Modified: 2011-12-30 00:55 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-30 00:55:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: smolt_data (4.02 KB, text/plain)
2011-12-10 23:30 EST, gcarter
no flags Details
File: backtrace (16.09 KB, text/plain)
2011-12-10 23:30 EST, gcarter
no flags Details
File: maps (8.20 KB, text/plain)
2011-12-10 23:30 EST, gcarter
no flags Details

  None (edit)
Description gcarter 2011-12-10 23:30:20 EST
libreport version: 2.0.7
abrt_version:   2.0.6
backtrace_rating: 4
cmdline:        /usr/bin/ibus-daemon -r --xim
comment:        Came out of a screen saver and ibus crashed.
crash_function: __GI_raise
executable:     /usr/bin/ibus-daemon
kernel:         3.2.0-rc5
pid:            2134
pwd:            /tmp
reason:         Process /usr/bin/ibus-daemon was killed by signal 6 (SIGABRT)
time:           Sat 10 Dec 2011 10:24:17 PM CST
uid:            1000
username:       gcarter
var_log_messages: Dec 10 22:24:17 kali abrt[4221]: Saved core dump of pid 2134 (/usr/bin/ibus-daemon) to /var/spool/abrt/ccpp-2011-12-10-22:24:17-2134 (44257280 bytes)

backtrace:      Text file, 16479 bytes
maps:           Text file, 8396 bytes
smolt_data:     Text file, 4114 bytes

dso_list:
:/lib64/libdl-2.14.90.so glibc-2.14.90-21.x86_64 (Fedora Project) 1323569333
:/lib64/libpthread-2.14.90.so glibc-2.14.90-21.x86_64 (Fedora Project) 1323569333
:/lib64/libgthread-2.0.so.0.3000.1 glib2-2.30.1-1.fc16.x86_64 (Fedora Project) 1321009479
:/usr/lib/locale/locale-archive glibc-common-2.14.90-21.x86_64 (Fedora Project) 1323569330
:/usr/lib64/libibus-1.0.so.0.400.0 ibus-libs-1.4.0-11.fc16.x86_64 (Fedora Project) 1322613902
:/lib64/libresolv-2.14.90.so glibc-2.14.90-21.x86_64 (Fedora Project) 1323569333
:/lib64/libglib-2.0.so.0.3000.1 glib2-2.30.1-1.fc16.x86_64 (Fedora Project) 1321009479
:/lib64/libgobject-2.0.so.0.3000.1 glib2-2.30.1-1.fc16.x86_64 (Fedora Project) 1321009479
:/lib64/librt-2.14.90.so glibc-2.14.90-21.x86_64 (Fedora Project) 1323569333
:/lib64/libgmodule-2.0.so.0.3000.1 glib2-2.30.1-1.fc16.x86_64 (Fedora Project) 1321009479
:/usr/lib64/libffi.so.5.0.10 libffi-3.0.10-1.fc16.x86_64 (Fedora Project) 1321009477
:/lib64/libgio-2.0.so.0.3000.1 glib2-2.30.1-1.fc16.x86_64 (Fedora Project) 1321009479
:/usr/bin/ibus-daemon ibus-1.4.0-11.fc16.x86_64 (Fedora Project) 1322613904
:/lib64/libselinux.so.1 libselinux-2.1.6-5.fc16.x86_64 (Fedora Project) 1323569334
:/lib64/libz.so.1.2.5 zlib-1.2.5-5.fc16.x86_64 (Fedora Project) 1321392970
:/lib64/libc-2.14.90.so glibc-2.14.90-21.x86_64 (Fedora Project) 1323569333
:/lib64/ld-2.14.90.so glibc-2.14.90-21.x86_64 (Fedora Project) 1323569333
:/lib64/libnss_files-2.14.90.so glibc-2.14.90-21.x86_64 (Fedora Project) 1323569333

environ:
:SHELL=/bin/bash
:DBUS_STARTER_ADDRESS=unix:abstract=/tmp/dbus-OwgF6nAnQA,guid=115e693b80ee256e798f56d800000013
:XDM_MANAGED=method=classic
:XDG_SESSION_COOKIE=654f1b866a2da2c0535215310000000c-1323569536.910613-1269186674
:XDG_RUNTIME_DIR=/run/user/gcarter
:DISPLAY=:0
:DESKTOP_SESSION=kde-plasma
:WINDOWPATH=1
:PATH=/usr/local/bin:/usr/bin:/bin:/usr/games
:XDG_VTNR=1
:DM_CONTROL=/var/run/xdmctl
:XDG_SESSION_ID=1
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-OwgF6nAnQA,guid=115e693b80ee256e798f56d800000013
:XDG_SEAT=seat0
:XAUTHORITY=/var/run/kdm/.Xauthw5esIa
:USER=gcarter
:DBUS_STARTER_BUS_TYPE=session
:GNOME_KEYRING_PID=1276
:SHLVL=1
:PWD=/home/gcarter
:GNOME_KEYRING_CONTROL=/tmp/keyring-C50Kce
:LANG=en_US.UTF-8
:_=/usr/bin/dbus-launch
:LOGNAME=gcarter
:HOME=/home/gcarter
:LC_CTYPE=en_US.UTF-8
:GTK_IM_MODULE=ibus
:QT_IM_MODULE=ibus
:XMODIFIERS=@im=ibus
Comment 1 gcarter 2011-12-10 23:30:30 EST
Created attachment 545138 [details]
File: smolt_data
Comment 2 gcarter 2011-12-10 23:30:35 EST
Created attachment 545139 [details]
File: backtrace
Comment 3 gcarter 2011-12-10 23:30:36 EST
Created attachment 545140 [details]
File: maps
Comment 4 fujiwara 2011-12-30 00:35:08 EST
I cannot reproduce your problem.
Do you still reproduce your error?


(In reply to comment #2)
> Created attachment 545139 [details]
> File: backtrace

#0  0x00007fdc4b75d285 in __GI_raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
        resultvar = 0
        pid = <optimized out>
        selftid = 2156
#1  0x00007fdc4b75eb9b in __GI_abort () at abort.c:91
        save_stage = 2
        act = {__sigaction_handler = {sa_handler = 0, sa_sigaction = 0}, sa_mask = {__val = {258294023922, 140584135351368, 140584145514496, 4294967296, 32, 16442016, 16442016, 4294967295, 140583607880192, 140583607802128, 140583607802128, 258296897592, 0, 140583742009600, 1, 0}}, sa_flags = 1274082820, sa_restorer = 0x5}
        sigs = {__val = {32, 0 <repeats 15 times>}}
#2  0x0000003c238683cd in g_assertion_message (domain=<optimized out>, file=<optimized out>, line=<optimized out>, func=0x41fa20 "bus_dbus_impl_dispatch_message_by_rule", message=0x7fdc2c00bc30 "assertion failed: (skip_connection == NULL || BUS_IS_CONNECTION (skip_connection))") at gtestutils.c:1425
        lstr = "1891\000\177\000\000P\027\253B\334\177\000\000\001\000\000\000\000\000\000\000\270\352A\000\000\000\000"
        s = 0x7fdc2c011910 "\360I\002,\334\177"
#3  0x0000003c238688f2 in g_assertion_message_expr (domain=0x41d907 "IBUS", file=0x41e6e3 "dbusimpl.c", line=1891, func=0x41fa20 "bus_dbus_impl_dispatch_message_by_rule", expr=<optimized out>) at gtestutils.c:1436
        s = <optimized out>
#4  0x000000000040abd1 in bus_dbus_impl_dispatch_message_by_rule (dbus=0xf74010 [BusDBusImpl], message=0x7fdc2c004800 [GDBusMessage], skip_connection=0x7fdc2c01e300) at dbusimpl.c:1891
        __PRETTY_FUNCTION__ = "bus_dbus_impl_dispatch_message_by_rule"
        dispatched_quark = 254
        is_running = <optimized out>
#5  0x000000000040af44 in bus_dbus_impl_connection_filter_cb (dbus_connection=<optimized out>, message=0x7fdc2c004800 [GDBusMessage], incoming=<optimized out>, user_data=0xf74010) at dbusimpl.c:1569
        __PRETTY_FUNCTION__ = "bus_dbus_impl_connection_filter_cb"
        dbus = 0xf74010 [BusDBusImpl]
        connection = 0x7fdc2c01e300
#6  0x0000003c2bca9d74 in on_worker_message_about_to_be_sent (worker=<optimized out>, message=0x7fdc38001450, user_data=0x7fdc3400f100) at gdbusconnection.c:2201
        connection = 0x7fdc3400f100 [GDBusConnection]
        filters = 0x7fdc2c0218d0
        num_filters = 1
        n = <optimized out>
        alive = <optimized out>
#7  0x0000003c2bcbfead in _g_dbus_worker_emit_message_about_to_be_sent (message=0x7fdc38001450, worker=0x7fdc34000d50) at gdbusprivate.c:494
        ret = <optimized out>
#8  maybe_write_next_message (worker=0x7fdc34000d50) at gdbusprivate.c:1412
        old_message = 0x7fdc38001450
        new_blob = <optimized out>
        new_blob_size = <optimized out>
        error = <optimized out>
        data = 0x107a8a0
        __PRETTY_FUNCTION__ = "maybe_write_next_message"
Comment 5 gcarter 2011-12-30 00:54:39 EST
It would seem the ibus issues have been resolved.

Except for the minor detail of the ibus intelligent agent app, which I guess doesn't put its Icon in the tray during KDE startup because it is launched too soon from what I have been reading.

(Fedora 15 it worked OK.)

Note You need to log in before you can comment on or make changes to this bug.