Bug 766263 - hedgewars-0.9.17 is available
Summary: hedgewars-0.9.17 is available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: hedgewars
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Hans de Goede
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 770982 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-12-11 11:20 UTC by Upstream Release Monitoring
Modified: 2012-11-26 04:19 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-11-26 04:19:58 UTC


Attachments (Terms of Use)

Description Upstream Release Monitoring 2011-12-11 11:20:30 UTC
Latest upstream release: 0.9.17
Current version in Fedora Rawhide: 0.9.15
URL: http://download.gna.org/hedgewars/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring

Comment 1 Bruno Wolff III 2011-12-11 16:50:19 UTC
Note that with 0.9.16 (and still in 0.9.17) the hedgewars server uses Text.Show.ByteString which is currently not in Fedora. Either that needs to get added or the code that uses it modified to get 0.9.17 to build.

Comment 2 Bruno Wolff III 2011-12-30 18:11:04 UTC
*** Bug 770982 has been marked as a duplicate of this bug. ***

Comment 3 Kevin Fenzi 2011-12-31 18:38:53 UTC
From someone on irc who was unwilling to register for a bugzilla account: 

Some other options: 

1) Fedora could stop shipping the server, and let people use the official servers. 

2) Ubunutu has apparently backported things to 0.9.15. See: 
https://bugs.launchpad.net/debian/+source/hedgewars/+bug/852603

Comment 4 Bruno Wolff III 2011-12-31 19:07:00 UTC
That's not what they have done. They have a patch to the server that eliminates the need for the extra haskel package. However, that's really what we want. I'll take a look at it tomorrow or Monday. If the patch applies fairly cleanly and works (which is what I expect), then I should be able to get a new build out.
Since network play is currently broken, I think this justifies doing updates for F15 and F16.

Comment 5 Bruno Wolff III 2012-01-01 22:03:40 UTC
I have a rawhide build now. It still needs testing before I try to do test builds for F15 and F16.
http://koji.fedoraproject.org/koji/buildinfo?buildID=280602

Comment 6 Fedora Update System 2012-01-02 00:13:19 UTC
hedgewars-0.9.17-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/hedgewars-0.9.17-1.fc15

Comment 7 Fedora Update System 2012-01-02 00:14:17 UTC
hedgewars-0.9.17-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/hedgewars-0.9.17-1.fc16

Comment 8 Bruno Wolff III 2012-01-02 00:15:49 UTC
Feedback on whether either or both of thse work well for you would be nice. I don't play a lot of hedgewars and probably only going to notice very obvious issues.

Comment 9 Jens Petersen 2012-01-06 05:46:13 UTC
(In reply to comment #1)
> Note that with 0.9.16 (and still in 0.9.17) the hedgewars server uses
> Text.Show.ByteString which is currently not in Fedora. Either that needs to get
> added or the code that uses it modified to get 0.9.17 to build.

(I am happy to help review or get bytestring-show into Fedora if needed.:)

Comment 10 Fedora Update System 2012-01-21 21:52:04 UTC
hedgewars-0.9.17-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2012-01-21 21:52:41 UTC
hedgewars-0.9.17-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.