Bug 766998 - Duplicated packages between XFCE group and XFCE spin
Duplicated packages between XFCE group and XFCE spin
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: spin-kickstarts (Show other bugs)
16
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Jeroen van Meeuwen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-12 18:01 EST by Massimiliano
Modified: 2011-12-13 17:40 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-13 17:40:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch (against current release) attached (873 bytes, patch)
2011-12-13 17:22 EST, Massimiliano
no flags Details | Diff

  None (edit)
Description Massimiliano 2011-12-12 18:01:35 EST
Description of problem:
There are duplicated packages between the XFCE group and the %packages section of the XFCE spin kickstart file.

Version-Release number of selected component (if applicable):
$ rpm -q spin-kickstarts
spin-kickstarts-0.16.6-1.fc16.noarch

Steps to Reproduce:
$ yum groupinfo xfce-desktop | sort > xfce-desktop.txt
$ cat /usr/share/spin-kickstarts/fedora-livecd-xfce.ks | sort > fedora-livecd-xfce.txt
$ join --nocheck-order xfce-desktop.txt fedora-livecd-xfce.txt 
  
Actual results:
A list of 41 packages, some of them in the mandatory or default section of the xfce-desktop group.

Expected results:
No package that is in the mandatory or default section of the xfce-desktop group, because the group is already included in the %packages section of the .ks file.

Additional info:
Pruning of duplicated packages should simplify readability and customization of the official spin.
Comment 1 Kevin Fenzi 2011-12-12 22:53:25 EST
Sure, I'd be happy to clean this up, but it's not any kind of high priority. 

Can you provide a diff against the kickstart file? I'd be happy to look it over and commit it. 

http://git.fedorahosted.org/git/?p=spin-kickstarts.git
Comment 2 Massimiliano 2011-12-13 17:22:51 EST
Created attachment 546424 [details]
Patch (against current release) attached
Comment 3 Kevin Fenzi 2011-12-13 17:40:43 EST
Added in commit a960d02b90364746aab36e3e0c5f26ac92b4bc7e

Thanks!

Note You need to log in before you can comment on or make changes to this bug.