Bug 767125 - The version of xterm in Fedora is a little old.
The version of xterm in Fedora is a little old.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xterm (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-13 05:28 EST by Thomas E. Dickey
Modified: 2012-01-18 21:04 EST (History)
3 users (show)

See Also:
Fixed In Version: xterm-277-1.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-18 20:39:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Thomas E. Dickey 2011-12-13 05:28:14 EST
Description of problem:  The version of xterm in Fedora is a little old.


Version-Release number of selected component (if applicable):  271, according to http://oswatershed.org/pkg/xterm, which is from mid-July 2011.  In particular, #276 has workarounds for changes in Fedora packaging.


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:  the current patch level is #276 (October 10).


Additional info:
Comment 1 Thomas E. Dickey 2011-12-13 05:31:15 EST
By the way, I'm working on #277.  The only regression fixed in that is for a change last touched in #270 (before Fedora's current version), so #276 is at least as stable as #271 as far as I can tell.
Comment 2 Miroslav Lichvar 2011-12-13 05:58:33 EST
Fedora 16 has 271. but rawhide is at 276 since Oct 11. Not sure what exactly future on that web page means, but it might need an update.

This bug has version set to rawhide, but I assume you'd like to see it updated in F16 too?
Comment 3 Thomas E. Dickey 2011-12-13 06:36:58 EST
yes - that would address the problem as reported to me
Comment 4 Miroslav Lichvar 2011-12-13 06:47:13 EST
Ok, I'll wait for 277 and prepare an F16 update.
Comment 5 Thomas E. Dickey 2011-12-13 06:57:46 EST
ok - perhaps this week (I have 3-4 items on my to-do list)
Comment 6 Thomas E. Dickey 2011-12-31 09:57:22 EST
I'm still working on #277.  There were 2 items that I made no
progress on (both have existing workarounds), and in the
meantime I picked up 2 new Debian reports that I'm working on.

Debian #640464 sounds like a regression introduced by the
event-merging in #274, so I have to investigate that before
I'm done for #277.
Comment 7 Thomas E. Dickey 2012-01-08 09:59:49 EST
Debian #640464 turned out to not be xterm.  I spent the
intervening time doing regression builds, and released
#277 yesterday.
Comment 8 Fedora Update System 2012-01-09 09:21:45 EST
xterm-277-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/xterm-277-1.fc16
Comment 9 Fedora Update System 2012-01-11 00:57:39 EST
Package xterm-277-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xterm-277-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-0256/xterm-277-1.fc16
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2012-01-18 20:39:57 EST
xterm-277-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Thomas E. Dickey 2012-01-18 21:04:12 EST
I had a report here -

http://www.freebsd.org/cgi/query-pr.cgi?pr=164101&cat=

for which I put out #278 this evening.

Note You need to log in before you can comment on or make changes to this bug.