Bug 767710 - ant is too old
ant is too old
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ant (Show other bugs)
6.1
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Java maintainers
qe-baseos-tools
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-14 12:28 EST by Boris Folgmann
Modified: 2012-04-30 09:05 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-30 09:05:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Boris Folgmann 2011-12-14 12:28:45 EST
Description of problem:
ant was too old in RHEL 5 and is still too old in RHEL 6!
ant 1.7 copylibs doesn't support the "indexMetaInf" attribute which is required to develop software for the Google App Engine.

Version-Release number of selected component (if applicable):
ant-1.7.1-13.el6.x86_64

How reproducible:
Trying to start local GAE
  
Actual results:
copylibs doesn't support the "indexMetaInf" attribute

Expected results:
should start local GAE for testing

Additional info:
Please see http://netbeans.org/bugzilla/show_bug.cgi?id=198848
Comment 3 Suzanne Yeghiayan 2012-02-14 18:24:32 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 4 Stanislav Ochotnicky 2012-04-30 09:05:55 EDT
Since new release would break API/ABI compatibility (removal of several jars, for example ant-nodeps and ant-trax), it will not be possible to update it at all.  It might be possible to package additional version of ant, but current ant will not be updated.

If you have a support contract, make sure to make your request known to your support representative so we can properly evaluate interest in new addition.

Due to above reasons closing as won't fix.

Note You need to log in before you can comment on or make changes to this bug.