Bug 767987 - missing symlink for grub's menu.lst
missing symlink for grub's menu.lst
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: distribution (Show other bugs)
5.8
Unspecified Unspecified
high Severity medium
: rc
: ---
Assigned To: RHEL Product and Program Management
Jan Tluka
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-15 08:20 EST by Jan Tluka
Modified: 2013-12-09 07:52 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-09 07:52:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Tluka 2011-12-15 08:20:02 EST
Description of problem:

When I update /boot/grub/menu.lst to add some kernel parameters they won't apply during the next boot. After investigation I've found out that /boot/grub/menu.lst is not a symlink but rather an ordinary file and therefore the changes won't affect anything.

# ls -l /etc/grub.conf 
lrwxrwxrwx 1 root root 22 Dec 14 16:32 /etc/grub.conf -> ../boot/grub/grub.conf
# ls -l /boot/grub/menu.lst
-rw-r--r-- 1 root root 644 Dec 15 13:28 /boot/grub/menu.lst
# ls -l /boot/grub/grub.conf 
-rw------- 1 root root 619 Dec 14 16:32 /boot/grub/grub.conf

Version-Release number of selected component (if applicable):
tree RHEL5.8-Server-20111210.0

How reproducible:
Easily and 100%

Steps to Reproduce:
1. edit /boot/grub/menu.lst and add an kernel parameter in a kernel stanza
2. reboot to the kernel with changed parameters
3. cat /proc/cmdline (check that output matches the change)
  
Actual results:
Updates to menu.lst file does not change anything

Expected results:
Updates to menu.lst are honored during next boot.

Additional info:
Comment 1 RHEL Product and Program Management 2011-12-15 08:37:29 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 2 Jan Tluka 2011-12-16 05:15:38 EST
Reopening for inclusion in 5.8 since this is obviously a regression.
Comment 3 RHEL Product and Program Management 2011-12-16 05:17:35 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Note You need to log in before you can comment on or make changes to this bug.