Bug 7680 - localization in man distribution never gets into rpm
localization in man distribution never gets into rpm
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: man (Show other bugs)
6.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-12-08 09:39 EST by noa
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-03 08:35:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rpm with support (189.06 KB, application/octet-stream)
2000-08-09 06:30 EDT, Bernhard Rosenkraenzer
no flags Details
an updated buildroot patch (4.96 KB, patch)
2000-08-10 09:07 EDT, noa
no flags Details | Diff
updated src.rpm compared to the one included in redhat-7 (190.06 KB, application/octet-stream)
2000-10-03 08:35 EDT, noa
no flags Details

  None (edit)
Description noa 1999-12-08 09:39:18 EST
the man package as maintained by Andries Brouwer (aeb@cwi.nl)
is internationalized in a proper but somewhat old fasioned way,
but the catalog files are not included in the rpm distribution.
This can be so for two reasons, one is that redhat has some
problem with localized packages not using gettext (which is stupid)
and the other that the packager was bitten by a bug in the makemsg
distributed with glibc-2.1.x. A patch to work around the latter
problem along with explanation can be found at http://noa.tm/man.txt
Comment 1 Bernhard Rosenkraenzer 2000-08-08 12:10:49 EDT
Does the i18n support in man actually work for you? It doesn't work here (can't
find the message catalog files, even though they're just where they're supposed
to be).
Comment 2 noa 2000-08-09 06:28:28 EDT
yes, it works for me(tm). Please send over (or point me to) your src.rpm and I
will try to track down the problem
Comment 3 Bernhard Rosenkraenzer 2000-08-09 06:30:44 EDT
Created attachment 2254 [details]
rpm with support
Comment 4 noa 2000-08-10 09:07:28 EDT
Created attachment 2354 [details]
an updated buildroot patch
Comment 5 noa 2000-08-10 09:09:37 EDT
ok, i've found the problems.
1. the man-1.5h1-buildroot.patch breaks the Makefile not to install man
   (a fixed version called man-1.5h1-newbuildroot.patch is attached, the
changesare small but
    a difference in the patch arguments makes comparison difficult (what do you
use? i use 'diff -ur')
2. You also need to add /usr/share/locale to the %files list. 
   (note that the use of %{_mandir} breaks the .specfile on redhat-6.2 systems,
so i removed it)

--- man.spec	Wed Aug  9 12:34:26 2000
+++ man.spec.right	Thu Aug 10 15:01:31 2000
@@ -8,7 +8,7 @@
 Source1: makewhatis.cronweekly
 Source2: makewhatis.crondaily
 Patch1: man-1.5h1-confpath.patch
-Patch2: man-1.5h1-buildroot.patch
+Patch2: man-1.5h1-newbuildroot.patch
 Patch3: man-1.5-manconf.patch
 Patch4: man-1.5h1-make.patch
 Patch6: man-1.5g-security.patch
@@ -103,7 +103,8 @@
 /usr/bin/whatis
 /usr/sbin/makewhatis
 %config /etc/man.config
-%{_mandir}/*
+/usr/share/man/*
+/usr/share/locale/*
 /usr/bin/man2html
 
 %attr(0775,root,man)	%dir /var/cache/man
Comment 6 Bernhard Rosenkraenzer 2000-08-15 08:07:29 EDT
Still doesn't work for me.
First of all, man installs stuff to /usr/lib/locale; fixing that is simple of
course.
But after fixing it, the localization has no effect:

[root@bero SPECS]# LANG=de man asdasdad
No manual entry for sdasda

Even though "No manual entry for %s" is translated in the de locale.
Comment 7 noa 2000-10-03 08:33:16 EDT
i'm back from some time working with other things, and I have a working package
here now. I'm
attaching the whole src.rpm (tested on redhat-7) so hopefully you will get it to
work.
Comments on changes: man.spec
- including the new man-1.5h1-i18n.patch
- including '+lang all' in the arguments to ./configure
- removing -D_GNU_SOURCE (why is that anyway? it creates a conflicting
declaration of getline())
- adding /usr/share/locale/* to %files

man-1.5h1-i18n.patch:
things reverting earlier changes in the buildroot patch:
- uncommenting messages and gencat/gencat targets and 'cd msgs; make install' in
Makefile.in
new changes
- changing the default NLSPATH so that messagesfiles gets installed where they
will be found in /usr/share/locale
- adding $(PREFIX) to msgs/Makefile.in so that buildroot will work
- the patch to makemsg.c mentioned first in this bugreport
Comment 8 noa 2000-10-03 08:35:48 EDT
Created attachment 3658 [details]
updated src.rpm compared to the one included in redhat-7
Comment 9 Bernhard Rosenkraenzer 2000-10-04 06:45:44 EDT
Thanks, that did it.
I've added some more minor modifications to the spec (marking the i18n files as
such) and built it in rawhide (1.5h1-11).

Note You need to log in before you can comment on or make changes to this bug.