Bug 768021 - Changes to networking always clear the contents of resolv.conf
Changes to networking always clear the contents of resolv.conf
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: ovirt-node (Show other bugs)
5.7
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: Mike Burns
Virtualization Bugs
: TestOnly, ZStream
Depends On: 675325
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-15 09:38 EST by Chris Pelland
Modified: 2016-04-26 10:19 EDT (History)
18 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The /etc/resolv.conf file was being overwritten every time a change was made to networking. The statement PEERDNS="no" is now added to all interface configuration (ifcfg*) files created by the hypervisor. This prevents the incorrect overwriting of the resolv.conf file.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-11 10:25:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Pelland 2011-12-15 09:38:38 EST
This bug has been copied from bug #675325 and has been proposed
to be backported to 5.7 z-stream (EUS).
Comment 4 Mike Burns 2012-01-03 09:32:14 EST
Test only, no code change
Comment 6 Guohua Ouyang 2012-01-04 03:40:12 EST
Correct the verify steps as below, on build rhev-hypervisor-5.7-20120103.1:
1. on multi-nics machine, setup one nice and dns during install
2. after reboot, all other nics have "PEERDNS=no" in ifcfg-ethX.
3. add "BOOTPROTO=dhcp" in ifcfg-ethX and ifup them, /etc/resolv.conf is not changed.

the bug is verified.
Comment 7 Stephen Gordon 2012-01-10 08:59:16 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
When the hypervisor was installed on a machine with multiple Network Interface Cards (NICs), and only one NIC wass configured at install time, the resolv.conf file would be overwritten each time a change was made to networking. The statement PEERDNS="no" is now added to all interface configuration (ifcfg*) files created by the hypervisor. This prevents the incorrect overwriting of the resolv.conf file.
Comment 8 Mike Burns 2012-01-10 09:45:46 EST
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-When the hypervisor was installed on a machine with multiple Network Interface Cards (NICs), and only one NIC wass configured at install time, the resolv.conf file would be overwritten each time a change was made to networking. The statement PEERDNS="no" is now added to all interface configuration (ifcfg*) files created by the hypervisor. This prevents the incorrect overwriting of the resolv.conf file.+The /etc/resolv.conf file was being overwritten every time a change was made to networking.  The statement PEERDNS="no" is now added to all interface configuration (ifcfg*) files created by the hypervisor. This prevents the incorrect overwriting of the resolv.conf file.
Comment 9 errata-xmlrpc 2012-01-11 10:25:09 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0015.html

Note You need to log in before you can comment on or make changes to this bug.