Bug 768244 - RFE: Make Maven client friendlier when handling URLs
RFE: Make Maven client friendlier when handling URLs
Status: CLOSED UPSTREAM
Product: Zanata
Classification: Community
Component: Component-Maven, Usability (Show other bugs)
1.5-SNAPSHOT
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Michelle Kim
Zanata-QA Mailling List
: screened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-16 01:26 EST by Sean Flanigan
Modified: 2015-07-28 23:34 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-28 23:34:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sean Flanigan 2011-12-16 01:26:19 EST
1. The client should deal with extra/missing '/' at the end of the server URL.  (Output a warning.)

2. If no matching URL is found in zanata.ini, we should generate an informative log message, because the user will probably want to add the URL to zanata.ini.  (Omit the message if the url, username and password are all configured.)

3. In *some* cases (mainly testing), it might be useful to have an option which let the user choose one of the profiles in zanata.ini's [servers] section, by specifying the prefix.
 eg:

[servers]
jboss.url=example.com
jboss.username=example
jboss.key=12354123

mvn zanata:push -Dserver=jboss
Comment 1 Michelle Kim 2015-02-23 20:17:15 EST
Is this still an issue or fixed?
Comment 2 Sean Flanigan 2015-02-23 20:32:04 EST
It's not fixed.  I think making the Maven/Java clients friendlier is still important.
Comment 4 Damian Jansen 2015-07-13 20:21:43 EDT
Reassigned to PM
Comment 5 Zanata Migrator 2015-07-28 23:34:08 EDT
Migrated; check JIRA for bug status: http://zanata.atlassian.net/browse/ZNTA-325

Note You need to log in before you can comment on or make changes to this bug.