Bug 76828 - TrueType fonts not working with non-Xft2 apps
TrueType fonts not working with non-Xft2 apps
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2002-10-27 13:05 EST by Carlos Rodrigues
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-10-27 17:01:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Carlos Rodrigues 2002-10-27 13:05:23 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
With non-Xft2 apps (gimp, QT apps when anti-aliasing is disabled in qtconfig...)
I can't use truetype fonts even though xlsfonts shows them. In xfontsel they are
available on the list but when selected nothing appears.

How reproducible:

Steps to Reproduce:
1.Install some truetype fonts (I have them in /usr/share/fonts/default/TrueType)
2.Add that directory to /etc/X11/fs/config
3.service xfs stop
4.service xfs start
6.run xfontsel
7.select one of the installed truetype fonts

Actual Results:  Nothing appears on the font display section of xfontsel (it
isn't even redrawn as remains of the menus aren't cleared).

Expected Results:  It should display a preview of the selected font as it did in
Red Hat 7.3.
Comment 1 Carlos Rodrigues 2002-10-27 17:01:03 EST
If make a symlink for every truetype font in /usr/share/fonts/TrueType in
/usr/X11R6/lib/X11/fonts/TTF and remove /usr/share/fonts/TrueType from
/etc/X11/fs/config and restart xfs, I can now use truetype fonts normally.
I still think that this is a bug although there is a easy workaround, I should
be able to put the fonts in any directory that xfs could find.
Comment 2 Mike A. Harris 2002-11-01 01:20:24 EST
Your "workaround" is working around some misconfiguration or somesuch
rather than working around a bug.  Truetype fonts, when _properly_
installed and configured work just fine.

Unfortunately, I don't have the time to help people properly install
and configure fonts in bugzilla, which is a bug tracker and not a tech
support forum.  Please use the Red Hat mailing lists for help installing
and configuring ttf fonts properly.

Also read the Font HOWTO's which explain various common gotchas.
Comment 3 Carlos Rodrigues 2002-11-01 09:46:36 EST
As I said, ttf fonts are working properly now, both with Xft2 and old X font
system (of course I could have added /usr/X11R6/lib/X11/fonts/TTF to
/etc/fonts/fonts.conf). My point was that in RedHat 7.3 all it took was to add
/usr/share/fonts/default/TrueType to xfs's configuration (it was already there
in fact) an put the ttf's on that dir. In 8.0 altough xfs finds the fonts,
builds the fonts.dir and fonts.scale files for them, which appear fine when I
look at them, they can't be used in non Xft2 apps. Normal X font system knows
about the directory but can't find the ttf files. I wasn't asking for help on
how to install ttf fonts...

PS: My install of 8.0 wasn't an upgrade nor did I change xfs's configuration
more that just adding that directory at the end of the list.
Comment 4 Mike A. Harris 2002-11-01 17:39:11 EST
The 2 font systems, core server fonts via xfs font server, and the new
Xft client side fonts via Xft2/fontconfig, are completely and totally
independant.  There is _no_ way to install and configure fonts and have
them magically appear in both font infrastructures.  You _must_ configure
fonts twice in order for all applications to see them properly.

The configuration of server side fonts (using xfs) is 100% identical to
the way it always has been in Red Hat Linux.  This has not changed at
all in any way.  It very much _does_ work too.

Xft2/fontconfig client side fonts are configured with fontconfig.

Upon doing a fresh installation of Red Hat Linux, fonts are preconfigured
for xfs ONLY for fonts that come WITH Red Hat Linux.  Any fonts that a
user installs in their system, it is the responsibility of the font rpm
packager to follow similar practice to that of Red Hat font packages in
order for the fonts to be visible in applications properly, or it is the
responsibility of the user installing the fonts to do so.  In the case
of xfs, the font path _MUST_ be configured in the xfs config file, the
proper commands executed to create fonts.dir and fonts.scale, and the
xfs font server and X server must be restarted.

This process is fairly well documented in various howto's and other
documentation.  I'm not going to repeat it here.  Nonetheless, ttf fonts
do work, and do work properly in Red Hat Linux 8.0, both using xfs, and
using Xft2, and this bug report is as such NOTABUG.  User inability to
configure something does not constitute it being a bug.

I can change the resolution to WORKSFORME if you like, or perhaps
Comment 5 Carlos Rodrigues 2002-11-01 19:44:49 EST
First, please note that I'm accepting this as NOTABUG. However, I think that
there is some miscommunication here since I said that the problem was that the
name of the directory mattered in whether fonts worked or not, but I've tried to
fiddle around with the configuration again (merely adding a directory to xfs
config and restarting it) and found out that now only some fonts that work out
of /usr/X11R6/lib/X11/fonts/TTF do not work out of the directory added to xfs
config when I expected all of them to work or none of them to work. I accept
that this may be my problem, therefore NOTABUG it is.

Note You need to log in before you can comment on or make changes to this bug.