Bug 768754 - [abrt] nogravity-2.00-12.fc15: V3XScene_Validate: Process /usr/bin/nogravity-opengl was killed by signal 11 (SIGSEGV)
Summary: [abrt] nogravity-2.00-12.fc15: V3XScene_Validate: Process /usr/bin/nogravity-...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: nogravity
Version: 16
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Hans de Goede
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:5186bd9c09b37a4906656fe34d7...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-12-18 16:36 UTC by ngomez2
Modified: 2012-04-22 03:46 UTC (History)
1 user (show)

Fixed In Version: nogravity-2.00-16.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-04-20 03:08:11 UTC
Type: ---


Attachments (Terms of Use)
File: maps (17.99 KB, text/plain)
2011-12-18 16:36 UTC, ngomez2
no flags Details
File: backtrace (15.63 KB, text/plain)
2011-12-18 16:36 UTC, ngomez2
no flags Details

Description ngomez2 2011-12-18 16:36:30 UTC
libreport version: 2.0.8
abrt_version:   2.0.7
backtrace_rating: 4
cmdline:        nogravity-opengl
crash_function: V3XScene_Validate
executable:     /usr/bin/nogravity-opengl
kernel:         3.1.5-2.fc16.x86_64
pid:            1563
pwd:            /home/nicoco/Documents
reason:         Process /usr/bin/nogravity-opengl was killed by signal 11 (SIGSEGV)
time:           Sat 17 Dec 2011 10:06:04 PM RET
uid:            1000
username:       nicoco
xsession_errors: 

backtrace:      Text file, 16008 bytes
maps:           Text file, 18423 bytes

build_ids:
:847d345f588ec73103f5a8237701e8e018b32613
:1c6a95451ee19617be5abea3d121f0226d21ddda
:dc998e8c1e1dc44c684b9b86e753945a868e134a
:3ed9e61c2b7e707ce244816335776afa2ad0307d
:4d5437cf71ea3e4bac1c445da58ca7897d509d15
:3e113d18232e9368a3d33d061ee14e221202b1cc
:d0c6e13f00a20952a72a945c929efb175fd760e3
:ab59942678bcdecb23756804dcd0aac63ccc1669
:7110c8ac5ea9a650cbf77c51e8cc1df7c407fafd
:a594ab36356a9b6dc6ecf25a6124463ccbfd0a29
:7ddde233293b60ff6de1dabd78d95aa43e47fc23
:9d1209fc79304f03cc839de1c0036c61b48dfff8
:638db099ff5fb986d1a092629d1bb1dca5be4904
:e5429e0905bedecc534b057783916ba43e06a66e
:44ece411beb2ef1acdb5eb2161666de41cc2f31d
:6fa46c9f11304fe8ffcb8f7f4c4f73a12cc27821
:-
:f417b25f83a1b878b1a8965478a7eecf0344eaca
:4b01fe6e705219deca2756ff0720d52ec81b4c87
:0f0c9eed63ed279ceb0aef109eff8bcbb351e4bb
:25b834f4c4dc534708635ff1064e2fe02a366a62
:4a7e68edf2778a9fbd3d4a8fbd3f9d1e7b785fc6
:c7a36a8603f2ab43a983f2aebfbfc69d1e6545d2
:7994f114cf7189e482f2665fae8e351ed8bc05e3
:1d1e7527a6b5fd829fe8c097bea4c62b2d0f2df9
:cc32e70895d23acd7bde1ef1a3286b5e179e2d49
:b0eabf9093defbfdd0857ea3ed1a4563b743434e
:4c842320387ff7f6f91b7842b223c16518be909f
:0911ea7c180d733724f89037b8e8a34e64024aec
:be507c791e34415e8f42f0e6030c889b2895cf9a
:3dd00a31cf09e7d59a58bbcf0750e12401a23e53
:c2d49d72ec1a1e68b39c3724693f83f44d80a259
:652978274d9edf0accf8057af35746fe32ca8b1c
:b092238efe70555aea56f2dd242b7c0fe06d29b6
:163b323da65b708418226eb5fa8b057c731d1475
:e02146cbd7b3747790cf4808baa58dc78c2e0042
:c1f034e216940c41dbe23880c3400ef9cffae35d
:daec0ba0ef53c9f6c098d2b47f5974fa82aff498
:8264e35452b2a930c1b9b092b87f32d42d69d8c5
:0949b493f01e0553822be3bd14def9dbe79b804f

dso_list:
:/usr/lib64/libXcursor.so.1.0.2 libXcursor-1.1.11-3.fc15.x86_64 (Fedora Project) 1320287315
:/lib64/libm-2.14.90.so glibc-2.14.90-21.x86_64 (Fedora Project) 1323892705
:/usr/lib64/libxcb.so.1.1.0 libxcb-1.7-3.fc16.x86_64 (Fedora Project) 1320287315
:/usr/lib64/libvorbis.so.0.4.5 libvorbis-1:1.3.2-1.fc15.x86_64 (Fedora Project) 1320287315
:/usr/lib64/libopenal.so.1.12.854 openal-soft-1.12.854-2.fc15.x86_64 (Fedora Project) 1324133559
:/usr/lib64/libX11-xcb.so.1.0.0 libX11-1.4.3-1.fc16.x86_64 (Fedora Project) 1320287315
:/usr/lib64/libvorbisenc.so.2.0.8 libvorbis-1:1.3.2-1.fc15.x86_64 (Fedora Project) 1320287315
:/lib64/libresolv-2.14.90.so glibc-2.14.90-21.x86_64 (Fedora Project) 1323892705
:/usr/lib64/libX11.so.6.3.0 libX11-1.4.3-1.fc16.x86_64 (Fedora Project) 1320287315
:/usr/lib64/libXtst.so.6.1.0 libXtst-1.2.0-2.fc15.x86_64 (Fedora Project) 1320287315
:/usr/lib64/libogg.so.0.7.1 libogg-2:1.2.2-3.fc15.x86_64 (Fedora Project) 1320287315
:/usr/lib64/libSM.so.6.0.1 libSM-1.2.0-2.fc15.x86_64 (Fedora Project) 1320287315
:/lib64/libpthread-2.14.90.so glibc-2.14.90-21.x86_64 (Fedora Project) 1323892705
:/usr/lib64/libXfixes.so.3.1.0 libXfixes-5.0-1.fc16.x86_64 (Fedora Project) 1320287315
:/usr/lib64/libpulse.so.0.12.4 pulseaudio-libs-0.9.23-1.fc16.x86_64 (Fedora Project) 1320287316
:/usr/lib64/gconv/gconv-modules.cache glibc-2.14.90-21.x86_64 (Fedora Project) 1323892705
:/usr/lib64/libXrender.so.1.3.0 libXrender-0.9.6-2.fc15.x86_64 (Fedora Project) 1320287315
:/usr/bin/nogravity-opengl nogravity-2.00-12.fc15.x86_64 (Fedora Project) 1324133564
:/lib64/libgcc_s-4.6.2-20111027.so.1 libgcc-4.6.2-1.fc16.x86_64 (Fedora Project) 1320287305
:/usr/lib64/libFLAC.so.8.2.0 flac-1.2.1-6.fc12.x86_64 (Fedora Project) 1320287316
:/lib64/libdbus-1.so.3.5.6 dbus-libs-1:1.4.10-3.fc16.x86_64 (Fedora Project) 1320287314
:/lib64/libdl-2.14.90.so glibc-2.14.90-21.x86_64 (Fedora Project) 1323892705
:/lib64/libuuid.so.1.3.0 libuuid-2.20.1-2.1.fc16.x86_64 (Fedora Project) 1323892721
:/usr/lib64/libpng12.so.0.46.0 libpng-2:1.2.46-1.fc16.x86_64 (Fedora Project) 1320287314
:/lib64/libc-2.14.90.so glibc-2.14.90-21.x86_64 (Fedora Project) 1323892705
:/lib64/librt-2.14.90.so glibc-2.14.90-21.x86_64 (Fedora Project) 1323892705
:/usr/lib64/libICE.so.6.3.0 libICE-1.0.7-1.fc16.x86_64 (Fedora Project) 1320287314
:/usr/lib64/nvidia/tls/libnvidia-tls.so.290.10 xorg-x11-drv-nvidia-libs-1:290.10-1.fc16.x86_64 (RPM Fusion) 1323963015
:/usr/lib64/libXau.so.6.0.0 libXau-1.0.6-2.fc15.x86_64 (Fedora Project) 1320287314
:/usr/lib64/libXrandr.so.2.2.0 libXrandr-1.3.1-2.fc15.x86_64 (Fedora Project) 1320287316
:/lib64/libz.so.1.2.5 zlib-1.2.5-5.fc16.x86_64 (Fedora Project) 1323892706
:/lib64/ld-2.14.90.so glibc-2.14.90-21.x86_64 (Fedora Project) 1323892705
:/usr/lib64/libXext.so.6.4.0 libXext-1.3.0-1.fc16.x86_64 (Fedora Project) 1323892707
:/usr/lib64/libsndfile.so.1.0.25 libsndfile-1.0.25-1.fc16.x86_64 (Fedora Project) 1320287316
:/usr/lib64/libstdc++.so.6.0.16 libstdc++-4.6.2-1.fc16.x86_64 (Fedora Project) 1320287314
:/usr/lib64/libasyncns.so.0.3.1 libasyncns-0.8-2.fc15.x86_64 (Fedora Project) 1320287316
:/usr/lib/locale/locale-archive glibc-common-2.14.90-21.x86_64 (Fedora Project) 1323892700
:/usr/lib64/libSDL-1.2.so.0.11.3 SDL-1.2.14-13.fc16.x86_64 (Fedora Project) 1323965305
:/lib64/libnsl-2.14.90.so glibc-2.14.90-21.x86_64 (Fedora Project) 1323892705
:/usr/lib64/libpulsecommon-0.9.23.so pulseaudio-libs-0.9.23-1.fc16.x86_64 (Fedora Project) 1320287316
:/lib64/libwrap.so.0.7.6 tcp_wrappers-libs-7.6-64.fc16.x86_64 (Fedora Project) 1320287315
:/usr/lib64/nvidia/libnvidia-glcore.so.290.10 xorg-x11-drv-nvidia-libs-1:290.10-1.fc16.x86_64 (RPM Fusion) 1323963015
:/usr/lib64/libXi.so.6.1.0 libXi-1.4.3-3.fc16.x86_64 (Fedora Project) 1320287315
:/usr/lib64/nvidia/libGL.so.290.10 xorg-x11-drv-nvidia-libs-1:290.10-1.fc16.x86_64 (RPM Fusion) 1323963015

environ:
:XDG_VTNR=1
:KDE_MULTIHEAD=false
:SSH_AGENT_PID=1250
:XDG_SESSION_ID=1
:DM_CONTROL=/var/run/xdmctl
:HOSTNAME=Nicoco-PC
:DESKTOP_STARTUP_ID=Nicoco-PC;1324137725;289481;1368_TIME227431
:SHELL=/bin/bash
:XDG_MENU_PREFIX=kde4-
:XDM_MANAGED=method=classic
:XDG_SESSION_COOKIE=539b48d062743c463c6d394300000008-1324137608.681817-1034793221
:HISTSIZE=1000
:GTK2_RC_FILES=/etc/gtk-2.0/gtkrc:/home/nicoco/.gtkrc-2.0:/home/nicoco/.gtkrc-2.0-kde4:/home/nicoco/.kde/share/config/gtkrc-2.0
:GTK_RC_FILES=/etc/gtk/gtkrc:/home/nicoco/.gtkrc:/home/nicoco/.kde/share/config/gtkrc
:GS_LIB=
:KDE_FULL_SESSION=true
:USER=nicoco
:SSH_AUTH_SOCK=/tmp/ssh-ZYlMdCrV1218/agent.1218
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1336,unix/unix:/tmp/.ICE-unix/1336
:PATH=/usr/local/bin:/usr/bin:/bin:/usr/games:/usr/local/sbin:/usr/sbin:/sbin:/home/nicoco/.local/bin:/home/nicoco/bin
:DESKTOP_SESSION=default
:MAIL=/var/spool/mail/nicoco
:PWD=/home/nicoco/Documents
:LANG=en_US.UTF-8
:KDE_IS_PRELINKED=1
:KDE_SESSION_UID=1000
:KDEDIRS=/usr
:HISTCONTROL=ignoredups
:SSH_ASKPASS=/usr/bin/ksshaskpass
:HOME=/home/nicoco
:XDG_SEAT=seat0
:SHLVL=2
:KDE_SESSION_VERSION=4
:XCURSOR_THEME=default
:LOGNAME=nicoco
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-xtntxFFhZC,guid=cfb268aee39eed059be1688e0000006f
:XDG_DATA_DIRS=/usr/share/kde-settings/kde-profile/default/share:/usr/local/share:/usr/share
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:DISPLAY=:0
:XDG_RUNTIME_DIR=/run/user/nicoco
:QT_PLUGIN_PATH=/home/nicoco/.kde/lib64/kde4/plugins/:/usr/lib64/kde4/plugins/:/usr/lib/kde4/plugins
:XAUTHORITY=/tmp/kde-nicoco/xauth-1000-_0

var_log_messages:
:Dec 17 22:06:04 Nicoco-PC kernel: [ 7667.125354] nogravity-openg[1563]: segfault at 7f10a5521e28 ip 000000000041d01c sp 00007fffde38dd70 error 4 in nogravity-opengl[400000+58000]
:Dec 17 22:06:05 Nicoco-PC abrt[4696]: Saved core dump of pid 1563 (/usr/bin/nogravity-opengl) to /var/spool/abrt/ccpp-2011-12-17-22:06:04-1563 (79536128 bytes)

Comment 1 ngomez2 2011-12-18 16:36:35 UTC
Created attachment 548400 [details]
File: maps

Comment 2 ngomez2 2011-12-18 16:36:39 UTC
Created attachment 548401 [details]
File: backtrace

Comment 3 Hans de Goede 2011-12-19 08:48:08 UTC
Hi,

Thanks for the bug report. Can you please give some information what you were doing / trying to do when this crash happened?

Thanks & Regards,

Hans

Comment 4 ngomez2 2011-12-20 03:27:26 UTC
hi,

I'm playing in the firt mission: empire Krosso, level 5 (champs d'aureas).

Best regards.

Nicolas

Comment 5 Hans de Goede 2011-12-20 08:07:14 UTC
Hi,

(In reply to comment #4)
> hi,
> 
> I'm playing in the firt mission: empire Krosso, level 5 (champs d'aureas).
> 

Thanks for the info. Have you tried to play the same level again? And did it crash again or did it work?

Did the crash happen while loading the level or during gameplay?

Regards,

Hans

Comment 6 ngomez2 2011-12-20 18:30:02 UTC
Hi,

Yes I'm playing today again on this level, and the game crashed again.

Best regards,

Nicolas

Comment 7 Hans de Goede 2012-01-02 10:01:17 UTC
(In reply to comment #6)
> Hi,
> 
> Yes I'm playing today again on this level, and the game crashed again.
> 

Thanks for the info, does this happen during loading the level, or during play?

If it happens during play, does it always happen at the same moment, and is it a far time into the level?

The reasons I'm asking this is because I've not played the game a whole lot myself, so I'll likely have trouble reproducing this...

If I were to do a special build for you with some extra debugging added could you install that and reproduce the bug with that?

Thanks & Regards,

Hans

Comment 8 ngomez2 2012-01-02 18:48:46 UTC
hi,

This bug when loading the level.

Thanks & happy New Year.

Nicolas

Comment 9 Hans de Goede 2012-01-04 10:19:30 UTC
(In reply to comment #8)
> hi,
> 
> This bug when loading the level.

Great, then I should be able to reproduce (and hopefully fix) it. Can you please tar up ~/.realtech and attach it here?

To do so run the following from a terminal:

tar cvfz realtech.tar.gz ~/.realtech

This will create a realtech.tar.gz file in the dir where you run the command, please attach that file to this bug. This will allow me to start at the same point in the game were you are, using your settings which should do the trick for reproducing the bug.

Comment 10 ngomez2 2012-01-04 19:22:53 UTC
hi, 

[Game]
Language=1
Difficulty=1
OS=33

[Video]
Dithering=yes
TexFiltering=yes
TexPOT=no
TexCompression=no
Sky=1
Shading=2
Gamma=1
LensFX=1
VisualsFx=4
Zbuffer=no
ResolutionX=1920
ResolutionY=1080
Fullscreen=1
ColorDepth=32
FrameSkip=0
Multisampling=0
VSync=1

[Sound]
VolFX=100.000000
VolDIG=100.000000
VolMusic=100.000000

[Control]
Controller=Mouse
Speed=12
FlipY=no
Key=36 4e 4a  f  e d3 d2 35  b 38 1c 39  d  c 1e 17 13 2e c8 d0 cd cb 
Joy= 2  0  0  0  5  0  0  0  4  1  3  6  0  0  7  0  8  0  0  0  0  0 
Mou= 2  0  0  0  0  0  0  0  0  1  0  0  0  0  0  0  0  0  0  0  0  0 
AltMouse=0
JoyThrottleAxis=0
JoyRollAxis=0
JoyCalibration2=0 0 0 0 0 0 0 0

Comment 11 Hans de Goede 2012-04-11 14:57:55 UTC
Hi,

It took a while for me to get around to debug this, but I've debugged and fixed this now, a fixed package is on its way to updates-testing.

Regards,

Hans

Comment 12 Fedora Update System 2012-04-12 07:02:14 UTC
nogravity-2.00-16.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/nogravity-2.00-16.fc17

Comment 13 Fedora Update System 2012-04-12 07:10:16 UTC
nogravity-2.00-16.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/nogravity-2.00-16.fc16

Comment 14 Fedora Update System 2012-04-12 08:39:48 UTC
nogravity-2.00-16.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/nogravity-2.00-16.fc15

Comment 15 Fedora Update System 2012-04-13 06:11:34 UTC
Package nogravity-2.00-16.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing nogravity-2.00-16.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-5778/nogravity-2.00-16.fc17
then log in and leave karma (feedback).

Comment 16 Fedora Update System 2012-04-20 03:08:11 UTC
nogravity-2.00-16.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2012-04-22 03:33:28 UTC
nogravity-2.00-16.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2012-04-22 03:46:53 UTC
nogravity-2.00-16.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.