Bug 76890 - anaconda installs unwanted packages and RFE: comps sanity
anaconda installs unwanted packages and RFE: comps sanity
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-28 15:06 EST by jbowman
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-28 17:55:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ks.cfg that produces no dependency warnings, yet installs many, many unspecified packages (2.82 KB, text/plain)
2002-10-28 15:09 EST, jbowman
no flags Details

  None (edit)
Description jbowman 2002-10-28 15:06:41 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021021
Phoenix/0.3

Description of problem:
Anaconda will install a large tree of unwanted packages during install, without
producing a prompt. This is especially noticeably during kickstart installations
where each package to be installed is explicitly listed.

Some of these packages seem to be the alternative language support for every
supported language, and the dependencies required to satisfy them. If they are
being included to satisfy a dependency, the dependency-resolution prompt should
be presented.

Others are being included for no apparent reason at all. For example, sendmail
(postfix is being installed by choice), namazu, namazu-devel, openssh,
openssh-clients, openssh-server, openssh-askpass, gtk+, and more.

I've seen this occur both on standard and kickstart installs, although it's
easier for me to quantify with a kickstart installation. It makes  putting
together a minimal kickstart install for servers a real nightmare,
package-management-wise. This behaviour was present in previous versions of
RedHat but at much-reduced level: Typically auto-installed packages were tied to
the kernel (i.e. kernel pcmcia support). In 8.0, the field of packages has
expanded enormously.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install without specifying one of the (many) specified packages.
2.
3.
	

Actual Results:  Canna was installed.

Expected Results:  Packages that aren't specified, either by selecting a group
including them or by selecting them individually, should not be installed.

Additional info:

Unspecified packages I've found installed so far after a kickstart install (this
is by no means complete, only a partial listing):

Canna
nvi-m17n-canna
Canna-libs
kinput2-canna-wnn6-v3
kWnn
kWnn-devel
aspell-es
aspell-fr
aspell-pt_BR
aspell-da
aspell-no
aspell-ca
aspell-en-gb
aspell-nl
aspell-sv
aspell
aspell-it
aspell-de
aspell-pt
aspell-en-ca
tWnn
kon2-fonts-0.3.9b-13
fontconfig-2.0-3
XFree86-font-utils-4.2.0-72
fonts-ISO8859-2-1.0-8
fonts-ISO8859-2-75dpi-1.0-8
fonts-KOI8-R-100dpi-1.0-3
ttfonts-ko-1.0.11-21
ttfonts-zh_CN-2.11-29
XFree86-100dpi-fonts-4.2.0-72
fonts-ja-8.0-4
XFree86-ISO8859-9-100dpi-fonts-4.2.0-72
chkfontpath-1.9.6-3
fonts-KOI8-R-1.0-3
ttfonts-ja-1.2-16
ttfonts-zh_TW-2.11-15
XFree86-cyrillic-fonts-4.2.0-72
hanterm-xf
Comment 1 jbowman 2002-10-28 15:09:30 EST
Created attachment 82444 [details]
ks.cfg that produces no dependency warnings, yet installs many, many unspecified packages
Comment 2 jbowman 2002-10-28 16:12:20 EST
This appears to also indicate some problems with dependency-resolving inside
anaconda itself, as in auditing the resulting installation I'm finding a number
of silently-resolved dependencies for packages that are listed in the ks.cfg
(i.e. usermode).

Perhaps the two symptoms (silently resolved dependencies and extraneous package
installations) are symptoms of a larger package-selection problem?
Comment 3 jbowman 2002-10-28 16:56:43 EST
Err, right then. Some, but not all, of these are attributable to what appears to
be a bug in the Core/Base groups auto-inclusion: In auto-including the groups
"Core" and "Base", anaconda doesn't bother to distinguish between 'default' and
'mandatory'. Shouldn't only mandatory packages be installed as part of the
forced-install of Core/Base?

I've found the error in my ks.cfg that was causing the full language support
packages to be installed. A change in the meaning of "lang_support --default
<language>" slipped by under my radar. :)


But this still fails to explain why certain packages *not* listed in Core/Base
that do not have explicit dependencies were also installed (i.e. mutt, net-snmp,
openssh).
Comment 4 jbowman 2002-10-28 17:55:05 EST
My apologies on the repeated commentary on this. The sticky mess that is package
resolution in anaconda continues to amaze me.

openssh/net-snmp are explained away because they're part of the 'default'
packagelist in the 'base' group. However, I still can't find an explanation for
mutt, as it's part of "text-internet", and has no references to either it, its
group, or the various meta-groups that contain it and its groups, inside 'base'
and 'core'.

I've changed the summary line and priority to something more suitable. Getting a
true 'minimal' set of auto-includes, at the very least in the kickstart install,
would be Very Nice. Or, perhaps even better, a flag for ks.cfg to disable
automatic package inclusion, so that only the specified packages get installed.
I'd really hate to be forced to create weird localized kickstart trees just to
get a decent server kickstart going. :)
Comment 5 Michael Fulbright 2002-10-30 16:33:05 EST
I think you'll want to read the section on langsupport here:

 
http://www.redhat.com/docs/manuals/linux/RHL-7.3-Manual/custom-guide/s1-kickstart2-options.html

You have:

langsupport --default en_US

which installs all langs and makes en_US the default.

Note You need to log in before you can comment on or make changes to this bug.