Bug 769298 - cvs assertion failure
cvs assertion failure
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cvs (Show other bugs)
5.7
All Linux
high Severity medium
: rc
: ---
Assigned To: Petr Pisar
qe-baseos-daemons
: Patch, Regression
Depends On:
Blocks: 772956
  Show dependency treegraph
 
Reported: 2011-12-20 08:23 EST by Petr Sklenar
Modified: 2016-04-26 11:02 EDT (History)
5 users (show)

See Also:
Fixed In Version: cvs-1.11.22-11.el5
Doc Type: Bug Fix
Doc Text:
Cause Using `cvs rtag' command on repository with `.' component in repository path. Consequence CVS server hits assertion test and terminates. Fix The assertion check for `.' in path has been removed as cvs can process such patch safely now. Result `cvs rtag' proceeds on repositories with dot in CVSROOT path as expected.
Story Points: ---
Clone Of: 441694
Environment:
Last Closed: 2012-02-21 01:20:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
testcase (242 bytes, text/plain)
2011-12-20 10:25 EST, Petr Pisar
no flags Details
Fix (52 bytes, text/plain)
2011-12-20 11:05 EST, Petr Pisar
no flags Details

  None (edit)
Comment 2 Petr Pisar 2011-12-20 10:25:55 EST
Created attachment 548865 [details]
testcase

This calls `cvs rtag' on CVSROOT with `/./' to trigger the assertion. This testcase touches current directory.
Comment 3 Petr Pisar 2011-12-20 10:53:24 EST
RHEL-6 (cvs-1.11.23) not affected.
Comment 4 Petr Pisar 2011-12-20 11:05:27 EST
Created attachment 548878 [details]
Fix

This is patch used in RHEL-4. It applies to RHEL-5 cvs cleanly and fixes this issue. It's in line with upstream development tree.
Comment 11 Petr Pisar 2012-01-03 07:50:52 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause
    Using `cvs rtag' command on repository with `.'
    component in repository path.
Consequence
    CVS server hits assertion test and terminates.
Fix
    The assertion check for `.' in path has been removed as
    cvs can process such patch safely now.
Result
    `cvs rtag' proceeds on repositories with dot in CVSROOT
    path as expected.
Comment 14 errata-xmlrpc 2012-02-21 01:20:13 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0253.html

Note You need to log in before you can comment on or make changes to this bug.