Bug 769483 - [abrt][kde] libreoffice-core-3.4.99.1-1.fc17: crash on exit, post-main QGlobalStaticDeleter dtor
[abrt][kde] libreoffice-core-3.4.99.1-1.fc17: crash on exit, post-main QGloba...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lukáš Tinkl
Fedora Extras Quality Assurance
abrt_hash:2673ff1f658cae147737040ced6...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-20 19:06 EST by Tom
Modified: 2015-07-13 13:36 EDT (History)
9 users (show)

See Also:
Fixed In Version: libreoffice-core-3.5.1.2-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-20 07:43:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: build_ids (8.57 KB, text/plain)
2011-12-20 19:06 EST, Tom
no flags Details
File: dso_list (21.35 KB, text/plain)
2011-12-20 19:06 EST, Tom
no flags Details
File: maps (90.75 KB, text/plain)
2011-12-20 19:06 EST, Tom
no flags Details
File: backtrace (25.16 KB, text/plain)
2011-12-20 19:06 EST, Tom
no flags Details
File: backtrace (27.40 KB, text/plain)
2012-03-03 11:04 EST, admin
no flags Details
File: backtrace (55.98 KB, text/plain)
2012-03-10 21:17 EST, admin
no flags Details
File: backtrace (41.67 KB, text/plain)
2012-03-10 23:32 EST, Peter Trenholme
no flags Details

  None (edit)
Description Tom 2011-12-20 19:06:21 EST
libreport version: 2.0.8
abrt_version:   2.0.7
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/soffice.bin --writer --splash-pipe=6
crash_function: __GI_exit
executable:     /usr/lib64/libreoffice/program/soffice.bin
kernel:         3.2.0-0.rc6.git1.1.fc17.x86_64
pid:            3630
pwd:            /home/tom/Documents
reason:         Process /usr/lib64/libreoffice/program/soffice.bin was killed by signal 11 (SIGSEGV)
time:           Tue 20 Dec 2011 06:58:05 PM UTC
uid:            1000
username:       tom
xsession_errors: 

backtrace:      Text file, 25764 bytes
build_ids:      Text file, 8774 bytes
dso_list:       Text file, 21865 bytes
maps:           Text file, 92929 bytes

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=1
:SSH_AGENT_PID=1383
:KDE_MULTIHEAD=false
:HOSTNAME=tom-3000
:DM_CONTROL=/var/run/xdmctl
:MALLOC_CHECK_=3
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:XDG_MENU_PREFIX=kde4-
:SHELL=/bin/bash
:TERM=dumb
:DESKTOP_STARTUP_ID=tom-3000;1324407468;712608;1503_TIME5878958
:HISTSIZE=1000
:XDG_SESSION_COOKIE=d04d0ab3977c9e0a14f929a20000003a-1324401738.942122-1384049290
:XDM_MANAGED=method=classic
:GTK2_RC_FILES=/etc/gtk-2.0/gtkrc:/home/tom/.gtkrc-2.0:/home/tom/.gtkrc-2.0-kde4:/home/tom/.kde/share/config/gtkrc-2.0
:GS_LIB=
:GTK_RC_FILES=/etc/gtk/gtkrc:/home/tom/.gtkrc:/home/tom/.kde/share/config/gtkrc
:OLDPWD=/usr/lib64/libreoffice/program
:KDE_FULL_SESSION=true
:IMSETTINGS_MODULE=none
:USER=tom
:SSH_AUTH_SOCK=/tmp/ssh-TiGlVENV1225/agent.1225
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1445,unix/unix:/tmp/.ICE-unix/1445
:MAIL=/var/spool/mail/tom
:DESKTOP_SESSION=default
:PATH=/usr/lib64/ccache:/usr/local/bin:/usr/bin:/bin:/usr/games:/usr/local/sbin:/usr/sbin:/sbin:/home/tom/.local/bin:/home/tom/bin
:QT_IM_MODULE=xim
:PWD=/home/tom/Documents
:XMODIFIERS=@im=none
:KDE_SESSION_UID=1000
:KDE_IS_PRELINKED=1
:LANG=en_US.UTF-8
:KDEDIRS=/usr
:SSH_ASKPASS=/usr/bin/ksshaskpass
:HISTCONTROL=ignoredups
:SHLVL=2
:XDG_SEAT=seat0
:HOME=/home/tom
:KDE_SESSION_VERSION=4
:XCURSOR_THEME=default
:SAL_ENABLE_FILE_LOCKING=1
:LOGNAME=tom
:CVS_RSH=ssh
:XDG_DATA_DIRS=/usr/share/kde-settings/kde-profile/default/share:/usr/local/share:/usr/share
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-d8ZLIxBCIR,guid=904d275744bc9aa0965163db00000098
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/tom
:DISPLAY=:0
:QT_PLUGIN_PATH=/home/tom/.kde/lib64/kde4/plugins/:/usr/lib64/kde4/plugins/:/usr/lib/kde4/plugins
:GTK_IM_MODULE=gtk-im-context-simple
:CCACHE_HASHDIR=
:XAUTHORITY=/tmp/kde-tom/xauth-1000-_0
:LD_LIBRARY_PATH=/usr/java/jre1.6.0_29/lib/amd64/client:/usr/java/jre1.6.0_29/lib/amd64/server:/usr/java/jre1.6.0_29/lib/amd64/native_threads:/usr/java/jre1.6.0_29/lib/amd64

smolt_data:
:
:
:General
:=================================
:UUID: 8c9683d5-583e-410d-aeee-e9de96d330d1
:OS: Fedora release 17 (Rawhide)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: x86_64
:BogoMIPS: 5984.94
:CPU Vendor: AuthenticAMD
:CPU Model: AMD Phenom(tm) II N660 Dual-Core Processor
:CPU Stepping: 3
:CPU Family: 16
:CPU Model Num: 6
:Number of CPUs: 2
:CPU Speed: 3000
:System Memory: 3931
:System Swap: 5983
:Vendor: Acer
:System: Aspire 5552G V2.14
:Form factor: Notebook
:Kernel: 3.2.0-0.rc6.git1.1.fc17.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(4098:17297:4133:1161) pci, ahci, STORAGE, SB7x0/SB8x0/SB9x0 SATA Controller [AHCI mode]
:(4098:17302:4133:1161) pci, ehci_hcd, USB, SB7x0/SB8x0/SB9x0 USB EHCI Controller
:(5772:46:6706:8969) pci, ath9k, NETWORK, AR9287 Wireless Network Adapter (PCI-Express)
:(4130:38401:4133:1161) pci, None, HOST/PCI, RS880 Host Bridge
:(4130:4612:0:0) pci, None, HOST/PCI, Family 10h Processor Link Control
:(5348:5778:4133:1161) pci, tg3, ETHERNET, NetLink BCM57780 Gigabit Ethernet PCIe
:(4130:4608:0:0) pci, None, HOST/PCI, Family 10h Processor HyperTransport Configuration
:(4130:4611:0:0) pci, k10temp, HOST/PCI, Family 10h Processor Miscellaneous Control
:(4130:4610:0:0) pci, None, HOST/PCI, Family 10h Processor DRAM Controller
:(4130:4609:0:0) pci, None, HOST/PCI, Family 10h Processor Address Map
:(4130:38403:4133:1161) pci, pcieport, PCI/PCI, RS780 PCI to PCI bridge (ext gfx port 0)
:(4098:17285:4133:1161) pci, piix4_smbus, SERIAL, SBx00 SMBus Controller
:(4098:17309:4133:1161) pci, None, PCI/ISA, SB7x0/SB8x0/SB9x0 LPC host controller
:(4098:17283:4133:1161) pci, snd_hda_intel, MULTIMEDIA, SBx00 Azalia (Intel HDA)
:(4098:17305:4133:1161) pci, ohci_hcd, USB, SB7x0/SB8x0/SB9x0 USB OHCI2 Controller
:(4098:17284:0:0) pci, None, PCI/PCI, SBx00 PCI to PCI Bridge
:(4098:43664:4133:1161) pci, snd_hda_intel, MULTIMEDIA, N/A
:(4098:26433:4133:1161) pci, radeon, VIDEO, NI Whistler [AMD Radeon HD 6600M Series]
:(4098:17303:4133:1161) pci, ohci_hcd, USB, SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
:(4098:17302:4133:1161) pci, ehci_hcd, USB, SB7x0/SB8x0/SB9x0 USB EHCI Controller
:(4098:17303:4133:1161) pci, ohci_hcd, USB, SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
:(4130:38404:4133:1161) pci, pcieport, PCI/PCI, RS780 PCI to PCI bridge (PCIE port 0)
:(4130:38405:4133:1161) pci, pcieport, PCI/PCI, RS780 PCI to PCI bridge (PCIE port 1)
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg_tom3000-lv_root / btrfs 4096 4096 13107200 9399751 8608901 0 0 0
:/dev/sda2 /boot ext4 1024 1024 508745 427224 401624 128016 127790 127790
:/dev/mapper/vg_tom3000-lv_home /home btrfs 4096 4096 58474496 57740032 57292632 0 0 0
:/dev/sr0 WITHHELD udf 2048 2048 3348102 0 0 90 0 0
:

var_log_messages:
:Dec 19 09:50:41 tom-3000 kernel: [ 2274.517622] soffice.bin[2337]: segfault at 7f646a6ceb90 ip 0000003882979599 sp 00007fff0129c590 error 4 in libQtCore.so.4.8.0[3882800000+2c2000]
:Dec 19 09:50:44 tom-3000 abrt[2345]: Saved core dump of pid 2337 (/usr/lib64/libreoffice/program/soffice.bin) to /var/spool/abrt/ccpp-2011-12-19-09:50:41-2337 (48963584 bytes)
:Dec 19 10:34:29 tom-3000 kernel: [ 4902.650923] soffice.bin[2407]: segfault at 7fd07b41eb90 ip 0000003882979599 sp 00007fffb1840e20 error 4 in libQtCore.so.4.8.0[3882800000+2c2000]
:Dec 19 10:34:32 tom-3000 abrt[3082]: Saved core dump of pid 2407 (/usr/lib64/libreoffice/program/soffice.bin) to /var/spool/abrt/ccpp-2011-12-19-10:34:29-2407 (87134208 bytes)
:Dec 20 09:48:51 tom-3000 kernel: [ 1862.086154] soffice.bin[12493]: segfault at 7f9255180900 ip 00007f9255180900 sp 00007fff301c0338 error 15
:Dec 20 09:48:59 tom-3000 abrt[12519]: Saved core dump of pid 12493 (/usr/lib64/libreoffice/program/soffice.bin) to /var/spool/abrt/ccpp-2011-12-20-14:48:51-12493 (87838720 bytes)
:Dec 20 09:49:48 tom-3000 kernel: [ 1918.754519] soffice.bin[12524]: segfault at 0 ip           (null) sp 00007fffc274fb78 error 14 in soffice.bin[400000+1000]
:Dec 20 09:49:54 tom-3000 abrt[12566]: Saved core dump of pid 12524 (/usr/lib64/libreoffice/program/soffice.bin) to /var/spool/abrt/ccpp-2011-12-20-14:49:48-12524 (89432064 bytes)
:Dec 20 11:55:10 tom-3000 kernel: [  329.212094] soffice.bin[1948]: segfault at 7f89b469d4c0 ip 00007f89b469d4c0 sp 00007fff2d5de498 error 15
:Dec 20 11:55:12 tom-3000 abrt[1962]: Saved core dump of pid 1948 (/usr/lib64/libreoffice/program/soffice.bin) to /var/spool/abrt/ccpp-2011-12-20-11:55:10-1948 (81416192 bytes)
:Dec 20 15:58:10 tom-3000 kernel: [  377.720103] soffice.bin[1691]: segfault at 7fd2011fdb90 ip 00007fd2007a5599 sp 00007fff8d44f6f0 error 4 in libQtCore.so.4.8.0[7fd20062c000+2c2000]
:Dec 20 15:58:13 tom-3000 abrt[1721]: Saved core dump of pid 1691 (/usr/lib64/libreoffice/program/soffice.bin) to /var/spool/abrt/ccpp-2011-12-20-15:58:10-1691 (83259392 bytes)
:Dec 20 17:34:10 tom-3000 kernel: [  860.649094] soffice.bin[1896]: segfault at 7f2a1ba56b90 ip 00007f2a1affe599 sp 00007fff8a6103f0 error 4 in libQtCore.so.4.8.0[7f2a1ae85000+2c2000]
:Dec 20 17:34:13 tom-3000 abrt[1939]: Saved core dump of pid 1896 (/usr/lib64/libreoffice/program/soffice.bin) to /var/spool/abrt/ccpp-2011-12-20-17:34:10-1896 (87851008 bytes)
:Dec 20 18:50:30 tom-3000 kernel: [ 5440.655023] soffice.bin[3465]: segfault at 7f920ea8bb90 ip 00007f920e033599 sp 00007fff26630360 error 4 in libQtCore.so.4.8.0[7f920deba000+2c2000]
:Dec 20 18:50:37 tom-3000 abrt[3491]: Saved core dump of pid 3465 (/usr/lib64/libreoffice/program/soffice.bin) to /var/spool/abrt/ccpp-2011-12-20-18:50:30-3465 (81821696 bytes)
:Dec 20 18:58:05 tom-3000 kernel: [ 5896.086501] soffice.bin[3630]: segfault at 7f3248d20160 ip 00007f3248d20160 sp 00007fff4df2d1b8 error 15
:Dec 20 18:58:09 tom-3000 abrt[3645]: Saved core dump of pid 3630 (/usr/lib64/libreoffice/program/soffice.bin) to /var/spool/abrt/ccpp-2011-12-20-18:58:05-3630 (82083840 bytes)
Comment 1 Tom 2011-12-20 19:06:26 EST
Created attachment 548961 [details]
File: build_ids
Comment 2 Tom 2011-12-20 19:06:27 EST
Created attachment 548962 [details]
File: dso_list
Comment 3 Tom 2011-12-20 19:06:29 EST
Created attachment 548963 [details]
File: maps
Comment 4 Tom 2011-12-20 19:06:30 EST
Created attachment 548964 [details]
File: backtrace
Comment 5 Tom 2011-12-20 19:12:48 EST
I get this error when using LibreOffice, eventhough it appears to work fine.

I had to install "hyphen-debuginfo libxml2-debuginfo libXext-debuginfo libreoffice-debuginfo" with yum to start getting debuginfo for backtrace, and also configure os release string for Bugzilla.
Comment 6 Caolan McNamara 2011-12-21 04:24:48 EST
looks like a crash on exit, in the kde-specific code
Comment 7 admin 2012-03-03 11:04:13 EST
1. Open LibreOffice Calc
2. Close LibreOffice Calc


backtrace_rating: 4
Package: libreoffice-core-3.5.1.1-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 8 admin 2012-03-03 11:04:27 EST
Created attachment 567292 [details]
File: backtrace
Comment 9 admin 2012-03-10 21:17:35 EST
Open .vsd file with OpenOfficeDraw with system dialog

backtrace_rating: 4
Package: libreoffice-core-3.5.1.1-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 10 admin 2012-03-10 21:17:46 EST
Created attachment 569151 [details]
File: backtrace
Comment 11 Peter Trenholme 2012-03-10 23:32:37 EST
I was Chrom under KDM to look at a Web page on a remote (Windows Vista) shared html file. (On my local network.) The file had a link to a .doc file, on which I clicked, and it was copied to this (virtual) system's hard drive. I then told the download manager (in the Chrom browser I was using)  to open the file using LibraOffice.

The LibraOffice pop-up was briefly displayed, and then was aborted by the SIGSEGV.

Note: I don't think that this has anything to do with LibraOffice since I've also had GNOME aborted by a SIGSEGV. 


backtrace_rating: 4
Package: libreoffice-core-3.5.1.1-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 12 Peter Trenholme 2012-03-10 23:32:41 EST
Created attachment 569161 [details]
File: backtrace
Comment 13 admin 2012-03-17 02:29:27 EDT
After last update the bug has dissapeared. You may close this bug.
Comment 14 Caolan McNamara 2012-03-20 07:43:49 EDT
That's encouraging, what version (rpm -q libreoffice-core) "works" ?
Comment 15 admin 2012-03-20 11:01:54 EDT
[root@raistlin raistlin]# rpm -q libreoffice-core
libreoffice-core-3.5.1.2-1.fc17.x86_64
[root@raistlin raistlin]#

Note You need to log in before you can comment on or make changes to this bug.