Bug 76960 - Evolution Japanese printing is broken.
Evolution Japanese printing is broken.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: gtkhtml (Show other bugs)
8.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Havoc Pennington
: MoveUpstream, Triaged
Depends On:
Blocks: 79579
  Show dependency treegraph
 
Reported: 2002-10-30 02:34 EST by Nakai
Modified: 2007-04-18 12:48 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-16 04:50:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nakai 2002-10-30 02:34:23 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ja-JP; rv:1.0.1) Gecko/20020830

Description of problem:
Evolution Japanese mail printing is broken.
Gnumeric and gedit works, so it's not gnome-print
problem but evolution's problem.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Print Japanese mail.
2. All Japanese chars are missing.
3. Sucks.
	

Additional info:
Comment 1 Akira TAGOH 2002-10-30 08:37:47 EST
Even if you change the printing font with gtkhtml-properties-capplet, can't you
print it out?
I think the printing is not broken. but the default font is broken for Japanese.
Comment 2 Akira TAGOH 2002-11-11 05:32:56 EST
Well, Ok. this problem was caused by some issues:
- we can't print CJK text out with the current default font; default font should
be gettextize.
- gtkhtml-properties-capplet's UI sucks; needed stuff for printing is a family
name and font size. but gtkhtml-properties-capplet provides it with gtkfontsel.
it contains the unusable fonts for printing, and that configuration is saved as
XLFD. So UI needs to be rewritten for gnome-print.
- we missed any link for gtkhtml-properties-capplet; people can't change it from
Evolution. the font properties are actually gtkhtml stuff. but people who
doesn't know it's gtkhtml stuff, assumes it's Evolution issue.
Comment 3 Havoc Pennington 2003-01-12 23:22:52 EST
How much of this has already been filed on bugzilla.ximian.com?
Do we have links to those bugs? Do we have patches?
Comment 4 Akira TAGOH 2003-04-16 04:50:44 EDT
I think it was fixed in Red Hat Linux 9. sorry for too late reply.

Note You need to log in before you can comment on or make changes to this bug.