Bug 76993 - Greek support is broken, typing in Greek shows blank spaces.
Greek support is broken, typing in Greek shows blank spaces.
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-30 14:04 EST by Dimitris
Modified: 2007-04-18 12:48 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-22 03:56:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dimitris 2002-10-30 14:04:39 EST
Description of problem:
Greek support is broken. Once Greek is selected for the keyboard
mapping, typing in Greek results in blank spaces, no characters
are displayed.

This does not seem to be related to the windowmanager, since it
happens with both Gnome and Kde.

Greek fonts are installed under:
/usr/X11R6/lib/X11/fonts/...

KDE also includes a i18n rpm package for Greek.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
For KDE:
1. Run the KDE Control Center
2. Select page Peripherals -> Keyboard
3. Enable "keyboard layouts"
4. Add the Greek language (el)
5. Enable writing in Greek via the applet, and type something.

	

Actual Results:  No characters show, none at all, just plain spaces.

Expected Results:  Greek characters should have shown.

Additional info:

This bug is not specific to a window manager, since it
happens in both KDE and Gnome.
Comment 1 Mike A. Harris 2002-11-01 22:56:05 EST
Have you installed any greek fonts?
Comment 2 Dimitris 2002-11-02 06:54:05 EST
Yes, Greek fonts are installed (find /usr -name "*8859-7*" shows them).
Comment 3 Mike A. Harris 2002-12-18 23:27:38 EST
Those are bitmapped fonts, and will only be seen by legacy applications
unless you configure your system to provide these bitmapped fonts to Xft
based applications as well.  You need to install Truetype or Type1 fonts
that contain Greek characters in order to have decent Greek fonts in XFree86
in Red Hat Linux 8.0.

Bitmap fonts are generally quite ugly, in particular when they're scaled,
and as such, bitmap fonts are installed in Red Hat Linux by default with
scaling of them disabled.

I've carbon copied Owen, in case he'd like to add a comment, however I do
not personally consider this an XFree86 bug.  It's just a font availability,
and configuration issue IMHO.

Any comments Owen?
Comment 4 Owen Taylor 2002-12-19 11:20:19 EST
I'd suggest grabbing FreeFont from

 http://savannah.nongnu.org/projects/freefont/

and putting it into your ~/.fonts directory (then run fc-cache ~/.fonts
from the command line for a bit of extra efficiency)

They aren't great fonts, but they include Greek and should "just work"
with the Red Hat 8 font system.

Note You need to log in before you can comment on or make changes to this bug.