Bug 770467 - cloud-init package needs to be ported to RHEL
cloud-init package needs to be ported to RHEL
Status: CLOSED DUPLICATE of bug 838659
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: releng (Show other bugs)
6.0
x86_64 Linux
medium Severity medium
: rc
: 6.4
Assigned To: Andrew Thomas
Release Test Team
: EC2, FutureFeature
Depends On:
Blocks: 823632
  Show dependency treegraph
 
Reported: 2011-12-26 16:15 EST by Christopher Tubbs
Modified: 2013-03-07 19:46 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
: 823632 (view as bug list)
Environment:
Last Closed: 2012-08-31 10:43:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher Tubbs 2011-12-26 16:15:04 EST
Description of problem:

The package is included in F16, but its service scripts have been written for upstart (Ubuntu) and systemd (Fedora). A chkconfig compatible init script is necessary for RHEL6 (and maybe RHEL5 also).

Version-Release number of selected component (if applicable):
0.6.2 is the latest version of cloud-init, source hosted at https://launchpad.net/cloud-init
0.6.2 is the Fedora 16 version, source at http://koji.fedoraproject.org/koji/buildinfo?buildID=267128
Comment 3 Suzanne Yeghiayan 2012-01-31 16:14:50 EST
This request was evaluated by Red Hat Product Management for inclusion in the
current release of Red Hat Enterprise Linux. Because the affected component is
not scheduled to be updated in the current release, Red Hat is unfortunately
unable to address this request at this time.  It has been proposed for the next
release. If you would like it considered as an exception in the current
release, please ask your support representative.
Comment 4 Jay Greguske 2012-05-21 14:14:00 EDT
Let's make this happen for 6.4. It should correct many other behaviors like printing ssh fingerprints to the console and logging in as non-root.
Comment 5 RHEL Product and Program Management 2012-07-10 02:59:38 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 6 RHEL Product and Program Management 2012-07-10 21:47:35 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 7 Jay Greguske 2012-08-31 10:43:42 EDT

*** This bug has been marked as a duplicate of bug 838659 ***

Note You need to log in before you can comment on or make changes to this bug.