Bug 770704 - External hdd can't be accessed via esata (/dev/sdb disappears on access)
Summary: External hdd can't be accessed via esata (/dev/sdb disappears on access)
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 16
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-12-28 12:57 UTC by tuxor
Modified: 2012-05-06 14:44 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-05-06 14:44:45 UTC


Attachments (Terms of Use)
dmesg from F17 beta i686 livecd (1.76 KB, text/x-log)
2012-04-22 18:00 UTC, tuxor
no flags Details

Description tuxor 2011-12-28 12:57:26 UTC
Description of problem:
When trying to access my external esata-harddrive I'm getting errors in /var/log/messages and the drive magically disappears from /dev.
Please note, that the harddrive is okay (smartctl) and everything works fine when connected via an esata-to-usb-adapter.

Version-Release number of selected component (if applicable):
3.1.6-1.fc16.x86_64

How reproducible:
almost always. Once in 10 tries it connects fine.

Steps to Reproduce:
1. Attach external Esata-HDD to esata port of Thinkpad T400s
2. Try to create a new partition table with gparted or...
3. ... try to mount an existing partition on the HDD
  
Actual results: (/var/log/messages)
Dec 28 13:47:55 fedora kernel: [ 9372.949143] usb 2-2: device descriptor read/64, error -110
Dec 28 13:47:56 fedora kernel: [ 9373.370064] usb 2-2: reset high speed USB device number 15 using ehci_hcd
Dec 28 13:48:06 fedora kernel: [ 9383.874165] usb 2-2: device not accepting address 15, error -110
Dec 28 13:48:06 fedora kernel: [ 9383.976173] usb 2-2: reset high speed USB device number 15 using ehci_hcd
Dec 28 13:49:02 fedora kernel: [ 9439.924049] usb 2-2: reset high speed USB device number 15 using ehci_hcd
Dec 28 13:49:02 fedora kernel: [ 9440.209062] usb 2-2: reset high speed USB device number 15 using ehci_hcd
Dec 28 13:49:12 fedora kernel: [ 9449.982036] usb 2-2: device descriptor read/64, error -71
Dec 28 13:49:12 fedora kernel: [ 9450.233043] usb 2-2: device descriptor read/64, error -71
Dec 28 13:49:13 fedora kernel: [ 9450.436046] usb 2-2: reset high speed USB device number 15 using ehci_hcd
Dec 28 13:49:13 fedora kernel: [ 9450.586050] usb 2-2: device descriptor read/64, error -71
Dec 28 13:49:13 fedora kernel: [ 9450.837065] usb 2-2: device descriptor read/64, error -71
Dec 28 13:49:13 fedora kernel: [ 9451.040063] usb 2-2: reset high speed USB device number 15 using ehci_hcd
Dec 28 13:49:14 fedora kernel: [ 9451.474044] usb 2-2: device not accepting address 15, error -71
Dec 28 13:49:14 fedora kernel: [ 9451.576050] usb 2-2: reset high speed USB device number 15 using ehci_hcd
Dec 28 13:49:14 fedora kernel: [ 9452.009054] usb 2-2: device not accepting address 15, error -71
Dec 28 13:49:14 fedora kernel: [ 9452.009113] usb 2-2: USB disconnect, device number 15
Dec 28 13:49:14 fedora kernel: [ 9452.010800] scsi 10:0:0:0: [sdb] killing request
Dec 28 13:49:14 fedora kernel: [ 9452.010847] scsi 10:0:0:0: [sdb] Unhandled error code
Dec 28 13:49:14 fedora kernel: [ 9452.010849] scsi 10:0:0:0: [sdb]  Result: hostbyte=DID_NO_CONNECT driverbyte=DRIVER_OK
Dec 28 13:49:14 fedora kernel: [ 9452.010853] scsi 10:0:0:0: [sdb] CDB: Read(10): 28 00 3a 38 5d e0 00 00 08 00
Dec 28 13:49:14 fedora kernel: [ 9452.010860] end_request: I/O error, dev sdb, sector 976772576
Dec 28 13:49:14 fedora kernel: [ 9452.010863] quiet_error: 79 callbacks suppressed
Dec 28 13:49:14 fedora kernel: [ 9452.010865] Buffer I/O error on device sdb, logical block 122096572
Dec 28 13:49:14 fedora kernel: [ 9452.010996] Buffer I/O error on device sdb, logical block 122096572

Expected results:
Connects and can be written on.

Additional info:
Used to work without problems in Fedora 15 (x86_64)

Please note, that the harddrive is okay (smartctl) and everything works fine when connected via an esata-to-usb-adapter.

Comment 1 tuxor 2012-01-15 10:03:03 UTC
The problem persists with kernel 3.1.8-2.fc16.x86_64.

Have a look at this dmesg-output:
http://pastebin.com/MhjX66hP

And now please note that accessing the esata-drive works on other distributions. For example, I have a dmesg log from a Linux Mint 12 Live CD with Kernel 3.0.0:
http://pastebin.com/TeQ2tpAq

Obviously the two operating systems are handling the esata-device in a _completely_ different way! While Fedora is having "usb XY" output all the time, Linux Mint states lines with "ata6".

No ideas, what's causing this problem?

Comment 2 tuxor 2012-01-24 17:32:09 UTC
Please note, that those errors do not appear with an equivalent Fedora installation and the exact same external hard drive on a HP ProBook 4520s (which comes with a similar esata-port).

Now again the error log (dmesg) with kernel-3.2.1-3.fc16.x86_64:

http://pastebin.com/imzvB3Sg

I plugged in the hard drive at 1083.070200. The output temporarily stops at 1097.745132 and when it starts again at 1206.475047, that's the moment I tried to access the hard drive (i.e. I started gparted, but the very same output is produced when trying to mount the hdd etc.).

Comment 3 tuxor 2012-02-10 10:35:34 UTC
Still no progress with 3.2.3-2.fc16.x86_64 ...

Comment 4 Dave Jones 2012-03-22 16:53:03 UTC
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.

Comment 5 Dave Jones 2012-03-22 16:56:48 UTC
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.

Comment 6 Dave Jones 2012-03-22 17:07:48 UTC
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.

Comment 7 tuxor 2012-03-22 22:53:58 UTC
New kernel update does not resolve the problem.

$ uname -r
3.3.0-4.fc16.x86_64

dmesg output: http://pastebin.com/NYcJE2mM

I plugged in the external hard drive via the esata port, it didn't automount. (At 5621 in dmesg output) I decided to mount it. After that device vanished from /dev/sdb and the LED on the external hard drive changed to red - didn't change back until I unplugged the esata cable.

Any other information needed?

Comment 8 sgtphou 2012-03-28 22:02:20 UTC
I am also seeing this problem. I did not see it before 3.3.* kernels.

Kernel: 3.3.0-4.fc16.x86_64

Hardware: Drobo S eSATA enclosure

Problem:
 1) Boot system, turn on disk, wait for it to do its checks, check dmesg that sdb shows up
 2) Command: sudo mkdir /media/drobo ; sudo mount -v /dev/sdb1 /media/drobo
 3) Use disk as normal
 4) I want to sleep the system, so I unmount the drive, power it down, and then sleep my system
 5) Upon resuming, dmesg never shows any hint that it is even aware the enclosure is there. Mount not possible.
 6) After a few minutes, the drive enters power standby mode, which is what it does when it is not physically connected to an eSATA port

If I reboot, I can mount it. Once I sleep one time, I am unable to even see the device in any way until after I reboot.

What other information can I provide to help?

Comment 9 sgtphou 2012-04-04 23:23:43 UTC
I still have this issue on 3.3.0-8.fc16.x86_64. In addition, I was able to get this to happen by:

 1) Booting
 2) Putting the system to sleep (never powered on the drobo at all)
 3) Resume, power on the drobo, and it goes into low power mode. There are no dmesg lines whatsoever indicating that it ever saw the enclosure.

Comment 10 tuxor 2012-04-05 07:22:48 UTC
I'm not sure, whether your problem actually corresponds to the bug described in this thread. If I understand you right, your problem has to do with sleep mode. But my problem is entirely unrelated with sleep mode. I simply plug in an esata drive and as soon as I try mounting it, its corresponding /dev/sd* vanishes.

By the way still there with 3.3.0-8 ...

Comment 11 tuxor 2012-04-15 14:50:50 UTC
/dev/sd* still vanishing whenever trying to mount it and many errors of type:

device descriptor read/64, error -71
device not accepting address 4, error -71

...with kernel 3.3.1-5.fc16.x86_64

Comment 12 sgtphou 2012-04-22 17:15:31 UTC
The issue I was describing regarding the drobo, which may or not be entirely related, has been resolved with kernel 3.3.2-1.fc16.x86_64.

Comment 13 tuxor 2012-04-22 18:00:40 UTC
Created attachment 579326 [details]
dmesg from F17 beta i686 livecd

For me it's still the same with the latest kernel update. But I've booted into Fedora 17 i686 Beta LiveCD (which brings kernel 3.3.0) and there everything works fine (see attached dmesg output and compare to other dmesg logs above).

So the error doesn't seem to be related to the kernel version. The reason is still obscure. One possibility is, that I was using a 32bit livecd (my local system is F16 x86_64). Or maybe there is some kind of conflict between some software on my local F16 system.

As soon as final Fedora 17 is out I'm going for a reinstall and report back whether it changed something. I'm gonna close this bug if Fedora 17 x86_64 solves this issue.

Comment 14 tuxor 2012-05-06 14:44:45 UTC
I migrated my whole system to Fedora 17 now. Everything is working fine here. Since nobody else is having this bug and I won't able to provide any further information about F16 compatibility, I close this bug.

Feel free to reopen if you keep experiencing the same issue.


Note You need to log in before you can comment on or make changes to this bug.