Bug 77083 - A bar chart report only shows numbers
A bar chart report only shows numbers
Status: CLOSED DEFERRED
Product: Bugzilla
Classification: Community
Component: Test (Show other bugs)
2.17
i386 Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: David Lawrence
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-31 17:20 EST by Göran Uddeborg
Modified: 2007-04-18 12:48 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-02 11:10:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The resulting report (3.89 KB, image/png)
2002-10-31 17:20 EST, Göran Uddeborg
no flags Details

  None (edit)
Description Göran Uddeborg 2002-10-31 17:20:06 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
Trying to do a bar chart gave me a picture with only distributed numbers in the
chart.  No bars as far as I could see.  And I don't understand what the numbers
would mean, the whole thing seems broken.

How reproducible:
Always

Steps to Reproduce:
1.Try the graphical report
2.Select component on vertical axis
3.Select resolution on horizontal axis
4.Select format "bar chart"
5.Select "plot data sets" individually
6.Select bugs with reporter goeran@uddeborg.pp.se
7.Generate
	

Actual Results:  The resulting picture is enclosed.
Comment 1 Göran Uddeborg 2002-10-31 17:20:53 EST
Created attachment 82965 [details]
The resulting report
Comment 2 David Lawrence 2002-12-02 00:49:46 EST
Problem is with resolution I would imagine. Please try this with a smaller list
of components and see if the bars become visible properly. Looks like it is
trying to squeeze alot of info into a small area. The resolution is hard coded
and would need to be changed upstream in the mainline Bugzilla code.
Comment 3 Göran Uddeborg 2002-12-02 07:53:57 EST
Is the URL still https://bugzilla.redhat.com/rh-bugzilla-beta3/ ?

I've tried to reach it a few times during the weekend.  (Because a comment from
you on the 26:th which seems to have been removed again.)  But only got error
messages back.  I'm not sure if it has been the same message all times, but
right now it says:

Bugzilla is currently broken. Please try again later. If the problem persists,
please contact dkl@redhat.com. The error you should quote is: FATAL 1:  Database
"bugs_rc1" does not exist in the system catalog. at globals.pl line 124.
Comment 4 David Lawrence 2002-12-02 10:38:18 EST
Oops. Sorry it is now https://bugzilla.redhat.com/rh-bugzilla-rc2.
Comment 5 Göran Uddeborg 2002-12-02 11:10:04 EST
Yes, that worked better.  And fter stripping down to just 9 packages, I could
see the bars.

If possible, I think it would be nice with some kind of warning about this in
the  bugzilla interface.  If the warning comes up only when applicable, only
when I have choosen too many packages, that would of course be best.  It wasn't
obvious to me I was choosing too many packages, and somebody else might make the
same mistake.

But in any case, your assumption about the cause of the problem seems to have
been correct.
Comment 6 David Lawrence 2002-12-02 11:29:43 EST
This should actually be reported in the upstream Bugzilla tree since the person
who originally re-wrote the new charting tool, may  have not realized the effect
when alot of components are chosen. I have filed a bug at bugzilla.mozilla.org
with this info so please follow along there.

http://bugzilla.mozilla.org/show_bug.cgi?id=183017
Comment 7 Göran Uddeborg 2002-12-02 12:06:11 EST
So this is a standard function of Bugzilla!  That was new to me.  (I'll have to
check if we have that at our installation at work! :-)

I'm CC:ing myself on the mozilla.org version.

Note You need to log in before you can comment on or make changes to this bug.