Bug 770995 - unable to login via serial console
Summary: unable to login via serial console
Keywords:
Status: CLOSED DUPLICATE of bug 691374
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: 16
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: systemd-maint
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-12-30 21:46 UTC by Vlad
Modified: 2012-01-02 13:50 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-01-02 13:50:46 UTC


Attachments (Terms of Use)

Description Vlad 2011-12-30 21:46:16 UTC
systemd is configured to launch getty on ttyS0 according to 
http://fedoraproject.org/wiki/QA:Testcase_Anaconda_User_Interface_serial_console
I see login prompt over serial console, and able to enter username for the first login attempt, however when entering a password, each pressing any key accepted as pressing the enter key. The following login prompt starts to acts by pressing enter as soon as a key pressed, untill getty restarted. 

Essentially, can't log in. Tried on multiple real and virtual servers.
Getty invoked as
/sbin/agetty -s ttyS0 115200 38400 9600
minicom from remote server is invoked using the correct com port speed/connection info.


Fedora release 16 (Verne)
Kernel 3.1.6-1.fc16.i686 on an i686 (ttyS0)

srv login: vlad
Password:
Login incorrect

login:
Password:
Login incorrect

login:
Password:
Login incorrect

login:
Password:

Login incorrect

Fedora release 16 (Verne)
Kernel 3.1.6-1.fc16.i686 on an i686 (ttyS0)

Comment 1 Michal Schmidt 2012-01-02 13:50:46 UTC
The symptoms match a known plymouth bug.

Please reopen if it turns out it's not the same problem.

*** This bug has been marked as a duplicate of bug 691374 ***


Note You need to log in before you can comment on or make changes to this bug.