Bug 771017 - log rotation
Summary: log rotation
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: munin
Version: el6
Hardware: noarch
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-12-31 07:34 UTC by Zied Fakhfakh
Modified: 2012-03-01 09:32 UTC (History)
3 users (show)

Fixed In Version: munin-1.4.6-5.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-03-01 09:31:22 UTC
Type: ---


Attachments (Terms of Use)

Description Zied Fakhfakh 2011-12-31 07:34:17 UTC
Description of problem:
After log rotation, the files:
- munin-graph.log,
- munin-html.log,
- munin-limits.log,
- munin-update.log
becomes unreadable to munin agent (I guess nobody):
- permissions: 640
- owner: munin
- group adm

Version-Release number of selected component (if applicable):
munin-1.4.6-4.el6.2.noarch

How reproducible:
every log rotation

Steps to Reproduce:
1. every rotation of munin logs
2.
3.
  
Actual results:
[root@www ~]# ll /var/log/munin/
total 760
-rw-r----- 1 munin adm   336359 Dec 31 08:30 munin-graph.log
-rw-r--r-- 1 munin munin 197073 Dec 30 03:08 munin-graph.log-20111230.gz
-rw-r----- 1 munin adm    15440 Dec 31 08:30 munin-html.log
-rw-r--r-- 1 munin munin   6574 Dec 30 03:08 munin-html.log-20111230.gz
-rw-r----- 1 munin adm    11328 Dec 31 08:30 munin-limits.log
-rw-r--r-- 1 munin munin   4091 Dec 30 03:08 munin-limits.log-20111230.gz
-rw-r----- 1 root  root    5075 Dec 31 08:30 munin-node.log
-rw-r--r-- 1 root  root   12464 Dec 30 03:08 munin-node.log-20111230.gz
-rw-r----- 1 munin adm    15930 Dec 31 08:30 munin-update.log
-rw-r--r-- 1 munin munin  34509 Dec 30 03:08 munin-update.log-20111230.gz

Expected results:
better keep them property of munin:munin with 644 permissions

Additional info:

Comment 1 Kevin Fenzi 2012-01-02 02:33:13 UTC
Is there an error or issue thats caused by these permissions? 

I wouldn't expect they would need to be read by the munin group after they have been rotated... 

That said, happy to adjust if there is an actual issue.

Comment 2 Zied Fakhfakh 2012-01-02 16:51:45 UTC
Actually yes,
there is a problem with the munin plugin itself (the plugin that generates reports on munin performance) it will be denied from reading the log while that's what it needs.

regards,

Comment 3 Kevin Fenzi 2012-01-11 18:31:37 UTC
Can you try the scratch build at: 

http://koji.fedoraproject.org/koji/taskinfo?taskID=3640136

and let me know if it fixes the issue you are seeing?

Comment 4 Fedora Update System 2012-02-19 21:22:23 UTC
munin-1.4.6-5.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/munin-1.4.6-5.fc16

Comment 5 Fedora Update System 2012-02-19 21:36:45 UTC
munin-1.4.6-5.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/munin-1.4.6-5.fc15

Comment 6 Fedora Update System 2012-02-21 01:29:20 UTC
Package munin-1.4.6-5.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing munin-1.4.6-5.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-2074/munin-1.4.6-5.fc15
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2012-03-01 09:31:22 UTC
munin-1.4.6-5.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2012-03-01 09:32:26 UTC
munin-1.4.6-5.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.