Bug 771351 - Acer eMachines e525 laptop has backlight off
Acer eMachines e525 laptop has backlight off
Status: CLOSED DUPLICATE of bug 752727
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
16
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-03 08:18 EST by Peter Scott
Modified: 2012-10-23 10:02 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-23 10:02:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Scott 2012-01-03 08:18:05 EST
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:7.0.1) Gecko/20111012 Firefox/7.0.1 SeaMonkey/2.4.1

I have an eMachines e525 and FC14 ran properly out of the box with the screen at 1366×768. With FC16 the screen resolution is fixed at 1024x768, everything looks squat and Gnome3 only runs in fallback mode.

Reproducible: Always

Steps to Reproduce:
1. Boot F16
2. Log in
3.
Actual Results:  
Screen resolution is 1024x768. Gnome in fallback mode.

Expected Results:  
Screen resolution is 1366×768. Gnome works

The e525 has the Intel Mobile 4 Series Chipset Integrated Graphics Controller
Comment 1 Peter Scott 2012-02-14 14:53:41 EST
Here is the xrandr from F14:

$ xrandr
Screen 0: minimum 320 x 200, current 1366 x 768, maximum 8192 x 8192
LVDS1 connected 1366x768+0+0 (normal left inverted right x axis y axis) 344mm x 193mm
   1366x768       60.0*+
   1024x768       60.0  
   800x600        60.3     56.2  
   640x480        59.9  
VGA1 disconnected (normal left inverted right x axis y axis)
DP1 disconnected (normal left inverted right x axis y axis)

Here is part of Xorg.0.log from F14:

[    27.354] (II) Loading extension DRI2
[    27.354] (==) Matched intel as autoconfigured driver 0
[    27.354] (==) Matched vesa as autoconfigured driver 1
[    27.354] (==) Matched fbdev as autoconfigured driver 2
[    27.355] (==) Assigned the driver to the xf86ConfigLayout
[    27.355] (II) LoadModule: "intel

With F16, vesa and VGA1 are used. (I will post the xrandr next time I retry F16.)
Comment 2 Peter Scott 2012-02-29 13:25:39 EST
Ignore the previous post!  I hadn't realised that if you do a basic video install an xorg.conf is created to ensure the use of the vesa driver. What I have here is the black screen problem. The brightness up and down controls change the brightness values in /sys/class/backlight/acpi_video0 but the X server never reflects them. I have this in dmesg:

[    3.977219] wmi: Mapper loaded
[   19.815699] acer_wmi: Acer Laptop ACPI-WMI Extras
[   19.816614] acer_wmi: Function bitmap for Communication Device: 0x1
[   19.816619] acer_wmi: Brightness must be controlled by generic video driver

If I do this:

setpci -s 00:02.0 F4.B=0

it turns the screen on until something dims it.

I am using the i915 driver for an Intel GM45 chipset.
Comment 3 Peter Scott 2012-08-15 14:03:19 EDT
Fedora 17 is no better.
Comment 4 Peter Scott 2012-10-23 10:02:51 EDT

*** This bug has been marked as a duplicate of bug 752727 ***

Note You need to log in before you can comment on or make changes to this bug.