This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 771423 - Murmur service won't start
Murmur service won't start
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mumble (Show other bugs)
16
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Christian Krause
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-03 12:35 EST by T. J. Brumfield
Modified: 2012-06-19 11:09 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-19 11:02:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description T. J. Brumfield 2012-01-03 12:35:46 EST
Description of problem:
Out of the box, the murmur service won't run. It won't start as root, nor as a non-root account.

As a root user I get the following output:

<W>2011-12-12 09:02:26.871 Initializing settings from /etc/mumble-server.ini (basepath /etc)
<W>2011-12-12 09:02:26.877 OpenSSL: OpenSSL 1.0.0e-fips 6 Sep 2011
<W>2011-12-12 09:02:26.891 SSL: Adding recommended CA UTN-USERFirst-Client Authentication and Email
<C>2011-12-12 09:02:26.891 Successfully switched to uid 993
<F>2011-12-12 09:02:26.912 ServerDB: Failed initialization: unable to open database file Error opening database

As non-root, the user doesn't have permissions to write a log file to /var/log/mumble-server/mumble-server.log

The default setting in mumble-server.ini seems to be to try and switch to a user account of mumble-server but that user account isn't created when installing the package.

Version-Release number of selected component (if applicable): murmur-1.2.3.5


How reproducible:
Every time

Steps to Reproduce:
1. Install a fresh install of FC16 (may have the same issue on 14/15 but haven't tested)
2. Install murmur
3. Attempt to start the service
  
Actual results:
Service won't start

Expected results:
Service starting

Additional info:
If I edit /etc/mumble-server.ini and comment out the uname setting, I can get it to run as root, but that is a security concern. I imagine the proper fix is to create a mumble-server user account and give it rights to write to the log file, but I don't know if it also needs permissions to other things (such as the sqlite database).
Comment 1 Fedora Update System 2012-06-04 16:42:42 EDT
mumble-1.2.3-7.fc17.1 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/mumble-1.2.3-7.fc17.1
Comment 2 Fedora Update System 2012-06-04 16:46:11 EDT
mumble-1.2.3-5.fc16.1 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/mumble-1.2.3-5.fc16.1
Comment 3 Fedora Update System 2012-06-04 17:08:34 EDT
mumble-1.2.3-4.fc15.1 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/mumble-1.2.3-4.fc15.1
Comment 4 Fedora Update System 2012-06-06 22:46:19 EDT
Package mumble-1.2.3-4.fc15.1:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mumble-1.2.3-4.fc15.1'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-8960/mumble-1.2.3-4.fc15.1
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2012-06-19 11:00:03 EDT
mumble-1.2.3-5.fc16.1 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2012-06-19 11:02:52 EDT
mumble-1.2.3-4.fc15.1 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2012-06-19 11:09:33 EDT
mumble-1.2.3-7.fc17.1 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.