Bug 771445 - [abrt] ibus-1.4.0-11.fc15: connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.Disconnected: Connection was disconnected before a reply was received
[abrt] ibus-1.4.0-11.fc15: connection.py:630:call_blocking:DBusException: org...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
15
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
abrt_hash:d9fca17518d8cf9a4874422f552...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-03 14:25 EST by Mihkel Vain
Modified: 2012-02-25 14:54 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-23 20:42:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mihkel Vain 2012-01-03 14:25:28 EST
abrt version: 2.0.3
architecture:   i686
cmdline:        /usr/bin/python /usr/share/ibus/setup/main.py
comment:        I clicked on ibus preferences link. Nothing happened. So I clicked again several times. Nothing happened. And then ABRT popped up and after a while several ibus preferences windows too.
component:      ibus
executable:     /usr/share/ibus/setup/main.py
kernel:         2.6.41.4-1.fc15.i686.PAE
os_release:     Fedora release 15 (Lovelock)
package:        ibus-1.4.0-11.fc15
reason:         connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.Disconnected: Connection was disconnected before a reply was received
time:           Tue Jan  3 21:21:50 2012
uid:            503
username:       mihkel

backtrace:
:connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.Disconnected: Connection was disconnected before a reply was received
:
:Traceback (most recent call last):
:  File "/usr/share/ibus/setup/main.py", line 569, in <module>
:    setup = Setup()
:  File "/usr/share/ibus/setup/main.py", line 77, in __init__
:    self.__init_ui()
:  File "/usr/share/ibus/setup/main.py", line 252, in __init_ui
:    engines = self.__bus.list_active_engines()
:  File "/usr/lib/python2.7/site-packages/ibus/bus.py", line 142, in list_active_engines
:    engines = self.__ibus.ListActiveEngines()
:  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 140, in __call__
:    **keywords)
:  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 630, in call_blocking
:    message, timeout)
:DBusException: org.freedesktop.DBus.Error.Disconnected: Connection was disconnected before a reply was received
:
:Local variables in innermost frame:
:byte_arrays: False
:self: <dbus.connection.Connection object at 0x8af862c>
:args: ()
:utf8_strings: False
:bus_name: 'org.freedesktop.IBus'
:get_args_opts: {'byte_arrays': False, 'utf8_strings': False}
:object_path: '/org/freedesktop/IBus'
:timeout: -1.0
:signature: ''
:dbus_interface: 'org.freedesktop.IBus'
:message: <dbus.lowlevel.MethodCallMessage object at 0x8a85610>
:method: 'ListActiveEngines'
Comment 1 fujiwara 2012-01-22 21:01:49 EST
(In reply to comment #0)
> :Traceback (most recent call last):
> :  File "/usr/share/ibus/setup/main.py", line 252, in __init_ui
> :    engines = self.__bus.list_active_engines()
> :  File "/usr/lib/python2.7/site-packages/ibus/bus.py", line 142, in
> list_active_engines
> :    engines = self.__ibus.ListActiveEngines()

I cannot reproduce your problem. The bus.list_active_engines() received the bus disconnection in your stack.
Are you still able to reproduce your problem?
Comment 2 Mihkel Vain 2012-01-23 06:50:47 EST
I'm sorry I don't have a Fedora 15 box anymore (upgraded to Fedora 16 couple of days ago) and I can't reproduce it on F16.
Comment 3 fujiwara 2012-01-23 20:42:14 EST
Thank you for your reply.
Comment 4 Maxim 2012-02-25 14:52:47 EST
Same bug on F16 Verne. ABRT don't want to submit it. Tells me it's duplicate. Error was once. I don't know how to reproduce.
Comment 5 Maxim 2012-02-25 14:54:00 EST
connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.Disconnected: Connection was disconnected before a reply was received

Traceback (most recent call last):
  File "/usr/share/ibus/setup/main.py", line 636, in <module>
    setup = Setup()
  File "/usr/share/ibus/setup/main.py", line 77, in __init__
    self.__init_ui()
  File "/usr/share/ibus/setup/main.py", line 249, in __init_ui
    engines = self.__bus.list_active_engines()
  File "/usr/lib/python2.7/site-packages/ibus/bus.py", line 142, in list_active_engines
    engines = self.__ibus.ListActiveEngines()
  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
DBusException: org.freedesktop.DBus.Error.Disconnected: Connection was disconnected before a reply was received

Local variables in innermost frame:
byte_arrays: False
self: <dbus.connection.Connection object at 0x856708c>
args: ()
utf8_strings: False
bus_name: 'org.freedesktop.IBus'
get_args_opts: {'byte_arrays': False, 'utf8_strings': False}
object_path: '/org/freedesktop/IBus'
timeout: -1.0
signature: ''
dbus_interface: 'org.freedesktop.IBus'
message: <dbus.lowlevel.MethodCallMessage object at 0x8707b70>
method: 'ListActiveEngines'

Note You need to log in before you can comment on or make changes to this bug.