Bug 77230 - Installer gave me: OSError: [Errno 12] Cannot allocate memory
Installer gave me: OSError: [Errno 12] Cannot allocate memory
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
8.0
i386 Linux
low Severity low
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-03 15:09 EST by kjellberg
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-11-04 21:03:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description kjellberg 2002-11-03 15:09:10 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; Q312461)

Description of problem:
Here is a typewritten version of what it gave me on the screen (it would not 
save it to floppy):

Traceback (most recent call last):
File "usr/lib/anaconda/gui.py",line 786, in handleRenderCallback
	self.currentWindow.renderCallback()
File "usr/lib/anaconda/iw/progress_gui.py",line 149, in renderCallback
	self.intf.icw.nextClicked()
File "usr/lib/anaconda/gui.py",line 632, in nextClicked
	self.dispatch.gotoNext()
File "usr/lib/anaconda/dispatch.py",line 150, in gotoNext
	self.moveStep()
File "usr/lib/anaconda/dispatch.py",line 215, in moveStep
	rc = apply(func, self.bindArgs(args))
File "usr/lib/anaconda/packages.py",line 430, in turnOnFilesystems
	partitions.doMetaDeletes(diskset)
File "usr/lib/anaconda/partitions.py",line 1110, in doMetaDeletes
	lvm.vgactivate()
File "usr/lib/anaconda/lvm.py",line 54, in vgactivate
	searchPath = 1)
File "usr/lib/anaconda/iutil.py",line 66, in execWithRedirect
	childpid = os.fork()
OSError: [Errno 12] Cannot allocate memory

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start the PC with the 8.0 installer CD in the drive
2. The installer start
3. Go through all the steps prior to the installer installing the product 
(i.e., Choose keyboard, language, mouse, time zone, automatic partitioning of 
drive, removal of all partitions, selecting customized (it does no matter what 
package I select) install), then after it checks for dependencies, it tells me 
it is ready to install. I click Next and the screen is replaced with the screen 
that tells you how many packages and megs are left to install. Before any of 
those fields fill and the installer starts, I get the error dialog that states 
the data mentioned above.

I did run the media check at the very beginning, and the cd checks out fine.

Actual Results:  I get the following error dialog:

Traceback (most recent call last):
File "usr/lib/anaconda/gui.py",line 786, in handleRenderCallback 
	self.currentWindow.renderCallback()
File "usr/lib/anaconda/iw/progress_gui.py",line 149, in renderCallback
	self.intf.icw.nextClicked()
File "usr/lib/anaconda/gui.py",line 632, in nextClicked
	self.dispatch.gotoNext()
File "usr/lib/anaconda/dispatch.py",line 150, in gotoNext
	self.moveStep()
File "usr/lib/anaconda/dispatch.py",line 215, in moveStep
	rc = apply(func, self.bindArgs(args))
File "usr/lib/anaconda/packages.py",line 430, in turnOnFilesystems
	partitions.doMetaDeletes(diskset)
File "usr/lib/anaconda/partitions.py",line 1110, in doMetaDeletes
	lvm.vgactivate()
File "usr/lib/anaconda/lvm.py",line 54, in vgactivate
	searchPath = 1)
File "usr/lib/anaconda/iutil.py",line 66, in execWithRedirect
	childpid = os.fork()
OSError: [Errno 12] Cannot allocate memory

Expected Results:  The installer should have installed correctly. I have Red 
Hat 6.2 on CD. It installs fine. I am able to go into Gnome and work fine. I 
can run the update from the 8.0 CD. The installation appears to run fine, but 
when I try and startx, I get a corruption error.

Additional info:

Again, here are the results:

Traceback (most recent call last):
File "usr/lib/anaconda/gui.py",line 786, in handleRenderCallback 
	self.currentWindow.renderCallback()
File "usr/lib/anaconda/iw/progress_gui.py",line 149, in renderCallback
	self.intf.icw.nextClicked()
File "usr/lib/anaconda/gui.py",line 632, in nextClicked
	self.dispatch.gotoNext()
File "usr/lib/anaconda/dispatch.py",line 150, in gotoNext
	self.moveStep()
File "usr/lib/anaconda/dispatch.py",line 215, in moveStep
	rc = apply(func, self.bindArgs(args))
File "usr/lib/anaconda/packages.py",line 430, in turnOnFilesystems
	partitions.doMetaDeletes(diskset)
File "usr/lib/anaconda/partitions.py",line 1110, in doMetaDeletes
	lvm.vgactivate()
File "usr/lib/anaconda/lvm.py",line 54, in vgactivate
	searchPath = 1)
File "usr/lib/anaconda/iutil.py",line 66, in execWithRedirect
	childpid = os.fork()
OSError: [Errno 12] Cannot allocate memory
Comment 1 Michael Fulbright 2002-11-04 16:36:12 EST
Do you have at least 64M of RAM? This is the minimum requirement of 8.0.
Comment 2 kjellberg 2002-11-04 21:03:46 EST
Have you ever felt dumb for not reading all the requirements? I now do. I will 
throw another stick of RAM in tomorrow and give it another shot. Do you mind if 
this is kept open one more day? Not sure what your required closure time is. I 
have changed the severityto normal.
Comment 3 kjellberg 2002-11-07 10:52:12 EST
Issue resolved. Again, sorry for the unnecessary ticket.

Thanks,

Tait
Comment 4 Michael Lee Yohe 2003-01-09 09:06:32 EST
This appears to be a duplicate of Bug 76123.  The problem is that there is not
enough memory to process the transactions that are to be executed by the
installer.  Anaconda, in GUI mode, requires at least 64M+ of memory and 128M of
swap.  

You can alternatively attempt to install Red Hat Linux 8.0 in text mode by
specifying "linux text" at the SYSLINUX prompt upon first boot.  Anaconda, in
text mode, is more lenient on memory resources.

Note You need to log in before you can comment on or make changes to this bug.