Bug 77272 - ttmkfdir Aborted error message lacks info
ttmkfdir Aborted error message lacks info
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: ttmkfdir (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Yu Shao
David Lawrence
:
: 77491 (view as bug list)
Depends On:
Blocks: 77492
  Show dependency treegraph
 
Reported: 2002-11-04 11:36 EST by Gene Czarcinski
Modified: 2007-04-18 12:48 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-27 14:12:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ttf.cpp.diff (1.62 KB, patch)
2002-11-07 00:48 EST, Yu Shao
no flags Details | Diff
ttmkfdir.cpp.diff (722 bytes, patch)
2002-11-07 00:50 EST, Yu Shao
no flags Details | Diff

  None (edit)
Description Gene Czarcinski 2002-11-04 11:36:50 EST
Description of Problem:
I had a bad .ttf file in a directory with a bunch of good .ttf files.  When I
ran ttmkfdir, the only thing it did was print "Aborted" with no additional
information about what was wrong.  Although I finally figured out that I had a
bad file and which file it was, it took some time.  This is silly.  It should at
least say that it got a bad file and what the file name was.

Version-Release number of selected component (if applicable):


How Reproducible:
always

Steps to Reproduce:
1. In a directory with some good ttf files, do:
  echo adsfasfd >asdasd.ttf
2. run ttmkfdir

Actual Results:
Aborted

Expected Results:
Error with file "asdasd.ttf"

Additional Information:
Comment 1 Mike A. Harris 2002-11-05 04:16:52 EST
Personally, I don't view this as that important to fix since ttmkfdir
is deprecated and will be replaced in the next release of Red Hat Linux
by the mkfontscale program which is part of XFree86 right now.  If
ttmkfdir were sticking around for any length of time, then it would
be something more worthy of fixing.

However...  Yu Shao is maintaining our ttmkfdir, and he might consider
it something worth fixing, or simple to fix, so I've CC'd him for
comment.  If he thinks it is worth fixing and sends me a patch, I'd
be glad to add it to future ttmkfdir builds and XFree86 erratum.

What are your thoughts Yu?

Comment 2 Gene Czarcinski 2002-11-05 13:36:29 EST
Mike, I realize that you are extremely busy juggling all of that XFree86 code
but you really need to advertise deprecated stuff so none of us waste time. 
There is no mention that ttmkfdir is being deprecated in the 8.0 release-notes.

Given that it is deprecated, why didn't you use mkfontscale in 8.0?  I see that
ttmkfdir and mkfontscale do produce different list but I am not sure which is
"correct".  Speaking of different list, will there be something similar to the
ttmkfdir -m parameter.  When I use ttmkfidr -m 100 I get a greatly expanded list
of fonts since some of the fonts have a lot of missing characters.
Comment 3 Yu Shao 2002-11-07 00:47:55 EST
The following patch fixed the problem, and make ttmkfdir default output to
fonts.scale rather than stdout, so any warnings etc will be output to stdout.

Mike, I do see ttmkfdir will be there for sometime, like Juliusz doesn't want to
implement TTCap for XTT, and XTT is really popular for CJK locales. And ttmkfdir
can do anything mkfontscale does.
Comment 4 Yu Shao 2002-11-07 00:48:42 EST
Created attachment 83926 [details]
ttf.cpp.diff
Comment 5 Yu Shao 2002-11-07 00:50:06 EST
Created attachment 83927 [details]
ttmkfdir.cpp.diff
Comment 6 Michael Lee Yohe 2002-11-09 17:27:55 EST
*** Bug 77491 has been marked as a duplicate of this bug. ***
Comment 7 Mike A. Harris 2002-12-19 03:30:24 EST
Just an update...

After much discussion, we have decided afterall to keep ttmkfdir for
the time being.  It is now a separate package and maintained by Yu Shao
officially.  In order to differentiate this a bit from every other
ttmkfdir out there, we've integrated all patches into the actual sources,
removed a bunch of ugliness and packaging hacks, etc. and bumped
the version of ttmkfdir up to 3.0.0.  Rawhide now has this ttmkfdir
package separate, and it should likely be much better now, and in the
future.
Comment 8 Gene Czarcinski 2003-10-27 14:12:00 EST
OBE

Note You need to log in before you can comment on or make changes to this bug.