Bug 772923 - problems with brightness and volume with fedora 16 and thinkpad t60
problems with brightness and volume with fedora 16 and thinkpad t60
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-10 05:59 EST by Davide Corrado
Modified: 2012-09-10 08:57 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-10 08:57:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Davide Corrado 2012-01-10 05:59:53 EST
Description of problem:

the brightness control via function keys is no more working in fedora 16. pressing the function keys for increasing and decreasing the lcd brightness shows the osd on gnome but nothing happens.
the same happens with the function dim screen to save power in the system settings, nothing happens.

perfoming:

echo "1">/sys/class/backlight/acpi_video0/brightness

works as expected

for the volume control i had to add options thinkpad_acpi hotkey=0x00ffffff to the thinkpad_acpi module parameters




Version-Release number of selected component (if applicable):
kernel 3.1.7-1.fc16.i686.PAE
/lib/modules/3.1.7-1.fc16.i686.PAE/kernel/drivers/platform/x86/thinkpad_acpi.ko
license:        GPL
version:        0.24
description:    ThinkPad ACPI Extras


How reproducible:
install f16 on t60. use function keys

  
Actual results:
the lcd brightness does not work
the volume cotrol works with a workaround


Expected results:
everything works

Additional info:
Comment 1 Tom Mannerhagen 2012-01-18 09:01:09 EST
I want to say that I have almost the same issue on my Toshiba Tecra M9.
The hotkeys for brightness are completely dead in my case.
However, they worked with the live image of F16.
After installing and updating the system to current status (current kernel is 3.1.9-1.fc16.i686) the keys stopped working completely.

The other hotkeys work as normal though.
Also the brightness control in the Screen applet of System Settings is gone.

Funny enough it is seen very very briefly when the applet is started, but disappears immediately.

BR Tom
Comment 2 Josh Boyer 2012-09-07 14:05:22 EDT
Is this still being seen with the 3.4 or 3.5 kernels in F16/F17?  If so, could you please attach the output of dmesg and lsmod after a fresh boot?
Comment 3 Tom Mannerhagen 2012-09-10 02:53:54 EDT
Hi Josh

This is currently working for me on my Tecra M9.
Thanks!

PS: as I am looking at Fedora to work 100% on Toshiba's, how and were do I report non-working hot-keys? Here in Bugzilla?

I mean, I believe this is not a Fedora-thing since hotkey-mappings are done somewhere else - upstream in some package? Kernel?

Please advice.

BR Tom
Comment 4 Josh Boyer 2012-09-10 08:57:13 EDT
(In reply to comment #3)
> Hi Josh
> 
> This is currently working for me on my Tecra M9.
> Thanks!

Great.  Thanks for letting us know.

> PS: as I am looking at Fedora to work 100% on Toshiba's, how and were do I
> report non-working hot-keys? Here in Bugzilla?
> 
> I mean, I believe this is not a Fedora-thing since hotkey-mappings are done
> somewhere else - upstream in some package? Kernel?

You can file them in bugzilla, but often it is more expedient to report issues to the platform-driver-x86@vger.kernel.org list directly.

Note You need to log in before you can comment on or make changes to this bug.