Bug 773120 - <para> tags are ignored on txt format
<para> tags are ignored on txt format
Status: CLOSED CURRENTRELEASE
Product: Publican
Classification: Community
Component: publican (Show other bugs)
2.8
All Linux
unspecified Severity high
: 3.0
: ---
Assigned To: Jeff Fearn
Ruediger Landmann
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-10 19:21 EST by Tomas Dabašinskas
Modified: 2012-10-30 23:11 EDT (History)
4 users (show)

See Also:
Fixed In Version: 3.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-30 23:11:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
test book (294.80 KB, application/x-gzip)
2012-01-10 19:21 EST, Tomas Dabašinskas
no flags Details

  None (edit)
Description Tomas Dabašinskas 2012-01-10 19:21:09 EST
Created attachment 551974 [details]
test book

Description of problem:
When I build txt report any new paragraphs are ignored and content is pasted in single line, breaking only when page width exceeded. This works fine for html, html-single and pdf report (haven't tested on epub)

Version-Release number of selected component (if applicable):
version=2.8

How reproducible:
Build txt report

Steps to Reproduce:
1. publican build --formats=txt --langs=en-US
  
Actual results:
This is a test paragraph This is another test paragraph

Expected results:
This is a test paragraph
This is another test paragraph

Additional info:

<chapter>
	<title>Test Chapter</title>
	<para>
		This is a test paragraph
	</para>
        <para>
                This is another test paragraph
        </para>
</chapter>
Comment 1 Ruediger Landmann 2012-03-12 19:48:53 EDT
I can reproduce this in publican-2.8-1.fc16

Moving upstream.
Comment 2 Jeff Fearn 2012-03-15 00:04:41 EDT
This is due to us changing the para tag from P to DIV. Using P allows invalid HTML generation due to nesting. Added work around for txt output.

Pushed To ssh://git.fedorahosted.org/git/publican.git
   c3ba47b..8d1c0c5  master -> master
Comment 3 Misha H. Ali 2012-04-22 17:06:25 EDT
Confirmed text between one pair of para tags appears as a single paragraph and subsequent paras appear as different paragraphs.

OS: Fedora 16
Publican: 3.0
Release designation: publican-3.0-0.fc16.t166.src.rpm

Note You need to log in before you can comment on or make changes to this bug.