Bug 773213 - [abrt][reproducible] libreoffice-core-3.4.4.2-6.fc16 crash moving ole2 object to undo stack
[abrt][reproducible] libreoffice-core-3.4.4.2-6.fc16 crash moving ole2 object...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michael Stahl
Fedora Extras Quality Assurance
abrt_hash:50ab2bc7bb5ace6cda4d69319f9...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-11 04:33 EST by difiado-43
Modified: 2012-09-25 15:55 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-25 15:55:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: dso_list (24.31 KB, text/plain)
2012-01-11 04:33 EST, difiado-43
no flags Details
File: build_ids (8.97 KB, text/plain)
2012-01-11 04:33 EST, difiado-43
no flags Details
File: Untitled 1.odt (18.78 KB, text/plain)
2012-01-11 04:33 EST, difiado-43
no flags Details
File: maps (94.79 KB, text/plain)
2012-01-11 04:33 EST, difiado-43
no flags Details
File: backtrace (59.87 KB, text/plain)
2012-01-11 04:33 EST, difiado-43
no flags Details

  None (edit)
Description difiado-43 2012-01-11 04:33:26 EST
libreport version: 2.0.8
abrt_version:   2.0.7
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/soffice.bin --writer --splash-pipe=7
crash_function: framework::LockHelper::acquireReadAccess
executable:     /usr/lib64/libreoffice/program/soffice.bin
kernel:         3.1.7-1.fc16.x86_64
pid:            25299
pwd:            /home/usuario
reason:         Process /usr/lib64/libreoffice/program/soffice.bin was killed by signal 11 (SIGSEGV)
time:           Wed 11 Jan 2012 07:22:46 AM BRST
uid:            1000
username:       usuario
xsession_errors: 

Untitled 1.odt: Binary file, 19233 bytes
backtrace:      Text file, 61305 bytes
build_ids:      Text file, 9184 bytes
dso_list:       Text file, 24891 bytes
maps:           Text file, 97070 bytes

comment:
:-open document 'Untitled 1.odt'
:-go to item "2 - trabalho remoto"
:-press backspace continuously

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=2
:SSH_AGENT_PID=1558
:HOSTNAME=fenix.casa
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:GPG_AGENT_INFO=/home/usuario/.gnupg/S.gpg-agent:1579:1
:GLADE_PIXMAP_PATH=:
:XDG_MENU_PREFIX=xfce-
:TERM=dumb
:SHELL=/bin/bash
:DESKTOP_STARTUP_ID=xfce4-panel/libreoffice/1595-20-fenix.casa_TIME47723606
:HISTSIZE=1000
:XDG_SESSION_COOKIE=84acca49ed1cfece8025795f00000010-1326164707.696508-362495501
:OLDPWD=/usr/lib64/libreoffice/program
:GNOME_KEYRING_CONTROL=/tmp/keyring-CmqRyO
:IMSETTINGS_MODULE=none
:USER=usuario
:GLADE_MODULE_PATH=:
:SSH_AUTH_SOCK=/tmp/ssh-fEwHwZjl1429/agent.1429
:USERNAME=usuario
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1588,unix/unix:/tmp/.ICE-unix/1588
:XDG_CONFIG_DIRS=/etc/xdg
:MAIL=/var/spool/mail/usuario
:DESKTOP_SESSION=xfce
:PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/usuario/.local/bin:/home/usuario/bin
:QT_IM_MODULE=xim
:PWD=/home/usuario
:XMODIFIERS=@im=none
:LANG=en_US.UTF-8
:GNOME_KEYRING_PID=1425
:GDMSESSION=xfce
:SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass
:HISTCONTROL=ignoredups
:SHLVL=2
:XDG_SEAT=seat0
:HOME=/home/usuario
:SAL_ENABLE_FILE_LOCKING=1
:LOGNAME=usuario
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-pQ2oRCZL5X,guid=eb4ca60d6ea8ebe1a4685b9200000060
:XDG_DATA_DIRS=/usr/local/share:/usr/share
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/usuario
:DISPLAY=:0.0
:GLADE_CATALOG_PATH=:
:LIBGLADE_MODULE_PATH=:
:XAUTHORITY=/var/run/gdm/auth-for-usuario-mvYh2L/database
:LD_LIBRARY_PATH=/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/client:/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/server:/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/native_threads:/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64

smolt_data:
:
:
:General
:=================================
:UUID: 5d035a84-521c-418c-b252-c0b60b82d311
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: x86_64
:BogoMIPS: 4787.26
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM) i5 CPU       M 450  @ 2.40GHz
:CPU Stepping: 5
:CPU Family: 6
:CPU Model Num: 37
:Number of CPUs: 4
:CPU Speed: 2395
:System Memory: 3756
:System Swap: 5791
:Vendor: Dell Inc.
:System: Inspiron N5010 A07
:Form factor: Portable
:Kernel: 3.1.7-1.fc16.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:11362:32902:32902) pci, None, HOST/PCI, Core Processor QuickPath Architecture Generic Non-core Registers
:(32902:11521:32902:32902) pci, None, HOST/PCI, Core Processor QuickPath Architecture System Address Decoder
:(32902:68:4136:1095) pci, agpgart-intel, HOST/PCI, Core Processor DRAM Controller
:(32902:11536:32902:32902) pci, None, HOST/PCI, Core Processor QPI Link 0
:(32902:11537:32902:32902) pci, None, HOST/PCI, Core Processor QPI Physical 0
:(32902:11538:32902:32902) pci, None, HOST/PCI, Core Processor Reserved
:(32902:11539:32902:32902) pci, None, HOST/PCI, Core Processor Reserved
:(32902:15152:4136:1095) pci, i801_smbus, SERIAL, 5 Series/3400 Series Chipset SMBus Controller
:(32902:15151:4136:1095) pci, ahci, STORAGE, 5 Series/3400 Series Chipset 6 port SATA AHCI Controller
:(32902:15115:4136:1095) pci, None, PCI/ISA, Mobile 5 Series Chipset LPC Interface Controller
:(32902:15154:4136:1095) pci, intel ips, NONE, 5 Series/3400 Series Chipset Thermal Subsystem
:(32902:15174:4136:1095) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 3
:(32902:9288:4136:1095) pci, None, PCI/PCI, 82801 Mobile PCI Bridge
:(5348:18215:4136:16) pci, brcmsmac, NETWORK, XPS 8300
:(32902:15164:4136:1095) pci, ehci_hcd, USB, 5 Series/3400 Series Chipset USB2 Enhanced Host Controller
:(32902:15156:4136:1095) pci, ehci_hcd, USB, 5 Series/3400 Series Chipset USB2 Enhanced Host Controller
:(32902:15204:4136:1095) pci, None, SIMPLE, 5 Series/3400 Series Chipset HECI Controller
:(32902:70:4136:1095) pci, i915, VIDEO, Core Processor Integrated Graphics Controller
:(32902:15170:4136:1095) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 1
:(32902:15172:4136:1095) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 2
:(32902:15178:4136:1095) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 5
:(32902:15190:4136:1095) pci, snd_hda_intel, MULTIMEDIA, 5 Series/3400 Series Chipset High Definition Audio
:(4332:33078:4136:1095) pci, r8169, ETHERNET, RTL8101E/RTL8102E PCI Express Fast Ethernet controller
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg_fenix-lv_root / ext4 4096 4096 4709051 2425645 2377817 1196032 1020803 1020803
:/dev/sda5 /boot ext4 1024 1024 495844 435313 409713 128016 127786 127786
:

var_log_messages:
:Jan 10 19:22:56 fenix kernel: [ 4571.800709] soffice.bin[3498]: segfault at 0 ip 00007f93ffc0030c sp 00007fff10391b38 error 4 in libfwilx.so[7f93ffbe4000+2e000]
:Jan 10 19:22:58 fenix abrt[3537]: Saved core dump of pid 3498 (/usr/lib64/libreoffice/program/soffice.bin) to /var/spool/abrt/ccpp-2012-01-10-19:22:56-3498 (107028480 bytes)
:Jan 10 20:16:43 fenix kernel: [ 7792.612525] soffice.bin[4137]: segfault at 0 ip 00007f1f3f01630c sp 00007fff75333a98 error 4 in libfwilx.so[7f1f3effa000+2e000]
:Jan 10 20:16:44 fenix abrt[4157]: Saved core dump of pid 4137 (/usr/lib64/libreoffice/program/soffice.bin) to /var/spool/abrt/ccpp-2012-01-10-20:16:43-4137 (99311616 bytes)
:Jan 10 23:01:25 fenix kernel: [17658.135914] soffice.bin[9050]: segfault at 0 ip 00007ff191da230c sp 00007fff2f2ec5d8 error 4 in libfwilx.so[7ff191d86000+2e000]
:Jan 10 23:01:27 fenix abrt[9097]: Saved core dump of pid 9050 (/usr/lib64/libreoffice/program/soffice.bin) to /var/spool/abrt/ccpp-2012-01-10-23:01:25-9050 (118226944 bytes)
:Jan 11 07:22:46 fenix kernel: [47688.367649] soffice.bin[25299]: segfault at 0 ip 000000376ac1c30c sp 00007fff8138bc88 error 4 in libfwilx.so[376ac00000+2e000]
:Jan 11 07:22:48 fenix abrt[25322]: Saved core dump of pid 25299 (/usr/lib64/libreoffice/program/soffice.bin) to /var/spool/abrt/ccpp-2012-01-11-07:22:46-25299 (109944832 bytes)
Comment 1 difiado-43 2012-01-11 04:33:30 EST
Created attachment 552047 [details]
File: dso_list
Comment 2 difiado-43 2012-01-11 04:33:33 EST
Created attachment 552048 [details]
File: build_ids
Comment 3 difiado-43 2012-01-11 04:33:35 EST
Created attachment 552049 [details]
File: Untitled 1.odt
Comment 4 difiado-43 2012-01-11 04:33:38 EST
Created attachment 552050 [details]
File: maps
Comment 5 difiado-43 2012-01-11 04:33:40 EST
Created attachment 552051 [details]
File: backtrace
Comment 6 Caolan McNamara 2012-01-11 08:58:38 EST
m_pSolarMutex->acquire(); is the final line, reproducible. Looks like ole2 stuff and undo stack related.
Comment 7 Michael Stahl 2012-09-25 15:55:55 EDT
i can make LO 3.4.3 crash like that but not current 3.5/3.6/master.

can't make much of the stack trace.

if you can reproduce somehow with 3.5 or later please reopen.

Note You need to log in before you can comment on or make changes to this bug.