Bug 77363 - segmentation fault in the 'panel' module when start X after using kernel parameter BIGPAGES=2048M for Oracle
segmentation fault in the 'panel' module when start X after using kernel para...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: XFree86 (Show other bugs)
2.1
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-05 16:28 EST by Boris Mironov
Modified: 2007-11-30 17:06 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-11-06 18:04:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Requested config files and system logs (39.50 KB, application/octet-stream)
2002-11-06 12:09 EST, Boris Mironov
no flags Details

  None (edit)
Description Boris Mironov 2002-11-05 16:28:39 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; T312461)

Description of problem:
I can not start X session because of 'segmentation fault' in the 'panel' 
module. It has started happening after I set kernel parameter 'bigpages=2048M' 
for Oracle.

Current system has 2 Xeon CPUs, ATI Rage XL, 4Gb of RAM and after restart it 
has about 1Gb of free memory (regarding to the 'free' command). 'swap' shows no 
usage of 8Gb swap at same time.

Very interesting thing about it that if I will try to 'startx' system will:
- hang for my session (from initlevel 3)
- I will not be able to use 'ps -elf' from any other terminal (it will hang 
right away without any output)
- I will not be able to use 'top' from any other terminal (it will hang right 
after the output of 'white page header')
- I will be able to 'telnet'
- Oracle will work fine
All of this at same time.

Version-Release number of selected component (if applicable):
the system is up-to-date on November 05, 2002 (regarding to RehHat network)


How reproducible:
Always

Steps to Reproduce:
1. set kernel parameter 'bigpages=2048M'
2. start oracle
3. startx
	

Actual Results:  startx will be very slow to start X session (on init screen 
with lighthouse)

bottom panel (with Gnome-logo) will be shown as gray stripe across the screen

nautilus will not be started

Additional info:

I have to have X on my Oracle server to use Administrator tools (java-
applications)


Do not hesitate to contact me if you need more information.

Thanks in any advise,
Boris Mironov
email: bmironov@jonview.com
Comment 1 Mike A. Harris 2002-11-06 06:21:19 EST
Can you attach your X server config file, your X log file, your /var/log/messages
file, and the output of:

cat /proc/version
lspci -vvn
lsmod
Comment 2 Boris Mironov 2002-11-06 12:09:06 EST
Created attachment 83867 [details]
Requested config files and system logs
Comment 3 Boris Mironov 2002-11-06 12:11:03 EST
Here is requested information about my system (DELL PowerEdge 4600) as an
attachment 'phoenix.tar.gz'.

Thanks in advance,
Boris Mironov
email: bmironov@jonview.com
Comment 4 Boris Mironov 2002-11-06 12:45:40 EST
The problem in the subject of the bug happened on Nov 1 at 11:45am.
After that I've lost ability to use local keyboard and mouse, but telnet 
sessions were Ok.

At noon I've restarted whole system by pressing 'Reset' button.


Hope, it will help with system logs.
Comment 5 Mike A. Harris 2002-11-06 12:46:58 EST
Thanks for the info.  One request though...  in the future, please attach
all files as individual uncompressed file attachments one at a time.  That
facilitates viewing them easily in a web browser.
Comment 6 Mike A. Harris 2002-11-06 12:47:48 EST
Changing component to XFree86, as this is not a 3.3.6 bug report.
Comment 7 Mike A. Harris 2002-11-06 13:02:33 EST
I've looked at your logs, and don't see anything noteable.  Not even
a sign of an XFree86 crash in your X log.  Are you sure this log is
from after a crash?  If you start up X again after a crash, it will
wipe out the log, so you need to snag a copy of the log without starting
up X.

Also, I'm not sure what you are refering to as the "panel".  Is this
the GNOME panel?  If GNOME is crashing, that isn't an XFree86 bug.

I've CC'd a couple of our GNOME guys for comment also.
Comment 8 Boris Mironov 2002-11-06 13:16:52 EST
I am not sure that it is exactly XFree86 bug. Probably, it is not (because I 
see blue background /*not black and white*/, some elements of desktop, etc...). 
Sorry, my mistake.

The XFree86.0.log is exact log that has been written on crush time (Nov 1, 
11:49am). Since then I did not start X again.

By "Panel" I refer to Gnome-panel ("with Gnome-logo" foot).
Comment 9 Mike A. Harris 2002-11-06 13:26:08 EST
On a side note, separate from the bug report..

You do realize you can use X on a different machine, and run Oracle
tools via "ssh -X" remotely, without requiring an X server on the Oracle
machine?

Just thought I'd mention that in case you weren't aware.  It could be
a useful workaround for now for you.
Comment 10 Mike A. Harris 2002-11-06 13:27:03 EST
Owen, Havoc:  Any comments?  I don't see any XFree86 problem here, but
before reassigning to gnome-panel I wanted to get your opinions.

TIA
Comment 11 Boris Mironov 2002-11-06 13:34:54 EST
Thanks, It is really good idea!
But I feel bad about existance of the problem in new production system.

... and posting little yellow note on the rack:
"Do not 'startx' on this server or I will fire at will"

(just kidding)
Comment 12 Owen Taylor 2002-11-06 14:37:07 EST
It's hard to tell here ... the useful file would be ~/.xsession-errors
user from the user that you tried in as.

It would be also useful to know if you could log in with a different
user.

Is the 'bigpages' command and starting oracle relevant? If you reboot
and don't do that, can you log in OK? If so, then it's almost certainly
a kernel or possibly an X bug.
Comment 13 Boris Mironov 2002-11-06 16:53:48 EST
Hello again,

I was calling RedHat tech support.
It seems now as misconfiguration of shm. Probably, this is the cause of 
the 'segmentation fault' error (shm was configured to be bigger than size of 
physical memory + swap).

For now, I guess, we can close this bug and if problem reappears I will create 
another one.

Thanks a lot,
Boris Mironov
email: bmironov@jonview.com
Comment 14 Boris Mironov 2002-11-06 18:04:44 EST
P.S. Another misconfiguration of my system (regarding to RedHat tech. support) 
was incorrect kernel. It is recommended to use the 'Enterprise' kernel in the 
system with 4Gb+ of virtual memory /* not the 'SMP'-kernel */.

My system has 4Gb of RAM and 8Gb of swap.
Comment 15 Mike A. Harris 2002-11-07 08:15:17 EST
You've indicated your system has been misconfigured, and that you've
now worked things out, so I'm closing this as NOTABUG.

Thanks for providing the updated information.
Comment 16 Boris Mironov 2002-11-07 11:04:34 EST
Sounds good!
Let's close it as NOTABUG!

Thanks a lot,
Boris Mironov
email: bmironov@jonview.com

Note You need to log in before you can comment on or make changes to this bug.