Bug 77490 - vim
Summary: vim
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: vim   
(Show other bugs)
Version: 8.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Karsten Hopp
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-07 21:59 UTC by erik
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-11-07 21:59:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description erik 2002-11-07 21:59:43 UTC
Description of Problem:
vim is missing dependency on libperl

Version-Release number of selected component (if applicable):
Vim 6.1-14

How Reproducible:
Always

Steps to Reproduce:
1. Install vim-6.1-14
2. perl-5.6.1-26.72.3
3. Start vim

Actual Results:

vim: error while loading shared libraries: libperl.so: cannot open shared 
object file: No such file or directory

Expected Results:


Additional Information:

Comment 1 Karsten Hopp 2002-11-07 22:40:57 UTC
vim-6.1-14 already has a dependency for libperl.so which perl-5.6.1-26.72.3 
from 7.2/updates could not satisfy (it only provides libperl.a). 
Are you sure that none of your packages has been installed with --force or --nodeps ? 
 
>rpm -q vim-enhanced 
vim-enhanced-6.1-14 
 
>rpm -q --requires vim-enhanced | grep libperl.so 
libperl.so 
 
>rpm -qpl perl-5.6.1-26.72.3.i386.rpm | grep libperl 
/usr/lib/perl5/5.6.1/i386-linux/CORE/libperl.a 
 
>rpm -qp --provides  perl-5.6.1-26.72.3.i386.rpm | grep libperl 
> 



Note You need to log in before you can comment on or make changes to this bug.