Bug 77587 - Truetype fonts not seen by font selector
Truetype fonts not seen by font selector
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: gnome-core (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Jay Turner
:
: 77586 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-09 16:09 EST by Scott Otterson
Modified: 2015-01-07 19:01 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-11-09 18:04:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Otterson 2002-11-09 16:09:02 EST
The gnome font selector at

 redhat menu -> preferences -> font

does not list any of my True Type fonts even though I've installed them in a
couple of ways.  First, I've copied them from my win2k partition and notified
xft about them i.e.

        su
        mkdir /usr/X11R6/lib/X11/fonts/msTrueType
        cp  /win2k/WINDOWS/FONTS/* /usr/X11R6/lib/X11/fonts/msTrueType
        cd /usr/X11R6/lib/X11/fonts/msTrueType
        ttmkfdir > fonts.scale
        mkfontdir

and then adding the line:

        /usr/X11R6/lib/X11/fonts/msTrueType,  

to my /etc/X11/fs/config file.  After this step, galeon is able to display with,
for example the georgia TTF.  However, georgia doesn't show up in the gnome font
menu.

The second way I tried to install fonts was to make a symbolic link in my home
dir i.e.
Comment 1 Scott Otterson 2002-11-09 17:15:12 EST
Please ignore this bug.  Somehow, galeon is submitting when I hit the tab key!
Comment 2 Havoc Pennington 2002-11-09 18:04:51 EST
*** Bug 77586 has been marked as a duplicate of this bug. ***
Comment 3 Havoc Pennington 2002-11-09 18:07:01 EST
Not a bug, just a FAQ answered a number of times on psyche-list.

(Short answer, put the ttf fonts in /usr/share/fonts or ~/.fonts 
and run fc-cache)

Note You need to log in before you can comment on or make changes to this bug.