Bug 77617 - aspell with -H option does not work
aspell with -H option does not work
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: aspell (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-10 21:21 EST by Malcolm Tredinnick
Modified: 2007-04-18 12:48 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-19 16:19:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Reasonably small test case (1.46 KB, text/plain)
2003-01-07 12:16 EST, Stephen Samuel
no flags Details

  None (edit)
Description Malcolm Tredinnick 2002-11-10 21:21:42 EST
Description of Problem:

Whenever I run 'aspell -c -H blah.xml' on a Docbook-style document, it does not
get to the point of presenting me with options to correct spelling errors.


Version-Release number of selected component (if applicable): aspell-0.33.7.1-16


How Reproducible: always


Steps to Reproduce:
1. Grab an XML document. One that is publicly available that I know fails is in
gnome-devel-docs/tutorials/i18n/C/i18n-guide.xml in the GNOME CVS repository.
2. Run 'aspell -c -H i18n-guide.xml'
3. You will need to ^C the application eventually, since it does nothing.

Actual Results:

The application appears to just hang, but eventually the disks start grinding
away (swapping). Running strace on the process shows that it gets stuck
requesting more and more memory (lots of brk(...) system calls one after another).


Expected Results:

The document above certainly has spelling errors in it, particularly if you use
the standard dictionary. So I would expect to see the screen come up that
reports misspelt words and gives options for correcting them.

Additional Information:

(1) Running the same command on the same document on Red Hat 7.3 machines
(aspell-0.33.7.1-9) works perfectly. The "corrections screen" comes up after
only a couple of seconds. I was previously using aspell a lot on these boxes and
never saw the above problem.

(2) Running the same command on four different Red Hat 8.0 installations (with
different CPU and memory configurations) shows the behaviour in this report.

(3) Running the command 'aspell -c i18n-guide.xml' brings up the "corrections
screen" almost instantly (just as on Red Hat 7.3), however, since it does not
know that this is an SGML-style document, it complains about most of the tags
and their attributes being misspelt, so this is not an acceptable workaround.
Comment 1 Doran Barton 2002-12-08 15:32:36 EST
I am seeing the same behavior. strace shows gobs and gobs of brk() calls
whenever I try to run 'aspell' on a .html file.
Comment 2 Stephen Samuel 2003-01-07 12:13:04 EST
Similar results here. when I run it in --list mode, it works fine. I'm attaching
a sample file.  When I name the file emb, it works fine, when I check it as
emb.html, I get the same result... infinite loop allocating 4K chunks via break.

One interesting thing is that the file doesn't generate any error messages for
me in --list mode, so it can't be choking on the 'display errors' section (it
also failed when I had mispellings).

The wierd thing is that an adb traceback seems to indicate that it's doing this
inside of free (!).

(gdb) back
#0  0x42074a27 in free () from /lib/i686/libc.so.6
#1  0x4015bde3 in operator delete(void*) (ptr=0x0)
    at ../../../../libstdc++-v3/libsupc++/del_op.cc:39
#2  0x4009a338 in
afilter::MapReplReadError::expecting_keyword::~expecting_keyword() () from
/usr/lib/libaspell.so.10
#3  0x4009914b in autil::GenericCopyPtr<afilter::MapReplReadError::error,
autil::ClonePtr<afilter::MapReplReadError::error>::Parms>::~GenericCopyPtr() ()
   from /usr/lib/libaspell.so.10


(backtrace goes to #14).


Dies under Redhat 8.0   seems to work fine under 7.2 and 7.3

for 8.0:
[samuel@algh1188y43bi slash]$ rpm -qa | grep -i spell
pspell-0.12.2-14
aspell-en-ca-0.33.7.1-16
gnome-spell-0.4.1-4
aspell-0.33.7.1-16
aspell-en-gb-0.33.7.1-16

for 7.3:
[samuel@reality samuel]$ rpm -qa | grep -i spell
pspell-0.12.2-8
gnome-spell-0.4.1-0.7x
aspell-0.33.7.1-9

Comment 3 Stephen Samuel 2003-01-07 12:16:17 EST
Created attachment 89188 [details]
Reasonably small test case 

kills aspell as emb.html, but not as emb.

In the latter case, it claims no spelling errors. (also dies with spelling
errors)
Comment 4 Eido Inoue 2003-02-19 16:19:24 EST
aspell will be upgraded in the next release

Note You need to log in before you can comment on or make changes to this bug.