Bug 7764 - should use "unsigned short" for cylinders on IDE drives
should use "unsigned short" for cylinders on IDE drives
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-12-12 02:17 EST by Marty Shannon
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-27 22:36:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marty Shannon 1999-12-12 02:17:19 EST
Most of the large drives have more than 32767 cylinders, which display in
/etc/sysconfig/hwconf as negative numbers.
Comment 1 Riley H Williams 1999-12-12 16:52:59 EST
Some also have more than 65,535 cylinders, which exceeds the limit of the
unsigned short that you propose. It seems to me that there is already a need to
move to 32-bit for this value - and, since negative numbers make no sense here,
we should switch to unsigned at the same time.
Comment 2 Bill Nottingham 1999-12-17 17:20:59 EST
The values in /etc/sysconfig/hwconf are
taken from /proc/ide/<device>/geometry...
they come straight from the kernel.
Comment 3 Cristian Gafton 2000-01-04 17:27:59 EST
Assigned to dledford
Comment 4 Eric Smith 2000-06-27 22:36:04 EDT
The kernel also had problems with IDE drives with more than 64k cylinders, until
version 2.2.14.  The recent errata kernels are 2.2.14 and 2.2.16 so they're OK,
but in order to install onto a large drive (e.g., Maxtor 60G), boot images with
the newer kernel would be needed.  Any chance of new boot images showing up in
Updates in the near future?

Note You need to log in before you can comment on or make changes to this bug.