Bug 779156 - (SOA-1551) No re-deployment of an altered package
No re-deployment of an altered package
Status: CLOSED NEXTRELEASE
Product: JBoss Enterprise SOA Platform 5
Classification: JBoss
Component: JBossESB (Show other bugs)
5.0.0 ER1
Unspecified Unspecified
high Severity high
: ---
: 5.0.0 GA,5.0.0 ER8
Assigned To: trev
http://jira.jboss.org/jira/browse/SOA...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-26 04:20 EDT by Lukáš Petrovický
Modified: 2010-02-05 03:44 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-05 03:44:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker SOA-1551 None None None Never

  None (edit)
Description Lukáš Petrovický 2009-10-26 04:20:15 EDT
Date of First Response: 2009-12-09 05:41:41
project_key: SOA

See JBESB-2912
Comment 1 Lukáš Petrovický 2009-10-26 04:20:31 EDT
Link: Added: This issue depends JBESB-2912
Comment 2 trev 2009-12-09 05:41:41 EST
Trev to get more info for Kev
Comment 3 Burr Sutter 2009-12-21 21:23:52 EST
If the .esb archive is deployed zipped then it "sees" updates to jboss-esb.xml file
if the .esb archive is deployed exploded then changes to jboss-esb.xml are ignored
The IDE uses the exploded variation and those changes are not seen.
Comment 4 Kevin Conner 2010-01-06 04:16:26 EST
Link: Added: This issue is a dependency of JBIDE-5534
Comment 5 Max Rydahl Andersen 2010-01-08 07:45:14 EST
Just to be clear, the IDE can use both exploded and non-exploded deployment - we just default to exploded since that is (normally) more efficient (i.e. copying  a few bytes vs MB's of jar)

Comment 6 Tom Fennelly 2010-01-12 08:05:17 EST
ESB install scripts updated to mod the profile.xml and include jboss-esb.xml in the mod filter bean's regex for AS5 based targets (which includes SOA-5).  Changes committed.
Comment 7 Tom Fennelly 2010-01-12 08:06:22 EST
Ooops... typo in last comment.  Should have said "which includes SOA-P".
Comment 8 Kevin Conner 2010-01-14 04:57:43 EST
This should be present in ER7
Comment 9 Kevin Conner 2010-01-15 09:59:00 EST
Sorry, I thought you were installing ESB directly into the server but have just found out that there is a copy stage inbetween.

You will need to add the profile.xml to your copy stage in order to pick up Tom's fix.
Comment 10 trev 2010-01-18 07:07:05 EST
committed builders/eap/post-patch/patch_bootstrap_profile.xml Rev 4801

If we change the build to use the esb install process to install directly into esb, this needs removing
Comment 11 Lukáš Petrovický 2010-02-05 03:44:21 EST
Re-deployment works as expected in ER8.

Note You need to log in before you can comment on or make changes to this bug.