Bug 779161 - (SOA-1556) jaxb-xjc.jar missing in soap.esb
jaxb-xjc.jar missing in soap.esb
Status: CLOSED NEXTRELEASE
Product: JBoss Enterprise SOA Platform 5
Classification: JBoss
Component: JBossESB (Show other bugs)
5.0.0 ER1
Unspecified Unspecified
high Severity high
: ---
: 5.0.0 GA,5.0.0 ER5
Assigned To: Kevin Conner
http://jira.jboss.org/jira/browse/SOA...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-26 07:59 EDT by Boris Belovic
Modified: 2010-01-03 12:37 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-03 12:37:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker SOA-1556 None Closed jaxb-xjc.jar missing in soap.esb 2012-03-04 19:38:18 EST

  None (edit)
Description Boris Belovic 2009-10-26 07:59:08 EDT
Date of First Response: 2009-10-26 08:11:02
project_key: SOA

File jaxb-xjc-<version>.jar is missing in soap.esb. This prevents webservice_consumer_wise_{1-4} quickstarts from being run correctly. Invoking "ant runtest" cause following exception:

12:39:51,916 INFO  [STDOUT] &&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&
12:39:51,922 INFO  [STDOUT] Request map is: {toWhom=Jimbo}
12:39:51,922 INFO  [STDOUT] &&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&
12:39:52,903 WARN  [MessageAwareListener] TransactionalRunner caught throwable: 
java.lang.NoClassDefFoundError: com/sun/tools/xjc/api/ErrorListener
	at org.jboss.ws.tools.jaxws.impl.SunRIConsumerImpl.consume(SunRIConsumerImpl.java:229)
	at org.jboss.wsf.spi.tools.WSContractConsumer.consume(WSContractConsumer.java:202)
	at it.javalinux.wise.core.client.WSDynamicClient.importObjectFromWsdl(WSDynamicClient.java:165)
	at it.javalinux.wise.core.client.WSDynamicClient.init(WSDynamicClient.java:125)
	at it.javalinux.wise.core.client.WSDynamicClient.init(WSDynamicClient.java:94)
	at org.jboss.soa.esb.actions.soap.wise.WSDynamicClientFactory.create(WSDynamicClientFactory.java:72)
	at org.jboss.soa.esb.actions.soap.wise.SOAPClient.createClient(SOAPClient.java:275)
	at org.jboss.soa.esb.actions.soap.wise.SOAPClient.process(SOAPClient.java:236)
	at org.jboss.soa.esb.listeners.message.ActionProcessingPipeline.processPipeline(ActionProcessingPipeline.java:634)
	at org.jboss.soa.esb.listeners.message.ActionProcessingPipeline.processPipeline(ActionProcessingPipeline.java:586)
	at org.jboss.soa.esb.listeners.message.ActionProcessingPipeline.process(ActionProcessingPipeline.java:420)
	at org.jboss.soa.esb.listeners.message.MessageAwareListener$TransactionalRunner.run(MessageAwareListener.java:545)
	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
	at java.lang.Thread.run(Thread.java:619)
Caused by: java.lang.ClassNotFoundException: com.sun.tools.xjc.api.ErrorListener from BaseClassLoader@19877096{VFSClassLoaderPolicy@af094f2{name=vfsfile:/home/bbelovic/SOA5/jboss-soa-p.5.0.0/jboss-as/server/production/deploy/soap.esb/ domain=ClassLoaderDomain@589260ee{name=DefaultDomain parentPolicy=BEFORE parent=org.jboss.bootstrap.NoAnnotationURLClassLoader@4f9dfbff} roots=[MemoryContextHandler@952279418[path= context=vfsmemory://3j001-lu05ni-g195jonc-1-g195k9uf-2s real=vfsmemory://3j001-lu05ni-g195jonc-1-g195k9uf-2s], FileHandler@1912040882[path=soap.esb context=file:/home/bbelovic/SOA5/jboss-soa-p.5.0.0/jboss-as/server/production/deploy/ real=file:/home/bbelovic/SOA5/jboss-soa-p.5.0.0/jboss-as/server/production/deploy/soap.esb/], DelegatingHandler@725810066[path=soap.esb/wise-core.jar context=file:/home/bbelovic/SOA5/jboss-soa-p.5.0.0/jboss-as/server/production/deploy/ real=file:/home/bbelovic/SOA5/jboss-soa-p.5.0.0/jboss-as/server/production/deploy/soap.esb/wise-core.jar], DelegatingHandler@982664302[path=soap.esb/stax-ex.jar context=file:/home/bbelovic/SOA5/jboss-soa-p.5.0.0/jboss-as/server/production/deploy/ real=file:/home/bbelovic/SOA5/jboss-soa-p.5.0.0/jboss-as/server/production/deploy/soap.esb/stax-ex.jar], DelegatingHandler@1489678284[path=soap.esb/jaxws-tools-2.1.1.jar context=file:/home/bbelovic/SOA5/jboss-soa-p.5.0.0/jboss-as/server/production/deploy/ real=file:/home/bbelovic/SOA5/jboss-soa-p.5.0.0/jboss-as/server/production/deploy/soap.esb/jaxws-tools-2.1.1.jar], DelegatingHandler@1658562462[path=soap.esb/streambuffer.jar context=file:/home/bbelovic/SOA5/jboss-soa-p.5.0.0/jboss-as/server/production/deploy/ real=file:/home/bbelovic/SOA5/jboss-soa-p.5.0.0/jboss-as/server/production/deploy/soap.esb/streambuffer.jar], DelegatingHandler@1121560774[path=soap.esb/jbossesb-soap.jar context=file:/home/bbelovic/SOA5/jboss-soa-p.5.0.0/jboss-as/server/production/deploy/ real=file:/home/bbelovic/SOA5/jboss-soa-p.5.0.0/jboss-as/server/production/deploy/soap.esb/jbossesb-soap.jar], DelegatingHandler@1607958899[path=soap.esb/jcip-annotations.jar context=file:/home/bbelovic/SOA5/jboss-soa-p.5.0.0/jboss-as/server/production/deploy/ real=file:/home/bbelovic/SOA5/jboss-soa-p.5.0.0/jboss-as/server/production/deploy/soap.esb/jcip-annotations.jar], DelegatingHandler@1031001645[path=soap.esb/jaxws-rt-2.1.1.jar context=file:/home/bbelovic/SOA5/jboss-soa-p.5.0.0/jboss-as/server/production/deploy/ real=file:/home/bbelovic/SOA5/jboss-soa-p.5.0.0/jboss-as/server/production/deploy/soap.esb/jaxws-rt-2.1.1.jar], DelegatingHandler@2146583519[path=soap.esb/jboss-wise-1.0.aop context=file:/home/bbelovic/SOA5/jboss-soa-p.5.0.0/jboss-as/server/production/deploy/ real=file:/home/bbelovic/SOA5/jboss-soa-p.5.0.0/jboss-as/server/production/deploy/soap.esb/jboss-wise-1.0.aop]]  delegates=null exported=[com.sun.tools.ws.processor.model.jaxb, com.sun.xml.ws.client.sei, com.sun.xml.ws.wsdl.parser, com.sun.istack.ws, com.sun.tools.ws.resources, com.sun.xml.ws.model.wsdl, it.javalinux.wise.core.client, com.sun.tools.ws.wsdl.document.soap, it.javalinux.wise.smooks.decoders, com.sun.tools.ws.api.wsdl, com.sun.xml.ws.api.model.wsdl, com.sun.xml.ws.wsdl.writer.document.xsd, com.sun.xml.ws.developer.servlet, com.sun.tools.ws.processor.util, com.sun.xml.ws.api.client, com.sun.xml.ws.api.server, com.sun.xml.ws.model, org.jboss.internal.soa.esb.soap.ws, com.sun.xml.ws.wsdl.writer.document.soap12, org.jboss.soa.esb.actions.soap, com.sun.xml.ws.spi, com.sun.xml.ws.message.jaxb, com.sun.tools.ws.processor.modeler, com.sun.xml.ws.util.xml, com.sun.tools.ws.processor.modeler.wsdl, com.sun.tools.ws.ant, com.sun.tools.ws.wsdl.framework, com.sun.xml.ws.message.stream, com.sun.xml.ws.wsdl.writer.document, com.sun.tools.ws.processor.model.java, com.sun.xml.ws, com.sun.tools.ws.processor, com.sun.tools.ws.processor.model, com.sun.xml.ws.api.wsdl.parser, com.sun.xml.ws.transport.http.client, com.sun.xml.ws.handler, com.sun.xml.ws.api.wsdl.writer, com.sun.xml.ws.client, com.sun.tools.ws.wsdl.parser, com.sun.xml.ws.util.localization, it.javalinux.wise.core.exceptions, com.sun.tools.ws.processor.generator, com.sun.xml.ws.util, com.sun.xml.ws.protocol.xml, it.javalinux.wise.core.utils, com.sun.xml.ws.util.pipe, com.sun.xml.ws.transport.http.server, com.sun.xml.stream.buffer, com.sun.tools.ws.wsdl.document.schema, META-INF.services, com.sun.xml.ws.api.message, com.sun.xml.ws.api, com.sun.tools.ws.util.xml, com.sun.xml.ws.api.addressing, com.sun.xml.ws.transport.http.servlet, com.sun.xml.ws.encoding, com.sun.xml.ws.message.source, com.sun.xml.ws.developer, com.sun.xml.ws.addressing.model, com.sun.xml.ws.model.soap, com.sun.xml.ws.wsdl.writer.document.http, com.sun.xml.ws.server.servlet, com.sun.xml.ws.encoding.soap, org.jvnet.staxex, com.sun.xml.ws.wsdl.writer.document.soap, com.sun.xml.ws.encoding.xml, com.sun.xml.ws.api.model, com.sun.xml.ws.addressing, com.sun.tools.ws.wsdl.document, com.sun.xml.ws.message, com.sun.xml.ws.server, com.sun.xml.ws.fault, com.sun.xml.ws.resources, com.sun.xml.ws.transport.http, com.sun.xml.ws.binding, com.sun.tools.ws.wsdl.document.mime, com.sun.tools.ws.spi, org.jboss.internal.soa.esb.soap.wise, com.sun.xml.ws.util.resources, net.jcip.annotations, com.sun.tools.ws.wscompile, com.sun.xml.ws.client.dispatch, com.sun.xml.ws.transport, com.sun.xml.ws.addressing.v200408, com.sun.xml.ws.api.pipe, com.sun.xml.ws.streaming, com.sun.xml.ws.api.model.soap, com.sun.tools.ws, com.sun.tools.ws.wsdl.document.http, com.sun.xml.ws.message.saaj, com.sun.tools.ws.util, org.jboss.soa.esb.actions.soap.wise, com.sun.xml.ws.api.fastinfoset, com.sun.xml.ws.protocol.soap, com.sun.tools.ws.wsdl.document.jaxws, it.javalinux.wise.core.client.handler, com.sun.xml.ws.server.provider, com.sun.xml.ws.encoding.fastinfoset, com.sun.xml.ws.encoding.soap.streaming, org.jboss.soa.esb.actions.soap.proxy, com.sun.tools.resourcegen, com.sun.tools.ws.api, com.sun.xml.ws.api.pipe.helper, com.sun.xml.stream.buffer.stax, META-INF, com.sun.xml.ws.api.message.stream, com.sun.xml.stream.buffer.sax, com.sun.xml.ws.util.exception, com.sun.tools.ws.processor.model.exporter, it.javalinux.wise.core.mapper, com.sun.xml.ws.wsdl.writer, org.jboss.soa.esb.actions.soap.adapter, com.sun.xml.ws.api.streaming, com.sun.xml.ws.server.sei, com.sun.tools.ws.processor.modeler.annotation] <IMPORT-ALL>NON_EMPTY}}
	at org.jboss.classloader.spi.base.BaseClassLoader.loadClass(BaseClassLoader.java:448)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
	at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:320)
	... 15 more
Comment 1 Kevin Conner 2009-10-26 08:11:02 EDT
jaxb-xjc.jar is not in soap.esb as it should already be included in the server.  Can you check to see if it is present elsewhere?
Comment 2 Boris Belovic 2009-10-26 09:40:44 EDT
I've already checked, jaxb-xjc.jar is placed in jboss-as/client and jboss-as/lib and is also part of webservice_bpel and opensso quickstarts. Without jaxb-xjc.jar in soap.esb service I am getting exception as mentioned above. So I tried to copy jaxb-xjc.jar into soap.esb service, then I invoked "ant runtest" and I got this output on console:

14:29:47,732 INFO  [STDOUT] &&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&
14:29:47,737 INFO  [STDOUT] Request map is: {toWhom=Jimbo}
14:29:47,737 INFO  [STDOUT] &&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&
14:29:49,146 INFO  [STDOUT] parsing WSDL...
14:29:50,162 INFO  [STDOUT] generating code...
14:29:50,237 INFO  [STDOUT] org/jboss/soa/esb/samples/quickstart/webservice_consumer_wise/generated/HelloWorld.java
14:29:50,311 INFO  [STDOUT] org/jboss/soa/esb/samples/quickstart/webservice_consumer_wise/generated/HelloWorldWSService.java
14:29:50,325 INFO  [STDOUT] org/jboss/soa/esb/samples/quickstart/webservice_consumer_wise/generated/ObjectFactory.java
14:29:50,364 INFO  [STDOUT] org/jboss/soa/esb/samples/quickstart/webservice_consumer_wise/generated/SayHello.java
14:29:50,366 INFO  [STDOUT] org/jboss/soa/esb/samples/quickstart/webservice_consumer_wise/generated/SayHelloResponse.java
14:29:50,367 INFO  [STDOUT] org/jboss/soa/esb/samples/quickstart/webservice_consumer_wise/generated/package-info.java
14:29:52,639 INFO  [STDOUT] &&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&
14:29:52,639 INFO  [STDOUT] Response Map is: {result=Hello World Greeting for 'Jimbo' on Mon Oct 26 14:29:52 CET 2009}
14:29:52,639 INFO  [STDOUT] &&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&
Comment 3 Kevin Conner 2009-10-26 09:42:25 EDT
Okay, we will definitely sort this out before the ESB 4.7 release is finalised.
Comment 4 Kevin Conner 2009-11-20 05:17:01 EST
It looks like this issue still exists in the 4.7 release, sorry about that.

I will create an issue for the CP release and get it fixed.
Comment 5 Kevin Conner 2009-11-20 05:22:30 EST
Link: Added: This issue depends JBESB-2989
Comment 6 Mark Little 2009-11-27 08:06:40 EST
Set the Component in future.
Comment 7 Kevin Conner 2009-12-03 10:05:01 EST
Fixed in the project, should be in the next merge.
Comment 8 Boris Belovic 2010-01-03 12:37:51 EST
Verified in ER5.

Note You need to log in before you can comment on or make changes to this bug.