Bug 779206 - (SOA-1599) Exception when creating jBPM database
Exception when creating jBPM database
Status: CLOSED NEXTRELEASE
Product: JBoss Enterprise SOA Platform 5
Classification: JBoss
Component: JBossESB, JBPM - within SOA (Show other bugs)
5.0.0 ER3
Unspecified Unspecified
urgent Severity urgent
: ---
: 5.0.0 GA,5.0.0 ER4
Assigned To: Julian Coleman
http://jira.jboss.org/jira/browse/SOA...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-16 02:56 EST by Jiri Pechanec
Modified: 2011-07-19 09:21 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-14 00:05:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
server.log.startup (113.74 KB, application/octet-stream)
2009-11-16 23:18 EST, Len DiMaggio
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker SOA-1599 Critical Closed Exception when creating jBPM database 2013-08-15 08:47:56 EDT

  None (edit)
Description Jiri Pechanec 2009-11-16 02:56:40 EST
Date of First Response: 2009-11-16 04:33:49
project_key: SOA

When starting ER3 configured for PostgreSQL then an exception is thrown
2009-11-16 08:44:54,879 ERROR [org.jboss.kernel.plugins.dependency.AbstractKernelController] (main) Error installing to Start: name=jboss.esb:service=JBPMDatabaseInitializer state=Create mode=Manual requiredState=Installed
org.postgresql.util.PSQLException: ERROR: relation "hibernate_sequence" already exists

The reason is the jUDDI now uses Hibernate for persistence too and during jUDDI db setup the sequence in question is created. Then jBPM SQL scripts tries to create sequence too and fails.
Comment 1 Kevin Conner 2009-11-16 04:33:49 EST
The juddi issue is already under investigation.
Comment 2 Len DiMaggio 2009-11-16 23:18:41 EST
Example server log
Comment 3 Len DiMaggio 2009-11-16 23:18:41 EST
Attachment: Added: server.log.startup
Comment 4 Julian Coleman 2009-12-02 10:31:01 EST
This was fixed with the import of ESB 4.7 GA.
Comment 5 Julian Coleman 2009-12-10 11:15:15 EST
Link: Added: This issue related SOA-1695
Comment 6 Jiri Pechanec 2009-12-14 00:05:37 EST
Verified in ER5
Comment 7 Jiri Pechanec 2011-07-19 09:21:30 EDT
Link: Added: This issue Cloned to SOA-3187

Note You need to log in before you can comment on or make changes to this bug.