Bug 779238 - (SOA-1631) Mail notifier fails on 5.0 ER4
Mail notifier fails on 5.0 ER4
Status: CLOSED NEXTRELEASE
Product: JBoss Enterprise SOA Platform 5
Classification: JBoss
Component: JBossESB (Show other bugs)
5.0.0 ER3
Unspecified Unspecified
high Severity high
: ---
: 5.0.0 GA,5.0.0 ER5
Assigned To: Kevin Conner
http://jira.jboss.org/jira/browse/SOA...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-21 19:33 EST by Len DiMaggio
Modified: 2010-01-04 10:36 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-04 10:36:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
jboss-esb.xml (2.47 KB, text/xml)
2009-11-21 19:34 EST, Len DiMaggio
no flags Details
Screenshot.png (232.90 KB, image/png)
2010-01-04 10:36 EST, Len DiMaggio
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker SOA-1631 None None None Never

  None (edit)
Description Len DiMaggio 2009-11-21 19:33:39 EST
Date of First Response: 2009-11-30 09:46:03
project_key: SOA

See attached file for example jboss-esb.xml - using this file with ESB 4.6 successfully sends mail - with SOA-P 5.0 ER4, it fails with this exception:

18:08:05,269 ERROR [NotificationList] Can't instantiate target <target ccTo="ldimaggi@redhat.com" class="NotifyEmail" from="person@server.com" message="This is the message - replaced by the Message object" sendTo="person@notredhat.com" subject="This is the subject"/>
org.jboss.soa.esb.notification.NotificationException: Exception while trying to send email
        at org.jboss.soa.esb.notification.NotifyEmail.sendNotification(NotifyEmail.java:121)
        at org.jboss.soa.esb.notification.NotificationList.notifyAll(NotificationList.java:164)
        at org.jboss.soa.esb.actions.Notifier.notifyOK(Notifier.java:93)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:597)
        at org.jboss.soa.esb.listeners.message.ActionProcessorMethodInfo.processSuccess(ActionProcessorMethodInfo.java:165)
        at org.jboss.soa.esb.listeners.message.OverriddenActionLifecycleProcessor.processSuccess(OverriddenActionLifecycleProcessor.java:108)
        at org.jboss.soa.esb.listeners.message.ActionProcessingPipeline.notifySuccess(ActionProcessingPipeline.java:950)
        at org.jboss.soa.esb.listeners.message.ActionProcessingPipeline.processPipeline(ActionProcessingPipeline.java:724)
        at org.jboss.soa.esb.listeners.message.ActionProcessingPipeline.processPipeline(ActionProcessingPipeline.java:586)
        at org.jboss.soa.esb.listeners.message.ActionProcessingPipeline.process(ActionProcessingPipeline.java:420)
        at org.jboss.soa.esb.listeners.message.MessageAwareListener$TransactionalRunner.run(MessageAwareListener.java:540)
        at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
        at java.lang.Thread.run(Thread.java:619)
Caused by: org.jboss.soa.esb.listeners.message.MessageDeliverException: MessageingException while trying to send email
        at org.jboss.soa.esb.actions.routing.email.Emailer.sendEmail(Emailer.java:150)
        at org.jboss.soa.esb.actions.routing.email.Emailer.sendEmail(Emailer.java:105)
        at org.jboss.soa.esb.notification.NotifyEmail.sendNotification(NotifyEmail.java:117)
        ... 16 more
Caused by: javax.mail.MessagingException:  (No such file or directory);
  nested exception is:
        java.io.FileNotFoundException:  (No such file or directory)
        at org.jboss.soa.esb.helpers.Email.<init>(Email.java:218)
        at org.jboss.soa.esb.actions.routing.email.Emailer.createEmailInstance(Emailer.java:264)
        at org.jboss.soa.esb.actions.routing.email.Emailer.sendEmail(Emailer.java:171)
        at org.jboss.soa.esb.actions.routing.email.Emailer.sendEmail(Emailer.java:141)
        ... 18 more
Caused by: java.io.FileNotFoundException:  (No such file or directory)
        at java.io.RandomAccessFile.open(Native Method)
        at java.io.RandomAccessFile.<init>(RandomAccessFile.java:212)
        at org.jboss.security.plugins.FilePassword.toCharArray(FilePassword.java:110)
        at org.jboss.soa.esb.services.security.PasswordUtil.getPasswordAsString(PasswordUtil.java:69)
        at org.jboss.soa.esb.helpers.Email.initMailServerSession(Email.java:481)
        at org.jboss.soa.esb.helpers.Email.<init>(Email.java:214)
        ... 21 more
Comment 1 Len DiMaggio 2009-11-21 19:34:31 EST
jboss-esb.xml for use with helloworld quickstart to recreate the error
Comment 2 Len DiMaggio 2009-11-21 19:34:31 EST
Attachment: Added: jboss-esb.xml
Comment 3 Len DiMaggio 2009-11-21 19:36:59 EST
Link: Added: This issue is a dependency of JBESB-2994
Comment 4 Kevin Conner 2009-11-30 09:46:03 EST
Fixed in the ESB project, will be in the next merge.
Comment 5 Kevin Conner 2009-12-07 05:40:45 EST
Link: Removed: This issue is a dependency of JBESB-2994 
Comment 6 Kevin Conner 2009-12-07 05:41:03 EST
Link: Added: This issue depends JBESB-2994
Comment 7 Len DiMaggio 2010-01-04 10:36:33 EST
Verified fixed in ER6 - see attached email screenshot
Comment 8 Len DiMaggio 2010-01-04 10:36:33 EST
Attachment: Added: Screenshot.png
Comment 9 Len DiMaggio 2010-01-04 10:36:54 EST
Verified fixed in ER6 - see attached email screenshot

Note You need to log in before you can comment on or make changes to this bug.