This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 779307 - (SOA-1695) jUDDI database initialization fails on Oracle and db2 - not an issue for PostgreSQL
jUDDI database initialization fails on Oracle and db2 - not an issue for Post...
Status: CLOSED NEXTRELEASE
Product: JBoss Enterprise SOA Platform 5
Classification: JBoss
Component: JBossESB, Configuration, Deployment (Show other bugs)
5.0.0 ER5
Unspecified Unspecified
urgent Severity urgent
: ---
: 5.0.0 GA,5.0.0 ER7
Assigned To: Julian Coleman
http://jira.jboss.org/jira/browse/SOA...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-09 02:22 EST by Jiri Pechanec
Modified: 2010-01-29 02:46 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-29 02:46:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker SOA-1695 None None None Never

  None (edit)
Description Jiri Pechanec 2009-12-09 02:22:32 EST
Date of First Response: 2009-12-10 11:15:15
project_key: SOA

jUDDI 3 uses Hibernate to access db. During server startup it tries to update db schema to conform mapping files. Unfortunately on Oracle if tables with the same name exists in an other schema then jUDDI thinks that db is correctly initialized and tables are not created.

To fix this issue it is necessary to use hibernate options hibernate.default_schema and/or hibernate.default_catalog in persistence.xml file. This can cuase problems with other databases.

I have tried to change hibernate.hbm2ddl.auto from update to create and issue has disappeared. Moreover this approach is better aligned with other db components using static sql files - no schema change is done inadvertently.
Comment 1 Julian Coleman 2009-12-10 11:15:15 EST
SOA-1599 is also a symptom of visibility across multiple schemas.
Comment 2 Julian Coleman 2009-12-10 11:15:15 EST
Link: Added: This issue is related to SOA-1599
Comment 3 Julian Coleman 2009-12-21 11:27:20 EST
This seems to be more a database setup problem, where multiple schemas are visible.
Changing the schema visibility in the database would fix this.
Comment 4 Lukáš Petrovický 2010-01-05 06:28:22 EST
hbm2ddl.auto should never carry the "update" value in the first place - it doesn't properly create indices. For more information, see http://www.hibernate.org/119.html#A10 and HHH-1012 (fixed only recently).
Comment 5 Kevin Conner 2010-01-05 07:01:52 EST
Link: Added: This issue depends JBESB-3097
Comment 6 Kevin Conner 2010-01-05 07:03:02 EST
Will also modify our base one in case that makes your job easier
Comment 7 Kevin Conner 2010-01-05 07:51:39 EST
ESB configuration has been changed, will be in next commit.
Comment 8 Julian Coleman 2010-01-18 09:53:00 EST
Resolving this, as the ESB JIRA (JBESB-3097) has been resolved.
Comment 9 Jiri Pechanec 2010-01-29 02:46:37 EST
Verified in ER7

Note You need to log in before you can comment on or make changes to this bug.