Bug 779379 - (SOA-1769) Need documentation for use of synchronousTimeout with http-gateway
Need documentation for use of synchronousTimeout with http-gateway
Status: CLOSED NEXTRELEASE
Product: JBoss Enterprise SOA Platform 5
Classification: JBoss
Component: Documentation, JBossESB (Show other bugs)
5.0.0 ER5
Unspecified Unspecified
medium Severity medium
: ---
: 5.0.0 GA
Assigned To: David Le Sage
http://jira.jboss.org/jira/browse/SOA...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-04 16:56 EST by david.boeren
Modified: 2010-02-08 14:38 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-08 14:38:24 EST
Type: Task
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker SOA-1769 Minor Closed Need documentation for use of synchronousTimeout with http-gateway 2012-12-21 06:28:56 EST

  None (edit)
Description david.boeren 2010-01-04 16:56:59 EST
Affects: Documentation (Ref Guide, User Guide, etc.)
Date of First Response: 2010-01-08 21:55:29
Help Desk Ticket Reference: https://enterprise.redhat.com/issue-tracker/?module=issues&action=view&tid=380285&gid=1354
project_key: SOA

Need documentation of the http-gateway "synchronousTimeout" property to be added here:  http://www.redhat.com/docs/en-US/JBoss_SOA_Platform/5.0.0-Beta1/html-single/Programmers_Guide/index.html#id3728654

I've already figured out how to do it from looking at the source code.  Just wanted to get a case created so that it would hopefully get in the official documentation before GA.

<http-gateway name="HttpGateway" urlPattern="redirectShip/*">
  <property name="synchronousTimeout" value="120000"/>
</http-gateway>
Comment 1 trev 2010-01-05 05:54:30 EST
Affects: Added: [Documentation (Ref Guide, User Guide, etc.)]
Comment 3 Len DiMaggio 2010-01-08 21:56:03 EST
Link: Added: This issue is related to SOA-1533
Comment 4 Len DiMaggio 2010-01-10 22:37:41 EST
The <synchronousTimeout> property seems to work - setting it to a very low value raises this exeception:

<property name="synchronousTimeout" value="1"/>

22:13:10,644 ERROR [[sales]] Servlet.service() for servlet sales threw exception
org.jboss.soa.esb.listeners.message.ResponseTimeoutException: No response received for service [Sales:List].

Comment 5 Tom Fennelly 2010-01-11 07:44:38 EST
Link: Added: This issue depends JBESB-3113
Comment 6 Len DiMaggio 2010-01-11 08:34:51 EST
Need to reference:  http://community.jboss.org/wiki/HTTPGateway
Comment 7 Kevin Conner 2010-01-11 08:46:15 EST
I have asked TomF to add a comment here, rather than doing wiki/docs, as his priority is with the redeployment issue.
Comment 8 Tom Fennelly 2010-01-11 17:49:21 EST
Added to the wiki page... sorry Kev... just saw your comment now.  Was easier to add there anyway.

Re the async invocation settings: http://community.jboss.org/wiki/HTTPGateway#Asynchronous_Responses
Re the sync response timeout: http://community.jboss.org/wiki/HTTPGateway#Response_Timeout
Comment 9 Dana Mison 2010-01-11 20:38:04 EST
Please update Programmers guide with those wiki page additions
Comment 10 David Le Sage 2010-01-26 21:11:52 EST
This has been documented in section 9.9.3 of the Programmers' Guide.
Comment 11 David Le Sage 2010-01-31 23:49:03 EST
Len,

As per the above, all of the synchronousTimeout info has been added to the document.


However, found the statement about documenting this Wiki ambiguous.  Do you want it all documented?  I ask this because there are significant differences between what is in the Wiki and what is in the upstream docs (for example, the entire "Security" section is missing from the Docs.)

Since the Wiki was updated recently (Jan 10) by Tom Fennelley, do we take it as the "source of truth" for the entire HTTP Gateway section?

Thanks.
Comment 13 David Le Sage 2010-02-03 18:00:31 EST
Hello Tom,


I have put all of this data in.  (Please let me know if any of it is not relevant, as it can be removed.)


Thanks,


David
Comment 14 Dana Mison 2010-02-07 19:14:55 EST
content was updated in the guide from the wiki as requested

Note You need to log in before you can comment on or make changes to this bug.