Bug 779552 - (SOA-1928) SOAPProxy Service with unreachable proxy URL causes server to hang
SOAPProxy Service with unreachable proxy URL causes server to hang
Status: CLOSED WONTFIX
Product: JBoss Enterprise SOA Platform 5
Classification: JBoss
Component: JBossESB (Show other bugs)
5.0.0 ER7
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Default User
http://jira.jboss.org/jira/browse/SOA...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-04 14:43 EST by Jeff DeLong
Modified: 2010-09-21 15:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
5.0.0.E7 on Mac OS JDK 1.6
Last Closed: 2010-09-21 15:42:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker SOA-1928 Major Closed SOAPProxy Service with unreachable proxy URL causes server to hang 2012-11-22 01:19:26 EST

  None (edit)
Description Jeff DeLong 2010-02-04 14:43:24 EST
Date of First Response: 2010-02-04 14:47:44
Help Desk Ticket Reference: https://enterprise.redhat.com/issue-tracker/848373
project_key: SOA


As documented in JBESB-2947, if I use an http url for a local JBossWS hosted web services, the server hangs. I replace the url with the internal url and the server starts fine. 

However, if the http url was for a service on another server, and that server was not reachable (e.g., I put it a bogus IP address for the servername), I found that it also causes the server to hang.  In this case there is an error message at least:

12:16:16,896 INFO  [EsbDeployment] Starting ESB Deployment 'UpdateStatusService.esb'
12:17:32,514 INFO  [HttpMethodDirector] I/O exception (java.net.SocketException) caught when processing request: Network is unreachable
12:17:32,514 INFO  [HttpMethodDirector] Retrying request

This server is still hung (e.g. jmx-console is not available). However it is not hung quite as bad, it will at least shut down without doing a kill -9.

This seems problematic to me, since a customer cannot guarantee that their real services are always running when they startup their ESB, and hanging the server is never acceptable.
Comment 1 Kevin Conner 2010-02-04 14:47:44 EST
Need to register HttpMethodParams.RETRY_HANDLER and extend it to other exceptions, default seems to be DefaultHttpMethodRetryHandler.
Comment 2 David Ward 2010-02-04 20:58:19 EST
Link: Added: This issue depends JBESB-3172
Comment 3 David Ward 2010-02-22 16:00:11 EST
FYI, the hanging only appears to happen on Mac OS, which SOA-P does not provide production support for, so we are putting this one aside for now.
Comment 4 David Ward 2010-05-06 12:12:11 EDT
Security: Removed: JBoss Internal Added: Public
Comment 5 Martin Weiler 2010-05-10 03:18:00 EDT
Additional information about the environment from Brad Davis: "This is the case with Windows XP with Java 1.6.0_18-b07 as well."
Comment 6 Martin Weiler 2010-05-10 03:18:33 EDT
Help Desk Ticket Reference: Added: https://enterprise.redhat.com/issue-tracker/848373
Comment 7 Kevin Conner 2010-05-10 04:11:43 EDT
This has not been seen in a windows environment until now (we test on windows).  Can we please have a log file attached to this case?
Comment 8 David Ward 2010-05-10 08:53:56 EDT
I have the fix completed locally (dead easy) that registers our own HttpMethodRetryHandler which (in addition to what DefaultHttpMethodRetryHandler checks for) also checks for a generic SocketException.  This should account for the Mac JDK vs. Linux JDK behavioral difference.  However, I am hesitating checking it in until I see a log file for the Windows JDK environment That Martin/Brad mentioned.  I want to make sure we cover that as well.  So, as Kevin requested, a log file would be much appreciated.  Thanks!
Comment 9 David Ward 2010-05-11 13:24:21 EDT
Tom Cunningham verified my fix on his Mac, so I have committed the fix for JBESB-3172 on trunk.  It will be included in .org ESB 4.9.

Now, since THIS issue (SOA-1928) is a platform issue, and we do not yet provide customer support for Mac OS, I don't know when there will be an associated JBESB issue that targets a platform CP release.  But when there is, it will be an easy port.
Comment 10 Anne-Louise Tangring 2010-09-21 15:42:08 EDT
MAC OS is not supported with SOA-P 5.x and there are no plans to do so.

Note You need to log in before you can comment on or make changes to this bug.