Bug 779667 - (SOA-2033) Deployment State in SOA-P 5
Deployment State in SOA-P 5
Status: CLOSED NEXTRELEASE
Product: JBoss Enterprise SOA Platform 5
Classification: JBoss
Component: JBossESB (Show other bugs)
5.0.0 GA
Unspecified Unspecified
high Severity high
: ---
: 5.1.0 GA
Assigned To: Kevin Conner
http://jira.jboss.org/jira/browse/SOA...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-08 13:14 EDT by david.boeren
Modified: 2011-02-11 01:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-11 01:00:03 EST
Type: Feature Request
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker SOA-2033 None None None Never

  None (edit)
Description david.boeren 2010-04-08 13:14:28 EDT
Date of First Response: 2010-04-08 14:00:43
Help Desk Ticket Reference: https://enterprise.redhat.com/issue-tracker/?module=issues&action=view&tid=581783&gid=1354
project_key: SOA

in ESB 4.6 there was a MBean attribute "StateString" available via the JMX console telling about the deployment state of an ESB package like "Started" or "Stopped".

We're searching for a solution on SOA-P 5 where this attribute doesn't seem to exist anymore.

Can this attribute or something similar be re-added for SOA-P 5.0?
Comment 2 Anne-Louise Tangring 2010-09-21 16:39:12 EDT
Candidate (optional) for SOA 5.1.0.
Comment 3 Kevin Conner 2010-09-27 11:38:39 EDT
Link: Added: This issue depends JBESB-3491
Comment 4 Kevin Conner 2010-10-11 05:03:52 EDT
Updated in ESB codebase, will need an updated plugin.
Comment 6 Dana Mison 2011-01-04 19:14:32 EST
Writer: Added: dlesage
Comment 7 David Le Sage 2011-02-11 00:54:15 EST
Temporarily reopening to update release note info.
Comment 8 David Le Sage 2011-02-11 00:58:35 EST
Release Notes Docs Status: Added: Documented as Resolved Issue
Release Notes Text: Added: https://issues.jboss.org/browse/JBESB-3491

The MBean attribute "StateString" that was previously available via the JMX console was no long present. This was because the SOA Platform is running on Application Server 5.  As a result, users could not find out the ESB package's deployment state (such as "Started" or "Stopped") via the JMX Console.  This feature has now been  ported to Application Server 5 so it can be utilised again.  


Note You need to log in before you can comment on or make changes to this bug.