Bug 779703 - (SOA-2067) SOAPProxy breaks when WSDL elements have special characters
SOAPProxy breaks when WSDL elements have special characters
Status: CLOSED NEXTRELEASE
Product: JBoss Enterprise SOA Platform 5
Classification: JBoss
Component: JBossESB (Show other bugs)
5.0.0 GA
Unspecified Unspecified
high Severity high
: ---
: 5.0.2
Assigned To: Kevin Conner
http://jira.jboss.org/jira/browse/SOA...
:
: 779790 779862 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-04 09:41 EDT by Kevin Conner
Modified: 2010-08-13 04:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 11:02:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker SOA-2067 None None None Never

  None (edit)
Description Kevin Conner 2010-05-04 09:41:11 EDT
Date of First Response: 2010-05-04 10:28:23
project_key: SOA
Comment 1 Kevin Conner 2010-05-04 09:41:39 EDT
Link: Added: This issue depends JBESB-3300
Comment 2 David Ward 2010-05-04 10:28:23 EDT
JBESB-3300 has been closed.
Comment 3 Darrin Mison 2010-06-07 21:05:12 EDT
More information needed for release notes:

What is the most appropriate name for the deployable unit here ?

Deploying a ??? would fail if the schemalocation URL in the WSDL contained characters that would be invalid in a filename on the host.

This occured because the URL was used in the name of a temp file.

The fix is that the URL is no longer used as part of the filename
Comment 4 Darrin Mison 2010-06-22 00:30:04 EDT
added to the SOA 5.1 release notes as resolved:

JBESB-3300
Deploying an ESB archive that used SOAProxy would fail if the schema location URL in the WSDL contained characters that would be invalid in a filename on the host. This occurred because the URL was used in the name of a temp file.
The URL is no longer used as part of the filename and deployment is successful.



Comment 5 Boris Belovic 2010-06-28 11:02:49 EDT
Verified in SOA-P 5.0.2 CR3 (covered by WebServiceProxyTest).
Comment 6 Kevin Conner 2010-08-13 04:34:10 EDT
Link: Added: This issue is duplicated by SOA-2221
Comment 7 Kevin Conner 2010-08-13 04:36:54 EDT
Link: Added: This issue is duplicated by SOA-2151

Note You need to log in before you can comment on or make changes to this bug.