Bug 779751 - (SOA-2113) jboss-esb.xml files for quickstarts do not include xsi:schemaLocation=http://anonsvn.labs.jboss.com/labs/jbossesb/trunk/product/etc/schemas/xml/jbossesb-1.1.0.xsd
jboss-esb.xml files for quickstarts do not include xsi:schemaLocation=http:/...
Status: CLOSED NEXTRELEASE
Product: JBoss Enterprise SOA Platform 5
Classification: JBoss
Component: JBossESB, Examples (Show other bugs)
5.0.2
Unspecified Unspecified
high Severity high
: ---
: 5.1.0 GA
Assigned To: Kevin Conner
http://jira.jboss.org/jira/browse/SOA...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-07 11:42 EDT by Len DiMaggio
Modified: 2011-02-14 10:46 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-14 10:46:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker SOA-2113 None None None Never

  None (edit)
Description Len DiMaggio 2010-06-07 11:42:11 EDT
project_key: SOA

The jboss-esb.xml files in the quickstarts include this namespace definition:

xmlns="http://anonsvn.labs.jboss.com/labs/jbossesb/trunk/product/etc/schemas/xml/jbossesb-1.0.1.xsd"

-------------------------

This URL is no longer valid - the files were supposed to have been updated to include:

<jbossesb xmlns="http://anonsvn.labs.jboss.com/labs/jbossesb/trunk/product/etc/schemas/xml/jbossesb-1.1.0.xsd"
 xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" 
 xsi:schemaLocation="http://anonsvn.labs.jboss.com/labs/jbossesb/trunk/product/etc/schemas/xml/jbossesb-1.1.0.xsd 
 http://anonsvn.jboss.org/repos/labs/labs/jbossesb/trunk/product/etc/schemas/xml/jbossesb-1.1.0.xsd"
 parameterReloadSecs="5"></jbossesb>
Comment 1 Len DiMaggio 2010-06-07 11:42:31 EDT
Link: Added: This issue is related to JBIDE-5444
Comment 2 Anne-Louise Tangring 2010-09-21 16:55:22 EDT
Candidate for SOA 5.1.0
Comment 3 Kevin Conner 2010-09-22 07:36:01 EDT
Link: Added: This issue depends JBESB-3483
Comment 4 Len DiMaggio 2010-10-04 13:47:44 EDT
In 5.1 ER2, the quickstarts' jboss-esb.xml files still refer to version 1.0.1:

grep -r "xmlns=\"http://anonsvn.labs.jboss.com/labs/jbossesb/trunk/product/etc/schemas/xml/jbossesb-1.0.1.xsd" * | wc -l
81


Comment 5 Kevin Conner 2010-10-04 14:08:57 EDT
The 1.0.1 schema is still valid, it is the location of the schema that has changed.  That is why the schemaLocation is now necessary.
Comment 6 Len DiMaggio 2010-10-04 14:39:19 EDT
Just re-checked - the schemaLocation is missing from the quickstarts' jboss-esb.xml files:

 grep -r "xsi:schemaLocation=\"http://anonsvn.labs.jboss.com/labs/jbossesb/trunk/product/etc/schemas/xml/jbossesb-1.1.0.xsd" *
Comment 7 Kevin Conner 2010-10-04 14:47:41 EDT
The schemaLocations are present but this is resolved against GA and not ER2, you will have to wait for the next tag to test this.
Comment 9 Darrin Mison 2011-01-04 19:14:42 EST
Writer: Added: dlesage
Comment 10 Len DiMaggio 2011-01-06 12:35:57 EST
In ER6 - 6 QS's are updated - the others are not yet:

[ldimaggi@ldimaggi quickstarts]$ grep -r "xsi:schemaLocation=\"http://anonsvn.labs.jboss.com/labs/jbossesb/trunk/product/etc/schemas/xml/jbossesb-1.0.1.xsd" *  | wc -l
75
Comment 11 Kevin Conner 2011-01-07 04:13:43 EST
Sorry, not sure what you are looking for here.  That is the namespace (which does not change) and is mapped on to the right location by the schemaLocation attribute.
Comment 12 Kevin Conner 2011-01-07 08:37:37 EST
Just checked ER6, all ESB quickstarts have been updated correctly.  What *hasn't* been done are the six platform specific quickstarts.

helloworld_ejb3_ws/jboss-esb.xml
helloworld_ejb3_ws_wss/jboss-esb.xml
opensso/jboss-esb.xml
swift2xml_action/jboss-esb.xml
wsmq_router/jboss-esb.xml
xml2swift_action/jboss-esb.xml
Comment 13 Kevin Conner 2011-01-07 08:41:25 EST
Link: Added: This issue related SOA-2755
Comment 14 Kevin Conner 2011-01-07 08:42:22 EST
Created SOA-2755 for platform quickstarts
Comment 15 Darrin Mison 2011-02-03 00:38:42 EST
does not need to be documented as this was a required change due to the ESB update in this version - ie was not a bug
Comment 16 Darrin Mison 2011-02-03 00:38:42 EST
Release Notes Docs Status: Added: Not Required
Writer: Removed: dlesage Added: Darrin
Comment 17 Darrin Mison 2011-02-03 00:49:32 EST
I stand corrected, while not a bug as such it is a change that might catch people out if they have code based on the old quickstarts
Comment 18 Darrin Mison 2011-02-03 00:49:32 EST
Release Notes Docs Status: Removed: Not Required Added: Documented as Resolved Issue
Release Notes Text: Added: The JBossESB namespace XSD URL has been changed for this release.  The jboss-esb.xml files in the JBossESB project quickstarts have been updated to reference the current namespace definition.  The correct namespace is required when using JBoss Developer Studio or autocompletion does not work.

The correct XSD URL is now:  http://anonsvn.labs.jboss.com/labs/jbossesb/trunk/product/etc/schemas/xml/jbossesb-1.1.0.xsd
Comment 19 Len DiMaggio 2011-02-14 10:46:32 EST
Verified in CR1 build.

Note You need to log in before you can comment on or make changes to this bug.