Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 77976 - Installer won't work
Installer won't work
Status: CLOSED DUPLICATE of bug 76213
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-16 01:20 EST by Son Tran
Modified: 2007-04-18 12:48 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:50:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Son Tran 2002-11-16 01:20:15 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98)

Description of problem:
right when it starts to install a bug report shows up

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Burned linux set up disc to cd's
2.Ran the software in dos
3.set it up
4.right be installation won't install bug report shows up

Actual Results:  bug report

Expected Results:  it should have installed linux

Additional info:

I tried to write the error onto disk but it didnt work so i wrote it down and 
recopied it.

Traceback (most recent call last):

File "/usr/lib/anaconda/gui.py", line 786, in handleRenderCallback 
self.currentwindow.RenderCallback()

File "/usr/lib/anaconda/iw/progless_gui.py", line 149, in renderCallback 
self.intf.icw.nextClicked()

File "/usr/lib/anaconda/gui.py", line 632, in nextClicked self.dispatch.gotonext
()

File "/usr/lib/anaconda/dispatch.py", line 150, in gotonext self.movestep()

File "/usr/lib/anaconda/dispatch.py", line 215 in movestep rc= apply (func, 
self.bindargs(args))

File "/usr/lib/anaconda/packages.py", line 430, in turnonfilesystems 
partition.demetadeletes(diskset)

File "/usr/lib/anaconda/partitions.py", line 1110, in dometadeletes 
lvm.vgactivate()

File "/usr/lib/anaconda/lvm.py", line 54, in vgactivate search path = 1)

File "/usr/lib/anaconda/ivtil.py", line 66, in execwithredirect childpid = 
os.fork()

OSError: [Errno 12] Cannot allocate memory
Comment 1 Michael Fulbright 2002-11-18 15:36:29 EST
How much RAM is in your system?

64MB is the minimum supported.
Comment 2 Son Tran 2002-11-28 15:14:05 EST
I have 64 mega bytes of ram
Comment 3 martin chaparro 2002-12-13 17:31:09 EST
I have the same bug and 64 megs of RAM too. Any thoughts?
Comment 4 Alpen Khatri 2002-12-25 22:30:20 EST
I have the same bug and have 128M of ram
Comment 5 case1984 2002-12-28 15:35:09 EST
The same thing is happening to me, about 90% of the time I try and install.  
I'm trying to install Red Hat 8.0 on an Intel Pentium 200MMX machine with 64mb 
memory and a 2gig HD.  I think this bug is actually a duplicate of this one:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=77598
Comment 6 case1984 2002-12-28 22:26:43 EST
I just finished installing Red Hat 8.0!
I couldn't get it to work, but as soon as I allocated 128 mb as a swap 
partition instead of 64 or 65 mb, it worked!
It had failed either right after the installer, or during installation itself 
at least 20 times, but as soon as I switched the swap, it worked the first 
time.  It may not work for you, but it worked for me!
Comment 7 Michael Lee Yohe 2003-01-09 09:04:40 EST
This appears to be a duplicate of Bug 76123.  The problem is that there is not
enough memory to process the transactions that are to be executed by the
installer.  Anaconda, in GUI mode, requires at least 64M+ of memory and 128M of
swap.  

You can alternatively attempt to install Red Hat Linux 8.0 in text mode by
specifying "linux text" at the SYSLINUX prompt upon first boot.  Anaconda, in
text mode, is more lenient on memory resources.
Comment 8 Jeremy Katz 2003-01-10 02:00:15 EST

*** This bug has been marked as a duplicate of 76213 ***
Comment 9 Red Hat Bugzilla 2006-02-21 13:50:09 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.