Bug 779821 - (SOA-2182) CBR: an object path is converted to a real object twice
CBR: an object path is converted to a real object twice
Status: CLOSED NEXTRELEASE
Product: JBoss Enterprise SOA Platform 5
Classification: JBoss
Component: JBossESB (Show other bugs)
5.0.0 GA,5.0.2
Unspecified Unspecified
urgent Severity urgent
: ---
: 5.1.0 GA
Assigned To: Kevin Conner
http://jira.jboss.org/jira/browse/SOA...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-26 14:26 EDT by Martin Vecera
Modified: 2011-02-11 00:41 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-11 00:41:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker SOA-2182 None None None Never

  None (edit)
Description Martin Vecera 2010-07-26 14:26:11 EDT
Complexity: Low
project_key: SOA

See the linked issue.
Comment 1 Martin Vecera 2010-07-26 14:27:01 EDT
Link: Added: This issue depends JBESB-3389
Comment 2 Anne-Louise Tangring 2010-09-10 16:37:19 EDT
Needs investigation. Candidate for SOA 5.1.0
Comment 4 Dana Mison 2011-01-04 19:14:36 EST
Writer: Added: dlesage
Comment 5 Martin Vecera 2011-01-27 08:17:31 EST
Verified in 5.1.0 ER8
Comment 6 David Le Sage 2011-02-11 00:38:22 EST
Temporarily reopening to update release note info.
Comment 7 David Le Sage 2011-02-11 00:41:36 EST
Release Notes Docs Status: Added: Documented as Resolved Issue
Release Notes Text: Added: https://issues.jboss.org/browse/JBESB-3389

An object path was being converted to a real object twice because of conflicting calls to the Object Mapper.  When the object on the object path was not a String an exception was thrown. In other cases, routing would not work. A series of code changes have been applied so that the duplication no longer occur, eliminating the problems this caused.

Note You need to log in before you can comment on or make changes to this bug.