Bug 779856 - (SOA-2216) bpm_orchestration2 process is not safe
bpm_orchestration2 process is not safe
Status: CLOSED NEXTRELEASE
Product: JBoss Enterprise SOA Platform 5
Classification: JBoss
Component: JBossESB, Examples (Show other bugs)
5.0.0 GA
Unspecified Unspecified
high Severity high
: ---
: 5.1.0 GA
Assigned To: Kevin Conner
http://jira.jboss.org/jira/browse/SOA...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-09 11:42 EDT by Len DiMaggio
Modified: 2011-02-17 06:30 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-17 06:30:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker SOA-2216 Major Closed bpm_orchestration2 process is not safe 2012-11-04 08:21:50 EST

  None (edit)
Description Len DiMaggio 2010-08-09 11:42:20 EDT
Help Desk Ticket Reference: https://enterprise.redhat.com/issue-tracker/303315
project_key: SOA
Comment 1 Kevin Conner 2010-08-09 11:43:09 EDT
Link: Added: This issue is related to SOA-1507
Comment 2 Kevin Conner 2010-08-09 11:44:32 EDT
Link: Added: This issue depends JBESB-3450
Comment 3 Anne-Louise Tangring 2010-09-10 12:29:14 EDT
This is a candidate for SOA 5.1.
Comment 4 Laura Bailey 2010-12-16 19:41:28 EST
Writer: Added: Darrin
Comment 5 Laura Bailey 2010-12-16 19:47:58 EST
Release Notes Docs Status: Added: Not Yet Documented
Comment 7 Len DiMaggio 2011-01-06 14:48:59 EST
Verified in ER6 build.
Comment 8 Darrin Mison 2011-02-17 06:30:19 EST
Release Notes Docs Status: Removed: Not Yet Documented Added: Documented as Resolved Issue
Labels: Removed: rn-dmison rn-open 
Release Notes Text: Added: The bpm_orchestration2 quickstart used to demonstrate fork and join operations in the business process could result in contention between the forked actions.  This was because the forked actions were all configured to update the same process variable.  This quickstart has been updated so that the forks use different variables.  This prevents the contention with actions after the join responsible for merging the data

Note You need to log in before you can comment on or make changes to this bug.