Bug 780044 - (SOA-2407) Web Services that uses WSDL with import statement cannot be proxied with internal:// referred wsdl
Web Services that uses WSDL with import statement cannot be proxied with inte...
Status: CLOSED NEXTRELEASE
Product: JBoss Enterprise SOA Platform 5
Classification: JBoss
Component: JBossESB (Show other bugs)
5.1.0.ER2
Unspecified Unspecified
high Severity high
: ---
: 5.1.0 GA
Assigned To: Kevin Conner
http://jira.jboss.org/jira/browse/SOA...
: Regression
: SOA-2434 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-12 05:11 EDT by Jiri Pechanec
Modified: 2011-02-17 04:45 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-17 04:45:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
wspb.zip (136.73 KB, application/zip)
2010-10-12 05:12 EDT, Jiri Pechanec
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker SOA-2407 None None None Never

  None (edit)
Description Jiri Pechanec 2010-10-12 05:11:15 EDT
project_key: SOA

See attached log and example. The @WbService bean contains reference to file with contract definition that contains and import statement referring to an XSD file stored on the disk. The Web Service itself is functioning, WSDL is available from console.

But if an jboss-esb.xml file contains definition like
                               <action name="proxy"
                                                class="org.jboss.soa.esb.actions.soap.proxy.SOAPProxy">
                                                <property name="wsdl" value="internal://jboss.ws:context=Quickstart_webservice_proxy_basic_ws,endpoint=HelloWorldImportWS"/>
                                </action>

then the deployment fails with an exception
Caused by: org.jboss.soa.esb.ConfigurationException: java.lang.NullPointerException
	at org.jboss.soa.esb.actions.soap.proxy.SOAPProxy.<init>(SOAPProxy.java:193)
	... 90 more
Caused by: java.lang.NullPointerException
	at java.net.URI$Parser.parse(URI.java:3003)
	at java.net.URI.<init>(URI.java:578)
	at java.net.URI.create(URI.java:840)
	at org.jboss.soa.esb.actions.soap.proxy.SOAPProxyWsdlLoader.load(SOAPProxyWsdlLoader.java:155)
	at org.jboss.soa.esb.actions.soap.proxy.SOAPProxy.<init>(SOAPProxy.java:188)
	... 90 more

This scenario worked in 5.0
Comment 1 Jiri Pechanec 2010-10-12 05:12:13 EDT
Attachment: Added: wspb.zip
Comment 2 Kevin Conner 2010-10-12 06:14:54 EDT
The issue appears to be related to the way in which WebServiceUtils (in ESB) searches for the wsdl, will get this addressed.
Comment 3 Kevin Conner 2010-10-12 06:36:57 EDT
Link: Added: This issue depends JBESB-3503
Comment 4 Kevin Conner 2010-10-18 04:32:02 EDT
Link: Added: This issue is duplicated by SOA-2434
Comment 5 Laura Bailey 2010-12-16 19:41:25 EST
Writer: Added: Darrin
Comment 6 Laura Bailey 2010-12-16 19:47:59 EST
Release Notes Docs Status: Added: Not Yet Documented
Comment 8 Jiri Pechanec 2011-01-11 06:55:17 EST
Verified in ER6
Comment 9 Darrin Mison 2011-02-17 04:45:08 EST
Release Notes Docs Status: Removed: Not Yet Documented Added: Not Required

Note You need to log in before you can comment on or make changes to this bug.