Bug 780052 - (SOA-2417) http_2way_ssl quickstart doesn't pass the HTTP header through JBR in the action chain
http_2way_ssl quickstart doesn't pass the HTTP header through JBR in the acti...
Status: CLOSED WONTFIX
Product: JBoss Enterprise SOA Platform 5
Classification: JBoss
Component: JBossESB, Examples (Show other bugs)
5.0.0 GA,5.0.2,5.1.0.ER2
Unspecified Unspecified
high Severity high
: ---
: 5.2.0 GA
Assigned To: tcunning
http://jira.jboss.org/jira/browse/SOA...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-13 10:36 EDT by Pavel Macik
Modified: 2011-10-07 04:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
SOA-P
Last Closed: 2011-10-07 04:37:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker JBESB-3627 None None None Never
JBoss Issue Tracker SOA-2417 None None None Never

  None (edit)
Description Pavel Macik 2010-10-13 10:36:01 EDT
project_key: SOA

There is an issue in "http_2way_ssl" quickstart (that is a part of SOA-P distribution).
In the case of SOA-P 4.3.0_CP04 the HTTP header ("blah: blahval") that is configured/provided by HTTPRouter in the ESB action chain passes all the way to client response and its presence is confirmed in the server's log where the quickstart prints the output.

But in the case of SOA-P v5 the header is not passed to the end of ESB action chain. The quickstart practically wasn't changed between the SOA-P versions.

SOA-P 4.3.0_CP04.GA - quickstart's output in server's log:
...
15:35:51,886 INFO  [STDOUT] =========== Server Request: ====================================
15:35:51,886 INFO  [STDOUT] Message Payload:
15:35:51,886 INFO  [STDOUT]     [Request Payload!]
15:35:51,886 INFO  [STDOUT]     Headers:
15:35:51,886 INFO  [STDOUT]             host: localhost
15:35:51,886 INFO  [STDOUT]             Method: POST
15:35:51,886 INFO  [STDOUT]             Path: /x/y
15:35:51,886 INFO  [STDOUT]             user-agent: Jakarta Commons-HttpClient/3.0.1
15:35:51,887 INFO  [STDOUT]             content-type: text/xml;charset=UTF-8
15:35:51,887 INFO  [STDOUT] ================================================================
15:35:51,940 INFO  [STDOUT] =========== Client Response: ===================================
15:35:51,940 INFO  [STDOUT] Message Payload:
15:35:51,940 INFO  [STDOUT]     [Http Response Payload!!]
15:35:51,940 INFO  [STDOUT] Http Response:
15:35:51,940 INFO  [STDOUT]     Code: 200
15:35:51,940 INFO  [STDOUT]     Length: 23
15:35:51,940 INFO  [STDOUT]     Encoding: ISO-8859-1
15:35:51,940 INFO  [STDOUT]     Headers:
15:35:51,940 INFO  [STDOUT]             blah: blahval
15:35:51,940 INFO  [STDOUT]             Content-Type: text/xml;charset=UTF-8
15:35:51,940 INFO  [STDOUT]             User-Agent: Jakarta Commons-HttpClient/3.0.1
15:35:51,940 INFO  [STDOUT]             Host: localhost
15:35:51,940 INFO  [STDOUT]             Content-Length: 16
15:35:51,940 INFO  [STDOUT] ================================================================
...

SOA-P 5.1.0.ER2 - quickstart's output in server's log:
...
15:44:22,936 INFO  [STDOUT] =========== Server Request: ====================================
15:44:22,936 INFO  [STDOUT] Message Payload:
15:44:22,937 INFO  [STDOUT]     [Request Payload!]
15:44:22,938 INFO  [STDOUT]     Headers:
15:44:22,972 INFO  [STDOUT]             host: localhost:9433
15:44:22,972 INFO  [STDOUT]             Method: POST
15:44:22,972 INFO  [STDOUT]             Path: /x/y
15:44:22,973 INFO  [STDOUT]             user-agent: Jakarta Commons-HttpClient/3.0.1
15:44:22,973 INFO  [STDOUT]             content-type: text/xml;charset=UTF-8
15:44:22,973 INFO  [STDOUT] ================================================================
15:44:23,040 INFO  [STDOUT] =========== Client Response: ===================================
15:44:23,040 INFO  [STDOUT] Message Payload:
15:44:23,040 INFO  [STDOUT]     [Http Response Payload!!]
15:44:23,085 INFO  [STDOUT] Http Response:
15:44:23,085 INFO  [STDOUT]     Code: 200
15:44:23,085 INFO  [STDOUT]     Length: 23
15:44:23,085 INFO  [STDOUT]     Encoding: ISO-8859-1
15:44:23,086 INFO  [STDOUT]     Headers:
15:44:23,086 INFO  [STDOUT]             Server: Apache-Coyote/1.1
15:44:23,086 INFO  [STDOUT]             ResponseCode: 200
15:44:23,086 INFO  [STDOUT]             ResponseCodeMessage: OK
15:44:23,086 INFO  [STDOUT]             remotingContentType: remotingContentTypeString
15:44:23,086 INFO  [STDOUT]             Content-Type: text/html
15:44:23,086 INFO  [STDOUT]             Content-Length: 23
15:44:23,086 INFO  [STDOUT]             Date: Wed, 13 Oct 2010 13:44:22 GMT
15:44:23,087 INFO  [STDOUT] ================================================================
...
Comment 1 Pavel Macik 2010-10-13 10:37:19 EDT
The issue is present even in all older SOA-P 5 versions.
Comment 2 Anne-Louise Tangring 2010-10-27 13:33:24 EDT
On Oct 19 we decided that Kevin would spend sometime investigating this.
Comment 3 tcunning 2011-07-08 14:33:43 EDT
Link: Added: This issue relates to JBESB-3627
Comment 4 Kevin Conner 2011-07-11 04:10:40 EDT
Link: Added: This issue duplicates SOA-2141
Comment 5 Kevin Conner 2011-07-11 04:13:26 EDT
This was chased up as part of the SOA-2141 investigation.
Comment 6 tcunning 2011-07-20 10:39:41 EDT
Resolving based on comments on SOA-2141.     This is the correct header behavior.    Talked to pmacik on irc and he agreed.
Comment 7 David Le Sage 2011-09-26 23:47:03 EDT
Release Notes Docs Status: Added: Not Required
Writer: Added: dlesage

Note You need to log in before you can comment on or make changes to this bug.